Have run update-grub2 and my other Linux-distros won't boot.

Bug #411705 reported by Dave Stroud on 2009-08-10
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
grub
Undecided
auto-obrtnik.mile
grub2 (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: grub2

I am running pclos on another partition, everything is correct as far I can see.I ran update-grub2 and it picks everything up correctly but when I boot it says no such partition.pclos is ext3 and kARMIC is ext4. Dont know if its a cause.

Colin Watson (cjwatson) wrote :

Please attach /boot/grub/grub.cfg from Ubuntu, and also the output of 'sudo parted -l' so that we can see what your partition layout looks like. If possible, identify for us on the 'sudo parted -l' output which partition contains PCLinuxOS.

Changed in grub2 (Ubuntu):
status: New → Incomplete
Dave Stroud (bigdavesr) wrote :

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "linux (on /dev/sda3)" {
 set root=(hd0,3)
 search --no-floppy --fs-uuid --set a41db825-e3ed-429f-bbfd-ea2db4a41ca1
 linux /boot/vmlinuz BOOT_IMAGE=linux root=UUID=a41db825-e3ed-429f-bbfd-ea2db4a41ca1 resume=UUID=399aa796-4e8c-463a-9b4b-69b6014b4c5d vga=791
 initrd (hd0,2)/boot/initrd.img
}
menuentry "linux-nonfb (on /dev/sda3)" {
 set root=(hd0,3)
 search --no-floppy --fs-uuid --set a41db825-e3ed-429f-bbfd-ea2db4a41ca1
 linux /boot/vmlinuz BOOT_IMAGE=linux-nonfb root=UUID=a41db825-e3ed-429f-bbfd-ea2db4a41ca1 resume=UUID=399aa796-4e8c-463a-9b4b-69b6014b4c5d
 initrd (hd0,2)/boot/initrd.img
}
menuentry "failsafe (on /dev/sda3)" {
 set root=(hd0,3)
 search --no-floppy --fs-uuid --set a41db825-e3ed-429f-bbfd-ea2db4a41ca1
 linux /boot/vmlinuz BOOT_IMAGE=failsafe root=UUID=a41db825-e3ed-429f-bbfd-ea2db4a41ca1 noapic failsafe acpi=off
 initrd (hd0,2)/boot/initrd.img : Model: ATA MAXTOR 6L040J2 (scsi)
Disk /dev/sda: 40.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 3 32.3kB 6284MB 6284MB primary ext3
 2 6284MB 40.0GB 33.7GB extended
 5 6284MB 17.3GB 11.0GB logical ext3
 6 17.3GB 26.7GB 9484MB logical ext4
 7 26.7GB 29.7GB 3002MB logical linux-swap(new)
 8 29.7GB 40.0GB 10.3GB logical ext4

Model: ATA Maxtor 83201A6 (scsi)
Disk /dev/sdb: 3209MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 32.3kB 3208MB 3208MB primary fat32 boot

root@bigdavesr:/home/bigdavesr# Hope this helps its shows everything is there. thanks

Colin Watson (cjwatson) wrote :

Thanks. The problem here is that the initrd line is wrong. One of the changes in GRUB 2 from GRUB Legacy is that it fixed what's now considered a design error: GRUB Legacy numbered partitions from 0, but GRUB 2 numbers them from 1. This means that you have "initrd (hd0,2)/boot/initrd.img" when it should be "initrd (hd0,3)/boot/initrd.img".

Actually it's rather unusual to have a partition here at all; just "initrd /boot/initrd.img" would be fine, I'm sure. I'll leave this bug as Confirmed rather than Triaged until we figure out whether this would best be fixed in grub2 or in os-prober.

Changed in grub2 (Ubuntu):
importance: Undecided → High
status: Incomplete → Confirmed
Dave Stroud (bigdavesr) wrote :

Thanks for your prompt response. How do you work aroud this.Grub legacy allowed you to edit menue first but grub 2 will not allow you to edit grub cnf.

A workaround might be to edit PCLinuxOS's grub menu.lst file to remove
the pointless (hd0,2) from the initrd line. There's no particularly
straightforward Ubuntu-side workaround for this yet unfortunately.

I may have run into the same or a similar bug - After installing Karmic in a new partition, I can no longer boot Jaunty. I have described this in http://ubuntuforums.org/showthread.php?t=1284332 and will attach relevant legacy and grub2 config files below.

hbarta@cypress:~$ sudo parted -l
[sudo] password for hbarta:
Model: ATA WDC WD5000BEVT-2 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 1049kB 1574MB 1573MB primary ntfs boot
 2 1579MB 53.1GB 51.5GB primary ntfs
 3 53.1GB 63.6GB 10.5GB primary ntfs
 4 63.6GB 500GB 437GB extended
 5 63.6GB 64.6GB 1045MB logical ext3
 6 64.6GB 85.6GB 20.9GB logical ext3
 9 85.6GB 96.1GB 10.5GB logical ext4
 7 96.1GB 100GB 4096MB logical linux-swap(v1)
 8 100GB 500GB 400GB logical ext3

hbarta@cypress:~$

Hmmm. Only one attachment, I'll post again to add the legacy grub config.

HankB (hbarta) wrote :

Follow-up to previous post with legacy grub menu.lst

HankB (hbarta) wrote :

I have confirmed that grub-pc did not recognize usage of the /boot partition for the "other" Linux install. I was able to boot my Jaunty install after changing the UUID in the search option and modifying the kernel and initial RAM disk file names to be relative to /boot:
102,104c102,104
< search --no-floppy --fs-uuid --set 9bdeb391-8fd9-48b1-9316-c4a00b7fa7a2
< linux /vmlinuz-2.6.28-15-generic root=UUID=7f69072f-cea2-4ec3-bde9-81dd16744034 ro quiet splash
< initrd /initrd.img-2.6.28-15-generic
---
> search --no-floppy --fs-uuid --set 7f69072f-cea2-4ec3-bde9-81dd16744034
> linux /boot/vmlinuz-2.6.28-15-generic root=UUID=7f69072f-cea2-4ec3-bde9-81dd16744034 ro quiet splash
> initrd /boot/initrd.img-2.6.28-15-generic

Following this, I installed grub-pc on Jaunty and after manually running update-grub, I note that it found Karmic but did not include a separate search line for that. I'm not sure it will boot Karmic using this because I do not know if it requires the search line for those entries. (Jaunty grub.cfg is attached.) If it uses the search specified for Jaunty (points to separate /boot partition) it will not find the Karmic kernel and initrd.

Bruce Miller (brm0423) wrote :

I am running Kubuntu Karmic beta, fully upgraded twice a day.

bruce@Xenophon:~$ uname -a
Linux Xenophon 2.6.31-13-generic #45-Ubuntu SMP Tue Oct 13 02:07:24 UTC 2009 x86_64 GNU/Linux
bruce@Xenophon:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu karmic (development branch)
Release: 9.10
Codename: karmic
bruce@Xenophon:~$

I am unable to boot into the other Ubuntu installation on my system --- which is the 8.04 LTS version. Grub2 throws the message:
error - you need to load the kernel first.

The grub.cfg file is attached.

summary: - have run udate-grub2 and my other linux wont boot
+ Have run update-grub2 and my other Linux-distros won't boot.
bert07 (marien.bert) wrote :

Also see bug#533032.

bert07 (marien.bert) wrote :

Running Lucid RC.
In my opinion: this needs a fix rather fast! Otherwise other distributions shall keep failing to load.

bert07 (marien.bert) wrote :

I fixed my problem by fixing the menu.lst files from Mandriva and PCLinuxOS.
I ran update-grub afterwards, and now everything just works.

bsalem (bruce-euphon) wrote :

Has this been seen in U 10.10 with latest kernel upgrades? I have an open question, 141576, in which
I had a grub boot menu that was destroyed, that is, replaced by one that only boots the U 10.10 install,
not Vista, not U 9.10 in Wubi, and not a separate U 9.04 install. Now the system only boots /dev/sda3,
not /devsda1 or /dev/sda7 where the other OSs live. I have not received a resolution in that question thread
which contains all the info from the boot check script and attempts to run grub-update.

bsalem (bruce-euphon) wrote :

sorry, I meant update-grub. See that question thread for details.

Dave Stroud (bigdavesr) wrote :

Has anything been done on this. It is still a problem on 11.04 and 11.10.Even though I know how to work around it, its still a nuisance . Thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

  • auto-obrtnik.mile Edit

Bug watches keep track of this bug in other bug trackers.