stage1 file doesn't exist

Bug #617284 reported by marco.pallotta on 2010-08-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub2

In my 10.04 installation I tried to test RAID 1 software functionalities. After I removed one of my two disks (I made tests in a virtual box machine) I "inserted" a new one and then a synchronized my raid partitions. All went ok but I obtained an error when I tried to install grub on the new replaced disk, after having installed grub package. In particular I typed:

$ grub
 > device (hd0) /dev/sda
 > root (hd0,0)
root /hd0,0)
> setup (hd0)
setup (hd0)
Checking if "/boot/grub/stage1" exists... no
Checking if "/grub/stage1" exists... no

Error 15: File not found

My root partition is installed in metadevice /dev/md0 built upon /dev/sda1 and /dev/sdb1.

From bug #585742 you can read that you cannot use the command
$ grub-install /dev/md0
so there is no way to re-install grub in this scenario.

Tested with Ubuntu 10.04 desktop edition and grub 0.97-29ubuntu60

Colin Watson (cjwatson) wrote :

You seem to be using GRUB Legacy here, not GRUB 2. I suggest giving GRUB 2 a try instead (it's in the grub-pc package).

affects: grub2 (Ubuntu) → grub (Ubuntu)
marco.pallotta (marco-pallotta) wrote :

The workaround for this issue is to install grub directly on device and not on raid metadevice
For example.

grub-install --no-floppy /dev/sdb (in the example of my bug report description)

works ok.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers