grub error 24 with Jaunty beta

Bug #353071 reported by Ralf Naujokat on 2009-04-01
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Undecided
Unassigned

Bug Description

Hi all.

I got grub
  Error 24: Attempt to access block outside partition
on two different machines now.
Both machines are running jaunty on ext4 file systems.
Both machines were dist-upgraded from intrepid on ext3.
Booting from Live CD and fsck gave no errors on the ext4 partitions.

On one machine i installed a new jaunty in a new ext3 partition,
after that the new boot menu had an entry for the previous non working
jaunty-ext4 installation. I can start that 'old' version now.
So the reinstalling of grub might be a solution.
I am trying to reinstall grub on the second machine now.
I keep you informed.

Sorry, i don't have no further information, but i found similar messages
from other users

greetings
  Ralf

Forgot to say,
both are 64bit desktop versions of Jaunty beta.

Ok. After some google i found that:
http://mapopa.blogspot.com/2009/01/grub-voodoo-error-no-1324-and-how-do-i.html
I followed his method and the problem was solved.

Short summary:
- Boot with Live CD (i used USB-boot)
- open a terminal and do

$ sudo su
# mount /dev/sda1 /mnt
# mount --bind /dev /mnt/dev
# mount --bind /dev/pts /mnt/dev/pts
# mount --bind /dev/shm /mnt/dev/shm
# mount -t proc none /mnt/proc
# mount -t sysfs none /mnt/sys
# chroot /mnt /bin/bash ; this step was missing
# grub-install /dev/sda --root-directory=/ --recheck

My partition was /dev/sda4, but that should make no difference.

After that everything was fine again.

greetings
  Ralf

I am checking out the differences between /boot/grub and a copy that i made.
I found, that there is a new e2fs_stage1_5 and stage2
and the installed-version changed from 0.97-29ubuntu45 to 0.97-29ubuntu51.

Is this a symptom of that 'ext4 bug'?
like: Some changes did not get sync'ed on updating grub files to a new version?
Or just a broken update?

greetings
  Ralf

Nick B. (futurepilot) wrote :

I've seen this as well on 2 different machines. Both were upgraded to Jaunty from Intrepid/Ext3 and then converted to Ext4. I also came across the above workaround by reinstalling Grub and that worked. It seems to me it's something that goes wrong when converting Ext3 to Ext4 as I haven't seen this with fresh installs with Ext4. I've set up a VM with Jaunty/Ext3 that I then converted to Ext4 to see if I can reproduce this again.

I did not get the error immediate after upgrading,
for some days i could work without problems.
The error occured on reboot after an apt-get upgrade.

greetings
  Ralf

tags: added: grub jaunty
tags: added: ext4
UnSandpiper (aybora) wrote :

Have experienced the same problem here.
Upgraded from 8.10 to 9.04 beta (32bit), converted to ext4 and reinstalled grub as instructed.

Couple of days everything was fine. After updating yesterday though, I got the grub 24 error when booting the next time.

Traditional way of booting with the live cd and using grub to reinstall failed.
Then used the procedure described by Ralf above to reinstall using live cd and grub-install and now I can boot again.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Ralf Naujokat wrote:
> I did not get the error immediate after upgrading,
> for some days i could work without problems.
> The error occured on reboot after an apt-get upgrade.
>
> greetings
> Ralf
>
It didn't happen immediately for me either. After I converted the
filesystem it worked fine for a about a day through numerous reboots
and then out of no where it just threw Error 24.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAknUaUcACgkQAGHzB9Tvw4zMnACfVoyuW0Yhv5azMAEVFeFVzKyG
DCcAn3ItCxM7ZcIIh1V+cZsgKpx9OUZ3
=ErtE
-----END PGP SIGNATURE-----

I just discovered, that a third pc with updated intrepid/ext3 to jaunty/ext4
had a grub installed-version with 0.97-29ubuntu36 until now, even after the
last update/upgrade. Before the next reboot, i did a
$ sudo grub-install /dev/sda --root-directory=/ --recheck
Now the installed-version contains 0.97-29ubuntu51.
I will try a reboot now. ;-)

Hi all!

Back again, everything is fine.
Might be, problem is an outdated grub when using ext4.

greetings
  Ralf

Nick B. (futurepilot) wrote :

I'm going to change this to Grub as it seems something isn't getting updated correctly with Grub. I can't seem to reproduce this with a fresh Jaunty/Ext3 install and then converting it. It seems to be strictly when upgrading from Intrepid to Jaunty then converting it to Ext4. I'm guessing there's something from Intrepid's version of Grub which doesn't support Ext4 still lying around somewhere and then it freaks out when it sees Ext4.

affects: ubuntu → grub (Ubuntu)
Nick B. (futurepilot) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Maybe this isn't a bug. I just noticed here
http://www.ubuntu.com/testing/jaunty/beta that it says

"Ext4 support in GRUB was provided by Colin King. If you choose to
upgrade your / or /boot filesystem in place from ext2 or ext3 to ext4
(as documented on the ext4 wiki
<http://ext4.wiki.kernel.org/index.php/Ext4_Howto#Converting_an_ext3_filesystem_to_ext4>),
*then you /must/ also use the grub-install command after upgrading to
Ubuntu 9.04 Beta to reinstall your boot loader. If you do not do this,
then the version of GRUB installed in your boot sector will not be
able to read the kernel from the ext4 filesystem and your system will
fail to boot.*"

What's odd is that it actually worked for a short period of time
without actually reinstalling Grub. I think what is confusing is that
people probably don't know that you need to reinstall Grub after
converting the file system as it's not really documented anywhere.
This is the first source that I've seen that says you need to
reinstall Grub afterwards.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAknZNckACgkQAGHzB9Tvw4wd1ACeP3a4U+aSAcfcYEQqZ9IAeaPL
hOUAnAz3ZlNJS1KtUqei6sPgPTdu99rx
=Gy8M
-----END PGP SIGNATURE-----

Hi,

> Maybe this isn't a bug. I just noticed here
> http://www.ubuntu.com/testing/jaunty/beta that it says

Seems you are right.

> http://ext4.wiki.kernel.org/index.php/Ext4_Howto#Converting_an_ext3_filesystem_to_ext4

May be it would be clever, to mention it right here, too.
Can someone do it or talk to the right people? It's a closed wiki.

I did not read the notice on the ubunto page, because google
took me to the kernel.org page when i was searching
for 'ext3 ext4 howto' or something.

Albert Vernon (d26pz8v02) wrote :

I received this error in the released version (not beta) of Jaunty. I upgraded from ext3 on Intrepid 64-bit to ext4 on Jaunty. I used the same instructions mentioned in comment #12 including grub-install at the end. Everything worked fine for several days, including reboots, until running apt-get upgrade on 2009-04-27. My software sources are set to include jaunty-proposed and jaunty-backports.

I can confirm that Ralf's instructions in comment #2 fixed the problem for me.

Matt Zimmerman (mdz) wrote :

This error is a result of using an old version of GRUB which does not understand ext4. If you convert your root filesystem to ext4, you must run grub-install with the latest version of grub (available in Ubuntu 9.04).

I've updated the Ext4_Howto on the ext4 wiki to include a note about this.

Changed in grub (Ubuntu):
status: New → Invalid
MFeif (matt-feifarek) wrote :

I am seeing this problem on a clean install of Jaunty -- no upgrade; root filesystem set to ext4.

I am also seeing this problem with a clean install of 9.04 / Jaunty.

The filesystem is (and always has been) ext3.

The problem only occurs with kernels 2.6.28-16 and onwards: I find I can boot successfully using 2.6.26-15 and earlier.

Changed in grub (Ubuntu):
status: Invalid → Incomplete
Steve Langasek (vorlon) wrote :

> The filesystem is (and always has been) ext3.

Then you have a different bug than the original submitter. Please file a separate bug report.

Changed in grub (Ubuntu):
status: Incomplete → Invalid

I add this information in case it is useful to anyone: the latest 9.04 update to kernel 2.6.28-19 has fixed it for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers