No second os showing up in d-i auto resize

Bug #456776 reported by Dave Morley on 2009-10-20
26
This bug affects 7 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
High
Colin Watson
Karmic
High
Colin Watson

Bug Description

Binary package hint: os-prober

I've started a new bug here incase it's not the obvious suspects again.

No second os showing up in grub's menu. Although it is pausing again like there should be.

ProblemType: Bug
Architecture: i386
Date: Tue Oct 20 23:35:26 2009
DistroRelease: Ubuntu 9.10
Package: os-prober 1.35
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: os-prober
Uname: Linux 2.6.31-14-generic i686
XsessionErrors:
 (gnome-settings-daemon:1623): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1623): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:1698): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:1684): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Jevgenijs Murans (drakonich) wrote :

Same with Alternate amd64 manual install

Ronald McCollam (fader) wrote :

This might also be a duplicate of bug 453588.

Changed in os-prober (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) wrote :

I think this is unrelated to bug 453588. The reporter of that bug says that it was fixed by a firmware update, which suggests to me that it was the consequence of some disk driver problem. That won't be the case here as Dave is testing with up-to-date packages.

Colin Watson (cjwatson) on 2009-10-21
affects: os-prober (Ubuntu Karmic) → grub-installer (Ubuntu Karmic)
Changed in grub-installer (Ubuntu Karmic):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
milestone: none → ubuntu-9.10
status: Confirmed → In Progress
Colin Watson (cjwatson) on 2009-10-21
Changed in grub-installer (Ubuntu Karmic):
status: In Progress → Fix Committed
Jevgenijs Murans (drakonich) wrote :

command sudo apt-get install grub2 solved that problem.
Just installed grub2 and rebooted.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub-installer - 1.43ubuntu7

---------------
grub-installer (1.43ubuntu7) karmic; urgency=low

  * Mount /target/sys when running update-grub (LP: #456776).

 -- Colin Watson <email address hidden> Wed, 21 Oct 2009 14:08:00 +0100

Changed in grub-installer (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in grub-installer (Ubuntu Karmic):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
tags: added: iso-testing

I need to see what the impact is on LP: #604335
At the very least I may need to roll this up with
https://launchpad.net/~nutznboltz/+archive/working-grub2-on-virtio-disk-for-lts

Oh, this is for grub1 not grub2

Ah, my issue is really Bug #692691

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers