Ubuntu

sometimes tries to edit menu.lst even with GRUB 2

Reported by Charlie Kravetz on 2009-06-11
94
This bug affects 12 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
High
Unassigned
Karmic
High
Unassigned

Bug Description

Binary package hint: ubiquity

RELEASE: Karmic Koala Alpha2 pre-release
CD/DVD VARIANT: 32bit Xubuntu desktop cd
ISO BUILD: 20090611
SYMPTOMS: Installing from livecd desktop icon; crashed at "install GRUB"
Apport also crashed, thus filing this using :
"sudo /usr/share/apport/apport-gtk --crash-file=/var/crash/_usr_lib_ubiquity_bin_ubiquity.0.crash" from command line
Also attaching /var/log/installer/debug and /var/log/installer/version

ProblemType: Crash
Architecture: i386
Date: Thu Jun 11 16:02:15 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.6
LiveMediaBuild: Xubuntu 9.10 "Karmic Koala" - Alpha i386 (20090611)
Package: ubiquity 1.13.3
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/7674/environ'
ProcVersionSignature: Ubuntu 2.6.30-8.9-generic
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
SourcePackage: ubiquity
Title: ubiquity crashed with InstallStepError in configure_bootloader()
Uname: Linux 2.6.30-8-generic i686
UserGroups:

visibility: private → public
tags: removed: need-duplicate-check
Colin Watson (cjwatson) wrote :

This happens if (a) you ask to use a GRUB password (which GRUB 2 doesn't support yet anyway) or (b) other operating systems are installed. In Charlie's case I think (b) is happening.

affects: ubiquity (Ubuntu) → grub-installer (Ubuntu)
Changed in grub-installer (Ubuntu):
importance: Undecided → High
milestone: none → karmic-alpha-3
status: New → Triaged
summary: - ubiquity crashed with InstallStepError in configure_bootloader()
+ sometimes tries to edit menu.lst even with GRUB 2
Colin Watson (cjwatson) wrote :

The problem is that our code to show the menu by default and raise the timeout hasn't been adapted to GRUB 2 yet. (Actually GRUB 2 does that by default so we probably need to do the inverse.)

Colin Watson (cjwatson) wrote :

My comment about this happening if you try to use a GRUB password was wrong; grub-installer is careful to only offer this for GRUB Legacy. That leaves (b).

That would be correct. I had another install of karmic on a 2nd hard drive. Even though I did tell it to use the entire drive, I did not erase the 2nd drive.

Steve Beattie (sbeattie) wrote :

Yes, that's also the situation that occurred with duplicate bug 386062, the disk image had a previous install of intrepid/kubuntu that was resized.

vaibhav mishra (vinu76jsr) wrote :

I have A Vista installed in a drive and I am attemting a install, although I am now going to use Vista for a fair amount of time in near future , I still want to know , is it make Vista not usable(fine - with - me) or also made current 9.10 entry un-bootable

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub-installer - 1.37ubuntu3

---------------
grub-installer (1.37ubuntu3) karmic; urgency=low

  * If using GRUB 2, don't try to edit menu.lst to change the timeout (LP:
    #385995). We need to do something with the GRUB 2 timeout, but this is
    blocked on settling on a way for grub-installer to adjust GRUB 2
    configuration in general.

 -- Colin Watson <email address hidden> Fri, 12 Jun 2009 13:35:20 +0100

Changed in grub-installer (Ubuntu Karmic):
status: Triaged → Fix Released
Colin Watson (cjwatson) wrote :

vaibhav mishra: Your installation of Vista will be unaffected itself, although GRUB won't be configured to be able to boot it so you may have to reinstall the Vista boot loader. There's an install-time workaround in the Alpha 2 release notes; if this is too complex for you, you can wait until Alpha 3 when this will be fixed.

Conn O Griofa (psyke83) wrote :

I tried to perform an install of Karmic Alpha 2 with the desktop i386 CD and suffered from this bug, and using the boot-time option "grub-installer/grub2_instead_of_grub_legacy=false" listed in the release notes did not work, unfortunately. I have a dual-boot configuration with Windows 7 RC on my Inspiron 510m laptop.

If any users are reading this a) who cannot install via the instructions listed in the Alpha 2 release notes, and b) do not wish to wait until alpha 3, there is a way to get it working:

When you login to the live environment, open a terminal and perform the following steps:
$ sudo apt-get update; sudo apt-get install ubiquity ubiquity-frontend-gtk ubiquity-ubuntu-artwork

This will upgrade the ubiquity installer to the fixed version within your live environment. You can now run the installer and it should hopefully complete GRUB2 installation for dual-boot systems successfully.

manishmahabir (manishmahabir) wrote :

I downloaded the daily build on 16th....ran an update in the live environment....then installed alongside my vista.
There is an entry in the grub menu for vista but on selecting it, it says bootmgr missing.
it was allright when jaunty was installed.
is there anyway to boot into vista successfully from grub itself?

Dragomir Minkovski (dejuren) wrote :

The bug is not fixed in Alpha 3 alternate install, but workaround with boot-time option "grub-installer/grub2_instead_of_grub_legacy=false" works. The reason I have it is a second OS on the HDD.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers