Failed to install Xenial in UEFI mode, failed with "grub-efi-amd64-signed package failed to install into /target/"

Bug #1521132 reported by Po-Hsu Lin on 2015-11-30
170
This bug affects 35 people
Affects Status Importance Assigned to Milestone
grub-installer
Fix Released
Unknown
grub-installer (Ubuntu)
Critical
Unassigned
Nominated for Xenial by Alberto Salvia Novella

Bug Description

With Xenial dailylive image (Nov. 29), installation in UEFI mode failed with the following error message:
The 'grub-efi-amd64-signed' package failed to install into /target/.
Without GRUB boot loader, the installed system will not boot.

After press OK, it will report that the installer has crashed, and open this bug report.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubiquity 2.21.38
ProcVersionSignature: Ubuntu 4.2.0-19.23-generic 4.2.6
Uname: Linux 4.2.0-19-generic x86_64
ApportVersion: 2.19.2-0ubuntu8
Architecture: amd64
CasperVersion: 1.366
Date: Mon Nov 30 05:34:56 2015
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash ---
LiveMediaBuild: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151129)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: grub-installer
UpgradeStatus: No upgrade log present (probably fresh install)

Po-Hsu Lin (cypressyew) wrote :
Phillip Susi (psusi) wrote :

It looks like you may have caught the mirrors in the middle of a grub transition and they hadn't fully synced up yet. Can you try again?

Changed in grub-installer (Ubuntu):
status: New → Incomplete
Po-Hsu Lin (cypressyew) wrote :

Hi,
thanks for your comment, I just tried 11/30 and 12/1 dailylive, this issue still exist.
Thanks

Changed in grub-installer (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub-installer (Ubuntu):
status: New → Confirmed
Changed in grub-installer (Ubuntu):
importance: Undecided → Critical

Please:

1. Report to <http://bugs.debian.org/>.
2. Paste the new report link here.
3. Set this bug status back to "confirmed".

Thank you.

Changed in grub-installer (Ubuntu):
status: Confirmed → Incomplete
Po-Hsu Lin (cypressyew) wrote :

Hi Alberto,
I just checked again with Dec. 9 dailylive image [1], I can finish the installation successfully on a Dell Latitude E5250.
It will be great if someone can double check this, and we can close this bug.
Thanks!

[1] 093395640aec16b8e0b1168ea6a23e87 *xenial-desktop-amd64.iso

Po-Hsu Lin (cypressyew) wrote :

I spoke too fast,
it can finish the installation because there is already an Ubuntu installed with Legacy mode, and I choose to install the Xenial alongside with it in UEFI mode. After it finished, I can't boot with UEFI mode.

Anyway, bug reported Debian can be found here:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=809788

Thanks

Changed in grub-installer (Ubuntu):
status: Incomplete → Confirmed

Thanks.

Changed in grub-installer:
importance: Undecided → Unknown
status: New → Unknown
Changed in grub-installer (Ubuntu):
status: Confirmed → Triaged

Answer in Debian report:

The package is a Ubuntu version, and does not even exist in Debian.
The -signed package is probably secureboot related, which as far as I
know Debian has no support for at this time.

And of course in BIOS mode secureboot does not apply and non efi grub
is used, so it is very very different.

So the bug report to Ubuntu makes sense, while the one to Debian does
not since there is no such package.

--
Len Sorensen

Changed in grub-installer:
status: Unknown → Fix Released
Franklin (franklin-goodhorse) wrote :

If installing without internet connected, grub-efi-amd64-signed will fail to install.

Franklin (franklin-goodhorse) wrote :

The problem seemed to be that, when chrooting into /target without any internet connected, the cdrom repository failed to update and hence couldn't find grub-efi-amd64-signed.

Please see the pastbin:

http://pastebin.com/ghWYjJmt

In the live environment it could find, but failed to find it in /target.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1521132

tags: added: iso-testing
Otus (jan-varho) wrote :

Same error here with the beta2 image. Also, the warning message about efi/legacy things claimed I was installing debian.

Brett Bogert (bbogert24) wrote :

I am also seeing this with the beta2 image.

Non-UEFI installs work fine but any attempt to install with UEFI fails with the reported error:

The 'grub-efi-amd64-signed' package failed to install into /target/.
Without GRUB boot loader, the installed system will not boot.

I have tried installing to a completely naked SSD (e.g. no partitons created before install)
and was connected to the internet during the install so EFI partition corruption and not
being connected to the internet don't seem to be the issue.

Just did a clean install of Xenial release and it happens to me as well.
Installing on XFS on /
with existing /home on XFS
in UEFI mode.

Tom Westerfield (twesterfield) wrote :

This appears to be the same thing I reported in #1572828, which should probably be marked a duplicate of this.

Jaroslav Pekar (jaroslav222) wrote :

I've probably created duplicate #1573722 unaware of this bug inside the installation process. I've also found workaround (in the comments).

Taleman (tapio-lehtonen) wrote :

Tried to install Trusty Tahr 14.04, image downloaded today. Same error on Acer Aspire E1-530G. So it is not regression
that 16.04 fails to install on this computer, it was broken already in 14.04.

Saji Nediyanchath (saji89) wrote :

The bug #1573409 ( https://bugs.launchpad.net/ubuntu/+source/grub-installer/+bug/1573409 ) that I have reported, might be a duplicate of this, but I have added me detailed research and experience of the issue, and its aftermath, with some relevant images, under that bug.

Saji Nediyanchath (saji89) wrote :

This bug has been commented to be in an Ubuntu specific package, so it seems that this bug report on Debian should be removed.

Phillip Susi (psusi) wrote :

Po-Hsu, can you attach an updated /var/log/syslog and /var/log/partman after getting this failure again? Everyone else commenting on this bug appears to simply be trying to install in EFI mode to a disk that is not partitioned for EFI and ignored the warning that they should switch back to bios mode, and so are not experiencing the same thing as Po-Hsu.

Changed in grub-installer (Ubuntu):
status: Triaged → Incomplete
Po-Hsu Lin (cypressyew) wrote :

Will do, since this bug was reported against the dailylive image date back to Nov. 29, I will re-test it with the new release image again.

Christoph Olszowka (colszowka) wrote :

This has also happened for me, unfortunately using the final 16.04 desktop release. Also, it didn't only fail to install the OS, but also broke my previously working dual-boot (windows/ubuntu gnome) grub install, leaving me with a grub rescue prompt on boot.

I also tried installing Ubuntu Gnome Xenial (same error), and disabling software package downloads during install (to avoid running into a mirroring/inconsistent packages glitch) - I keep getting this message.

I also noticed two things about the installer though (in German):

On the first screen, the installer prompts you to install "$(RELEASE)" (sic), there seems a string replacement to be missing there. Also, when asked for the desired computer hostname, it says "-ToBeFilledByOEM" - to me this seems to be really obvious stuff that shouldn't have made it into a final LTS release distro?

ArminiusTux (varus-ubuntus-9) wrote :

Ubuntu Studio 16.04 LTS (final xenial) is also affected.

The nasty message appears quite late (latter third) in the installation.
Due to other bugs (USB and LAN failure) grub package can not be updated and the whole installation fails and does not boot.

Manual partitions on a OCZ Trion100 240GB SSD:

sdc1 EFI (/boot/efi) 0.5GB
sdc2 ext4 (/) 235GB
sdc3 swap 4.5GB

Using an AMD System with a Gigabyte GA-990FXA-UD5 Mobo with EFI enabled (turning it off has no altering effect though).

Po-Hsu Lin (cypressyew) wrote :

Hello Phillip,
I tried to install 16.04 on two different Dell Latitude E5250, I can't reproduce this issue now, they will all finish the installation in EFI mode and ask me to reboot. (Although I got some "No bootable devices found." issue in EFI mode, but at least I didn't see that grub-efi-amd64-signed' package failed to install issue anymore)

Thanks.

Phillip Susi (psusi) wrote :

Thanks for letting us know.

Changed in grub-installer (Ubuntu):
status: Incomplete → Invalid
ArminiusTux (varus-ubuntus-9) wrote :

After applying a workaround to get rid of https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1574869 the installation of Ubuntu Studio went through flawlessly (EFI secureboot PW type install) - so the error is gone on my system as well.

Zaki Chowdhury (z4ki) on 2016-07-22
Changed in grub-installer (Ubuntu):
status: Invalid → Confirmed
Changed in grub-installer (Ubuntu):
status: Confirmed → Triaged
Phillip Susi (psusi) wrote :

Please don't reopen bugs without a reason.

Changed in grub-installer (Ubuntu):
status: Triaged → Invalid
Swaraj Mohapatra (linuxode) wrote :

I do not know if it is too late now, but I found a solution (http://askubuntu.com/a/790003/242381) that solved my problem. Worked for Ubuntu 16.04.

I have spent two days stuck. didn't realise it was a bug. I have tried 28 installs of Lubuntu using various parameters. I might have to install something kde . . . . right?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.