Server Installer fails at 'grub install dummy' in EFI mode

Bug #1054323 reported by Kent Baxley on 2012-09-21
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
High
Colin Watson
Quantal
High
Colin Watson

Bug Description

Release: Ubuntu 12.10 Server amd64 Edition, September 21st daily build

grub2-common_2.00-5ubuntu3_amd64.deb
grub-efi-amd64-bin amd64 2.00-5ubuntu3 [746 kB]
grub-efi-amd64 amd64 2.00-5ubuntu3
grub-efi amd64 2.00-5ubuntu3
grub-installer 1.78ubuntu2

The 12.10 server installer crashes at what appears to be the grub-install phase on PowerEdge hardware running in EFI mode. This is seen on both 11G and 12G systems.

Steps to Reproduce:

1) Kick off an installation of 64-bit Ubuntu 12.10 server in EFI mode

2) Follow all the installation steps and prompts.

Actual Results:

At the grub-install phase, the system attempts to install the bootloader, but, fails to do so claiming that "grub install dummy" has failed.

Expected Results:

grub installation completes along with the rest of the server OS.

Non-EFI installations work fine.

Kent Baxley (kentb) wrote :

syslog attached from a recent failure. This was repeatable on PowerEdge T410, M915, R820, and R815 systems.

affects: ubiquity (Ubuntu) → grub-installer (Ubuntu)
Kent Baxley (kentb) wrote :
Brian Murray (brian-murray) wrote :

Here is the full error:

Sep 21 15:29:52 grub-installer: info: Installing grub on 'dummy'
Sep 21 15:29:52 grub-installer: info: grub-install does not support --no-floppy
Sep 21 15:29:52 grub-installer: info: Running chroot /target grub-install --force
Sep 21 15:29:53 grub-installer: source_dir doesn't exist. Please specify --target or --directory
Sep 21 15:29:53 grub-installer: error: Running 'grub-install --force failed.

tags: added: quantal
Changed in grub-installer (Ubuntu):
importance: Undecided → High

I'm also able to confirm that the same behavior occurs in a VM (under VMware Workstation) running in UEFI mode, so the behavior is not limited to PowerEdge. I can manually install grub by switching to the command line, but the installer will not find where to install grub.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub-installer (Ubuntu):
status: New → Confirmed

For reference, here's my work-around. After I get the error, I switch to vt2. I run:

mount -o bind /sys /target/sys
chroot /target bash
grub-install /dev/sda
update-grub
exit

Then I select the option to continue without installing a bootloader. The installed system comes up fine.

Kent Baxley (kentb) on 2012-09-24
summary: - Installer fails at 'grub install dummy' on PowerEdge Hardware in EFI
- mode
+ Installer fails at 'grub install dummy' in EFI mode
Kent Baxley (kentb) on 2012-09-24
summary: - Installer fails at 'grub install dummy' in EFI mode
+ Server Installer fails at 'grub install dummy' in EFI mode
Colin Watson (cjwatson) wrote :

Looks like a regression in 1.78ubuntu1. /sys is no longer bind-mounted.

Changed in grub-installer (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
status: Confirmed → In Progress
Colin Watson (cjwatson) wrote :

Ah. Actually, the bug was always (for some value of ...) present in grub-installer, but a change in GRUB 2.00 triggered it.

Colin Watson (cjwatson) on 2012-09-24
Changed in grub-installer (Ubuntu Quantal):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub-installer - 1.78ubuntu3

---------------
grub-installer (1.78ubuntu3) quantal; urgency=low

  * Fix incorrect test for whether to bind-mount /sys (LP: #1054323).
 -- Colin Watson <email address hidden> Mon, 24 Sep 2012 21:37:10 +0100

Changed in grub-installer (Ubuntu Quantal):
status: Fix Committed → Fix Released
Olaf Seibert (oseibert-sys11) wrote :

Can it be that this problem has come back in focal? I get a very similar problem, and the sys file system does not seem to be mounted in /target.

Olaf Seibert (oseibert-sys11) wrote :

May 26 11:51:56 grub-installer: info: Running chroot /target grub-install --force "dummy"
May 26 11:51:56 grub-installer: Installing for x86_64-efi platform.
May 26 11:51:57 grub-installer: File descriptor 3 (pipe:[37905]) leaked on vgs invocation. Parent PID 3610: grub-install
May 26 11:51:57 grub-installer: File descriptor 4 (/dev/ttyS1) leaked on vgs invocation. Parent PID 3610: grub-install
May 26 11:51:57 grub-installer: File descriptor 5 (/dev/ttyS1) leaked on vgs invocation. Parent PID 3610: grub-install
May 26 11:51:57 grub-installer: File descriptor 6 (/dev/ttyS1) leaked on vgs invocation. Parent PID 3610: grub-install
May 26 11:51:57 grub-installer: File descriptor 8 (/dev/sdb1) leaked on vgs invocation. Parent PID 3610: grub-install
May 26 11:51:57 grub-installer: File descriptor 3 (pipe:[37905]) leaked on vgs invocation. Parent PID 3610: grub-install
May 26 11:51:57 grub-installer: File descriptor 4 (/dev/ttyS1) leaked on vgs invocation. Parent PID 3610: grub-install
May 26 11:51:57 grub-installer: File descriptor 5 (/dev/ttyS1) leaked on vgs invocation. Parent PID 3610: grub-install
May 26 11:51:57 grub-installer: File descriptor 6 (/dev/ttyS1) leaked on vgs invocation. Parent PID 3610: grub-install
May 26 11:51:57 grub-installer: File descriptor 8 (/dev/sdb1) leaked on vgs invocation. Parent PID 3610: grub-install
May 26 11:51:57 grub-installer: grub-install: warning: Cannot read EFI Boot* variables.
May 26 11:51:57 grub-installer: grub-install: warning: read_file: could not read from file: Input/output error.
May 26 11:51:57 grub-installer: grub-install: warning: vars_get_variable: read_file(/sys/firmware/efi/vars/Boot0001-8be4df61-93ca-11d2-aa0d-00e098032b8c/raw_var) failed: Input/output error.
May 26 11:51:57 grub-installer: grub-install: warning: efi_get_variable: ops->get_variable failed: Input/output error.
May 26 11:51:57 grub-installer: grub-install: error: failed to register the EFI boot entry: Input/output error.
May 26 11:51:57 grub-installer: error: Running 'grub-install --force "dummy"' failed.
May 26 11:51:57 debconf: --> SUBST grub-installer/grub-install-failed BOOTDEV dummy
May 26 11:51:57 debconf: Adding [BOOTDEV] -> [dummy]
May 26 11:51:57 debconf: <-- 0
May 26 11:51:57 debconf: --> INPUT critical grub-installer/grub-install-failed

On the other hand, maybe the real problem is the Input/output errors on the EFI variables.

Is there some way to skip installing the boot loader? We boot from PXE anyway.

Colin Watson (cjwatson) wrote :

I recommend filing a new bug - it's probably a new cause with similar symptoms, and comments on long-closed bugs rarely get much attention.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments