Dependency on libbsf-java is invalid

Bug #239906 reported by Olivier Mengué
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
groovy (Debian)
New
Undecided
Unassigned
groovy (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Binary package hint: groovy

Bean Shell Framework is an alternative JVM based scripting language.
I don't see any reason why Groovy would depend on it.

Tags: patch
Revision history for this message
Olivier Mengué (dolmen) wrote :

In fact, the binary package 'groovy' should not have any dependency on any lib*-java not 'antlr' as those libs are all included directly in the groovy package. See the file list here: http://packages.ubuntu.com/hardy/all/groovy/filelist

It looks like the developer put the same dependencies for the binary package as for the source package and this is wrong.

Revision history for this message
Nathan Handler (nhandler) wrote :

groovy (1.5.6-1ubuntu1) intrepid; urgency=low

  * Remove unneeded dependencies (LP: #239906)
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Nathan Handler <email address hidden> Sun, 06 Jul 2008 22:37:21 -0500

Changed in groovy:
status: New → Confirmed
Revision history for this message
Onkar Shinde (onkarshinde) wrote :

In my opinion, you are fixing the problem in wrong way. We need to fix the package to not include the jar files from other libraries.

Revision history for this message
Luis Arias (kaaloo) wrote :
Download full text (5.5 KiB)

I don't believe the package is including jar files at all. The result of dpkg-deb -c on groovy_1.5.6-1 in intrepid show links to the libraries in /usr/share/java:

luis@trinity:~/dev/groovy$ dpkg-deb -c groovy_1.5.6-1_all.deb
drwxr-xr-x root/root 0 2008-05-12 07:17 ./
drwxr-xr-x root/root 0 2008-05-12 07:17 ./usr/
drwxr-xr-x root/root 0 2008-05-12 07:17 ./usr/share/
drwxr-xr-x root/root 0 2008-05-12 07:17 ./usr/share/doc/
drwxr-xr-x root/root 0 2008-05-12 07:17 ./usr/share/doc/groovy/
-rw-r--r-- root/root 3232 2008-05-12 07:16 ./usr/share/doc/groovy/README.Debian
-rw-r--r-- root/root 2223 2008-05-12 07:16 ./usr/share/doc/groovy/copyright
-rw-r--r-- root/root 1421 2008-05-12 07:16 ./usr/share/doc/groovy/changelog.Debian.gz
drwxr-xr-x root/root 0 2008-05-12 07:17 ./usr/share/man/
drwxr-xr-x root/root 0 2008-05-12 07:17 ./usr/share/man/man1/
-rw-r--r-- root/root 874 2008-05-12 07:17 ./usr/share/man/man1/groovy.1.gz
-rw-r--r-- root/root 451 2008-05-12 07:17 ./usr/share/man/man1/groovyc.1.gz
drwxr-xr-x root/root 0 2008-05-12 07:17 ./usr/share/groovy/
drwxr-xr-x root/root 0 2008-05-12 07:17 ./usr/share/groovy/bin/
-rwxr-xr-x root/root 759 2008-05-12 07:17 ./usr/share/groovy/bin/groovy
-rwxr-xr-x root/root 605 2008-05-12 07:17 ./usr/share/groovy/bin/groovyConsole
-rwxr-xr-x root/root 626 2008-05-12 07:17 ./usr/share/groovy/bin/groovyc
-rwxr-xr-x root/root 714 2008-05-12 07:17 ./usr/share/groovy/bin/groovysh
-rwxr-xr-x root/root 633 2008-05-12 07:17 ./usr/share/groovy/bin/java2groovy
-rwxr-xr-x root/root 8009 2008-05-12 07:17 ./usr/share/groovy/bin/startGroovy
drwxr-xr-x root/root 0 2008-05-12 07:17 ./usr/share/groovy/conf/
-rw-r--r-- root/root 892 2008-04-25 12:26 ./usr/share/groovy/conf/groovy-starter.conf
drwxr-xr-x root/root 0 2008-05-12 07:17 ./usr/share/groovy/lib/
-rw-r--r-- root/root 2304286 2008-05-12 07:17 ./usr/share/groovy/lib/groovy-1.5.6.jar
drwxr-xr-x root/root 0 2008-05-12 07:17 ./usr/share/java/
drwxr-xr-x root/root 0 2008-05-12 07:17 ./usr/bin/
lrwxrwxrwx root/root 0 2008-05-12 07:17 ./usr/share/man/man1/startGroovy.1.gz -> groovy.1.gz
lrwxrwxrwx root/root 0 2008-05-12 07:17 ./usr/share/man/man1/groovyConsole.1.gz -> groovy.1.gz
lrwxrwxrwx root/root 0 2008-05-12 07:17 ./usr/share/man/man1/java2groovy.1.gz -> groovy.1.gz
lrwxrwxrwx root/root 0 2008-05-12 07:17 ./usr/share/man/man1/groovysh.1.gz -> groovy.1.gz
lrwxrwxrwx root/root 0 2008-05-12 07:17 ./usr/share/groovy/lib/xpp3.jar -> ../../java/xpp3.jar
lrwxrwxrwx root/root 0 2008-05-12 07:17 ./usr/share/groovy/lib/xstream.jar -> ../../java/xstream.jar
lrwxrwxrwx root/root 0 2008-05-12 07:17 ./usr/share/groovy/lib/servlet-api.jar -> ../../java/servlet-api.jar
lrwxrwxrwx root/root 0 2008-05-12 07:17 ./usr/share/groovy/lib/regexp.jar -> ../../java/regexp.jar
lrwxrwxrwx root/root 0 2008-05-12 07:17 ./usr/share/groovy/lib/mx4j.jar -> ../../java/mx4j.jar
lrwxrwxrwx root/root 0 2008-05-12 07:17 ./usr/share/groovy/lib/mockobjects-core.jar -...

Read more...

Revision history for this message
Luis Arias (kaaloo) wrote :

I submitted a debdiff on bug #256325 that removes the bsf runtime dependency.

Revision history for this message
Matthias Klose (doko) wrote :

the fix from bug #256325 was applied

Changed in groovy:
status: Confirmed → Fix Released
Revision history for this message
Olivier Mengué (dolmen) wrote :

The fix does not seem to be in Ubuntu Lucid.
Here is the list of package that aptitude want to install when adding 'groovy':

  antlr{a} groovy ivy{a} junit4{a} libantlr-java{a} libasm2-java{a} libbsf-java{a} libcommons-cli-java{a}
  libcommons-lang-java{a} libcommons-logging-java{a} libhamcrest-java{a} libjline-java{a} libmockobjects-java{a}
  libregexp-java{a} libservlet2.5-java{a} libxpp3-java{a} libxstream-java{a}

libbasf-java is still in the list. And also many other packages (antlr, ivy, junit, libservlet2.5-java) which clearly should not be necessary to run Groovy script from the terminal.
It looks like that the list of packages required for *building* Groovy has been copied to the binary package for the Groovy runtime.

Revision history for this message
Olivier Mengué (dolmen) wrote :

The bug is still in Ubuntu Maverick: groovy still depends on libbsf-java.

Changed in groovy (Ubuntu):
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers