Problem with non-latin1 graphs in ghostscript, dot and postscript format.

Bug #371105 reported by David Kohen on 2009-05-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gramps
Fix Released
Unknown
gramps (Ubuntu)
Undecided
David Kohen

Bug Description

Using gramps 3.0.4-1 on 9.04.
I had problems with Hebrew graphs since I wanted a multi-page output...
So I fixed it...
It should work with any language now (utf8).
I didn't have the time to make a complete source tree, so the patch is just for the file, the file is in the ReportBase directory.
Please forward this upstream...
Thank you,
David Kohen

David Kohen (kohen-d) wrote :

Should I set it to "fix committed"?

Changed in gramps (Ubuntu):
assignee: nobody → David Kohen (kohen-d)
status: New → Confirmed
Duncan Lithgow (duncan-lithgow) wrote :

Are you able to test this issue with the current release of GRAMPS, 3.1.1? If it's fixed there then we don't need to apply the patch. Remember to export to xml before upgrade.

I don't think it's normal to confirm your own bugs, I mean you can't be totally sure if it's a common problem. But I'll assume you've checked that possibility. I'll make the gramps-dev list aware of this patch in case it's needed.

David Kohen (kohen-d) wrote :

The code is the same in the current SVN.
The bug is caused when the "dot" command is run with non-latin1 characters, the documentation of GraphViz mentions it:
http://www.graphviz.org/doc/info/output.html#d:ps

The fact whether the problem is common or not is irrelevant, since the code does something incorrectly, and my patch makes it so it does the same thing, only this time, it works with every case.

Changed in gramps:
status: Unknown → New
David Kohen (kohen-d) wrote :

Gramps devs have tested my patch and it works...
What should be done to add it to the package?

Duncan Lithgow (duncan-lithgow) wrote :

You've mentioned that the patch works with the SVN code, in order for it to be applied by the Ubuntu devs (unlikely in my opinion) it would need to work with 3.1.1. I suggest you get the patch included in gramps 3.1.2 which is not far away and then we can see if it's time to get 3.1.2 into Karmic Koala (and possibly backported to Jaunty)

Changed in gramps:
status: New → Fix Released
David Kohen (kohen-d) wrote :

It has been committed in SVN, so it will exist in 3.1.2.
A lot of changes have been made in the code, I added the additional related fixes to the patch but it doesn't apply on 3.0.4.

Benny (benny-malengier) on 2010-11-03
Changed in gramps (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.