Consider overriding lintian "wrong-name-for-upstream-changelog" warning in grace

Bug #712837 reported by Alex Valavanis on 2011-02-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grace (Debian)
Fix Released
Unknown
grace (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: grace

When grace is built in Ubuntu, lintian mistakenly gives a "wrong-name-for-upstream-changelog" warning. The reason for this is as follows:

Upstream changelogs are not installed in Ubuntu by default... however, the grace package installs two other documentation files which happen to be called "CHANGES" and "doc/CHANGES.html". Lintian mistakenly thinks that these files are the upstream changelog, and it complains because they are not called "ChangeLog.gz" as it expects.

This problem does not exist in Debian, because their build system *does* install the upstream changelog... lintian sees it, and is happy!

As far as I am aware, there is no way for us to tell lintian that the CHANGES* files are not upstream changelogs. We may want to consider overriding the lintian warning in Ubuntu. However, it is a very minor problem, and it's probably not worth branching from Debian for this reason alone.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: grace 1:5.1.22-9
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Fri Feb 4 00:20:45 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 LC_MESSAGES=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: grace

Revision history for this message
Alex Valavanis (valavanisalex) wrote :
Revision history for this message
Alex Valavanis (valavanisalex) wrote :
tags: removed: amd64
Changed in grace (Ubuntu):
importance: Undecided → Low
Revision history for this message
Alex Valavanis (valavanisalex) wrote :

Very strange. Apparently, this doesn't happen in Debian - just in Ubuntu. The Debian bug has been closed as invalid. Any suggestions?? Here's the Debian maintainer's comment from their bug tracker.

>>
% ls -l /usr/share/doc/grace/changelog.gz
-rw-r--r-- 1 root root 13788 May 21 2008 /usr/share/doc/grace/changelog.gz
% apt-cache policy grace | grep Install
 Installed: 1:5.1.22-9

I'm not sure what Ubuntu is doing differently, but this bug does not appear to
be present in the Debian packages, either the one I built for the last upload
or the autobuilt packages from other architectures. Note that changelog.gz and
CHANGES.html contain different content.

- Nicholas

Revision history for this message
Alex Valavanis (valavanisalex) wrote :

OK, I get it. The Ubuntu build system doesn't install changelogs by default, whereas Debian does. To fix the problem properly, we should just remove doc/CHANGES.html from debian/grace.docs. I will prepare a new debdiff shortly.

Changed in grace (Ubuntu):
status: New → In Progress
assignee: nobody → Alex Valavanis (valavanisalex)
Changed in grace (Debian):
status: Unknown → Fix Released
Revision history for this message
Bryce Harrington (bryce) wrote :

Okay, resubscribe sponsors when it's ready to go

Revision history for this message
Alex Valavanis (valavanisalex) wrote :

Right, after further investigation with the help of the Debian maintainer, it seems that the following is happening...

* CHANGES and doc/CHANGES.html show upstream changes for different
version releases of grace. They are distributed using dh_installdocs
in both Debian and Ubuntu
* ChangeLog is the actual upstream changelog (i.e. a step-by-step
development log). This is distributed using dh_installchangelogs as
changelog.gz in Debian, but is *not* distributed in Ubuntu.

So, the problem is Ubuntu specific - lintian sees the
/usr/share/doc/grace/CHANGES.html documentation and thinks it's the
upstream changelog, because there is no changelog.gz.

The question is whether it's worth adding a lintian override in Ubuntu. I'm not sure the problem is serious enough for us to branch from Debian.

Changed in grace (Ubuntu):
status: In Progress → New
assignee: Alex Valavanis (valavanisalex) → nobody
summary: - upstream changelog is installed with incorrect name
+ Consider overriding lintian "wrong-name-for-upstream-changelog" warning
+ in grace
Changed in grace (Ubuntu):
status: New → Triaged
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.