kleopatra complains that gpgme should be compiled with gpgconf support

Bug #305565 reported by PascalC on 2008-12-05
20
Affects Status Importance Assigned to Milestone
KDE PIM
Invalid
Undecided
Unassigned
gpgme1.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libgpgme11

Kubuntu Intrepid

kleopatra autotest at start complains that gpgme should be compiled with gpgconf support
see attached screenshot

ii libgpgme11 1.1.6-2ubuntu1 GPGME - GnuPG Made Easy
ii kleopatra 4:4.1.3-0ubuntu1~intrepid2 KDE Certificate Manager

Related branches

PascalC (p92) wrote :
Andreas Roth (aroth) wrote :

Same result for kleopatra from KDE 4.2 beta:
ii kleopatra 4:4.1.80-0ubuntu1~intrepid1~p KDE Certificate Manager

Peter Antoniac (pan1nx) wrote :

I confirm. And it causes some strange behaviour when you try to configure the keyservers or other configurations related to gpgconf.

Changed in gpgme1.0:
status: New → Confirmed
giacof (giacof) wrote :

I confirm. Same packages version.
I also get errors that in English would sound like 'unable to detect certificate type', when trying to import certificates from a file. That ends up with a failure in verifying the email signature.

Bryan (brywilharris) wrote :

Fix. I recompiled libgpgme11 from source and that fixed the error message. I can confirm that gpg encryption/decryption now work in kmail, but not signing for some reason. I have attached the rebuilt deb and all the source stuff I used to compile this package.

Bryan (brywilharris) wrote :

source

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gpgme1.0 - 1.1.8-2ubuntu2

---------------
gpgme1.0 (1.1.8-2ubuntu2) jaunty; urgency=low

  * Add gpg2 build-dep LP: #305565

 -- Florian Reinhard <email address hidden> Wed, 18 Mar 2009 16:21:41 +0100

Changed in gpgme1.0:
status: Confirmed → Fix Released
Changed in kdepim:
status: New → Invalid

So does this means you aren't going to fix this in Intrepid because the Jaunty
package works?

--
Bryan Harris
Research Engineer
Structures and Materials Evaluation Group
<email address hidden>
http://www.udri.udayton.edu/
(937) 229-5561
On Wednesday 18 March 2009 15:16:13 you wrote:
> ** Changed in: kdepim
> Status: New => Invalid

OK, gotcha. I misunderstood. Thanks.
--
Bryan Harris
Research Engineer
Structures and Materials Evaluation Group
<email address hidden>
http://www.udri.udayton.edu/
(937) 229-5561
On Wednesday 18 March 2009 16:20:44 you wrote:
> No. All it means is that the bug isn't in kdepim.

Colin Watson (cjwatson) wrote :

Unfortunately this has rendered seahorse unbuildable since it Build-Conflicts: gnupg2. Somebody should investigate this.

Colin Watson (cjwatson) wrote :

I've filed bug 346591 for the seahorse problem.

Mikael Gerdin (mgerdin) wrote :

It seems that it is sufficient for gpgme to know the path of where it should find gpgconf, just as with the gpg and gpgsm binaries. Simply adding "--with-gpgconf=/usr/bin/gpgconf" to its configure options makes it work for me.
Attaching debdiff

Martin Pitt (pitti) wrote :

This update also caused bug 352180. I will change the binary dependency to be "gnupg | gnupg2". In fact, I see no reason why a library should depend on any application in the first place.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers