gparted automatically starts scanning all devices slowly and never completing the task

Bug #1029149 reported by warren on 2012-07-25
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gparted (Ubuntu)
Undecided
Unassigned

Bug Description

1) Ubuntu 12.10 Alpha3 i386 (Live USB stick)
2) gparted 0.12.1-1
3) I expected to open gparted completing the system scan in a matter of seconds.
4) When opened gparted the scanning all devices is never completed. The scanning all devices is extremely slow. It takes approximatetly 8 seconds for the orange indicator to move from left to right or right to left.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gparted 0.12.1-1
ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
Uname: Linux 3.5.0-6-generic i686
ApportVersion: 2.4-0ubuntu5
Architecture: i386
CasperVersion: 1.320
Date: Wed Jul 25 21:18:33 2012
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120724.2)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gparted
UpgradeStatus: No upgrade log present (probably fresh install)

warren (wkclemmons) wrote :
Sasa Paporovic (melchiaros) wrote :

Could you check if you have on the stick a FAT32 partition (may be not overwritten during install to the stick). In this case it is a ḱnown bug and we adapt the report.

Thank you for reporting warren.

Sasa Paporovic (melchiaros) wrote :
Changed in gparted (Ubuntu):
status: New → Incomplete

Melchiaros,

I used a USB stick created using the Startup disk creator with the FAT32
single partition with 1gb persistence ext2. When I look at the USB stick
using gparted it shows only one partition. I am not certain that this bug
matches the bug you referred to 121943 since there was no external HD just
usb flash drive live medium. The bugs do seem similar with cpu 100% even
after gparted is closed. I did get ubuntu updates on the usb persistence
which seemed to clear up the gparted not functioning properly.

I hope this helps and is not too late.

warren

On Fri, Jul 27, 2012 at 12:19 PM, melchiaros <email address hidden> wrote:

> The report I mention is:
>
> https://bugs.launchpad.net/ubuntu/+source/gparted/+bug/121943
>
> ** Changed in: gparted (Ubuntu)
> Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1029149
>
> Title:
> gparted automatically starts scanning all devices slowly and never
> completing the task
>
> Status in “gparted” package in Ubuntu:
> Incomplete
>
> Bug description:
> 1) Ubuntu 12.10 Alpha3 i386 (Live USB stick)
> 2) gparted 0.12.1-1
> 3) I expected to open gparted completing the system scan in a matter of
> seconds.
> 4) When opened gparted the scanning all devices is never completed. The
> scanning all devices is extremely slow. It takes approximatetly 8 seconds
> for the orange indicator to move from left to right or right to left.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.10
> Package: gparted 0.12.1-1
> ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
> Uname: Linux 3.5.0-6-generic i686
> ApportVersion: 2.4-0ubuntu5
> Architecture: i386
> CasperVersion: 1.320
> Date: Wed Jul 25 21:18:33 2012
> LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120724.2)
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: gparted
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gparted/+bug/1029149/+subscriptions
>

Sasa Paporovic (melchiaros) wrote :

No, it is not to late.

So, I have understand you correct that now gparted works.

In this case let us see this as fixed by the way and close this ticket as Fix Released.

When you observe it again, please set it back to new.

If you want you could look at bug 121943 if this is reproducible or is also gone with the latest Ubuntu version.

In this case you can close the lauchpad bug and leave a message on the gnome bugtracker.

Changed in gparted (Ubuntu):
status: Incomplete → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1029149

tags: added: iso-testing
Curtis Gedak (gedakc) wrote :

While GParted is scanning the devices, would you be able to provide the output from the following command?

ps -ef | egrep -i "dos|ntfs"

This will tell us if the problem is already known for fat16/32, or ntfs file systems.

warren (wkclemmons) wrote :

Curtis

I attached two screenshots both from live usb stick one with ext2
persistence and one without.

warren

>

Curtis Gedak (gedakc) wrote :

Warren,

Perhaps the BIOS on the computer is misconfigured to indicate that a floppy disk device is present when the computer does not have a physical floppy disk drive.

See Ubuntu Launchpad Bug #910379 - Gparted does not start and continues to scan devices

See also GParted FAQ
http://gparted.org/faq.php#faq-11

Would you be able to check the BIOS settings with regards to the floppy drive?

warren (wkclemmons) wrote :

Curtis,

I have three versions of Lubuntu installed on the hdd. I have screenshots
of gparted with the floppy enabled and disabled with each attachment.

warren

Curtis Gedak (gedakc) wrote :

Based on your screen shots from lubuntu12.10, it appears that the root of the problem is that the scan does not complete when the BIOS is set to indicate a floppy is present when no physical floppy device is attached.

To confirm that I have understood the output correctly, does GParted finish scanning devices when the floppy is disabled in the BIOS?

warren (wkclemmons) wrote :

Curtis,

In Lubuntu 12.10 Gparted does finish when the Floppy is disabled in the
BIOS. So I guess i can thank Asus for doing such a wonderful job with the
BIOS.

warren

Curtis Gedak (gedakc) wrote :

The root of the problem is the misconfigured BIOS. Having said this, it appears that earlier versions of Lubuntu did not suffer from this problem. This suggests a change in some of the underlying utilities and libraries.

Would you be able to reproduce the problem in Lubunut 12.10, and then while GParted is endlessly scanning capture the output of all the processes running with the following command?

ps -ef > ps-output.txt

Please post the contents of the ps-output.txt file here so that we can investigate to see what command or utility might be taking a long time to run.

warren (wkclemmons) wrote :

On Thu, Aug 30, 2012 at 1:16 PM, Curtis Gedak <email address hidden> wrote:

> The root of the problem is the misconfigured BIOS. Having said this, it
> appears that earlier versions of Lubuntu did not suffer from this
> problem. This suggests a change in some of the underlying utilities and
> libraries.
>
> Would you be able to reproduce the problem in Lubunut 12.10, and then
> while GParted is endlessly scanning capture the output of all the
> processes running with the following command?
>
> ps -ef > ps-output.txt
>
> Please post the contents of the ps-output.txt file here so that we can
> investigate to see what command or utility might be taking a long time
> to run.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1029149
>
> Title:
> gparted automatically starts scanning all devices slowly and never
> completing the task
>
> Status in “gparted” package in Ubuntu:
> Fix Released
>
> Bug description:
> 1) Ubuntu 12.10 Alpha3 i386 (Live USB stick)
> 2) gparted 0.12.1-1
> 3) I expected to open gparted completing the system scan in a matter of
> seconds.
> 4) When opened gparted the scanning all devices is never completed. The
> scanning all devices is extremely slow. It takes approximatetly 8 seconds
> for the orange indicator to move from left to right or right to left.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.10
> Package: gparted 0.12.1-1
> ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
> Uname: Linux 3.5.0-6-generic i686
> ApportVersion: 2.4-0ubuntu5
> Architecture: i386
> CasperVersion: 1.320
> Date: Wed Jul 25 21:18:33 2012
> LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120724.2)
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: gparted
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gparted/+bug/1029149/+subscriptions
>

Curtis Gedak (gedakc) wrote :

Thank you Warren for the process status output. From a quick look it would appear that the 'blkid' command is not returning in a reasonable amount of time.

To confirm this is the problem, would you be able to test the following command with a misconfigured BIOS?

     sudo blkid

Normally this command should read the information from the cache file /etc/blkid.tab, display the partition details such as LABEL, UUID, and TYPE, and then quickly return control to the command line..

warren (wkclemmons) wrote :

Curtis

The output that I got from the sudo blkid is displayed in the screenshot.
I'm assuming the output is stored in no other location. I'm also assuiming
the resulting output should be immediately displayed in the terminal.

warren

On Thu, Aug 30, 2012 at 2:51 PM, Curtis Gedak <email address hidden> wrote:

> Thank you Warren for the process status output. From a quick look it
> would appear that the 'blkid' command is not returning in a reasonable
> amount of time.
>
> To confirm this is the problem, would you be able to test the following
> command with a misconfigured BIOS?
>
> sudo blkid
>
> Normally this command should read the information from the cache file
> /etc/blkid.tab, display the partition details such as LABEL, UUID, and
> TYPE, and then quickly return control to the command line..
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1029149
>
> Title:
> gparted automatically starts scanning all devices slowly and never
> completing the task
>
> Status in “gparted” package in Ubuntu:
> Fix Released
>
> Bug description:
> 1) Ubuntu 12.10 Alpha3 i386 (Live USB stick)
> 2) gparted 0.12.1-1
> 3) I expected to open gparted completing the system scan in a matter of
> seconds.
> 4) When opened gparted the scanning all devices is never completed. The
> scanning all devices is extremely slow. It takes approximatetly 8 seconds
> for the orange indicator to move from left to right or right to left.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.10
> Package: gparted 0.12.1-1
> ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
> Uname: Linux 3.5.0-6-generic i686
> ApportVersion: 2.4-0ubuntu5
> Architecture: i386
> CasperVersion: 1.320
> Date: Wed Jul 25 21:18:33 2012
> LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120724.2)
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: gparted
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gparted/+bug/1029149/+subscriptions
>

Curtis Gedak (gedakc) wrote :

Warren, it looks like blkid is hanging, or at least taking a long time to process partition statistics, when working on a PC with the BIOS misconfigured to indicate a floppy is present when no physical floppy drive is installed.

Can you create a bug report for blkid?

warren (wkclemmons) wrote :

Curtis

What is the process for filing a bug for blkid?

warren

On Thu, Aug 30, 2012 at 4:16 PM, Curtis Gedak <email address hidden> wrote:

> Warren, it looks like blkid is hanging, or at least taking a long time
> to process partition statistics, when working on a PC with the BIOS
> misconfigured to indicate a floppy is present when no physical floppy
> drive is installed.
>
> Can you create a bug report for blkid?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1029149
>
> Title:
> gparted automatically starts scanning all devices slowly and never
> completing the task
>
> Status in “gparted” package in Ubuntu:
> Fix Released
>
> Bug description:
> 1) Ubuntu 12.10 Alpha3 i386 (Live USB stick)
> 2) gparted 0.12.1-1
> 3) I expected to open gparted completing the system scan in a matter of
> seconds.
> 4) When opened gparted the scanning all devices is never completed. The
> scanning all devices is extremely slow. It takes approximatetly 8 seconds
> for the orange indicator to move from left to right or right to left.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.10
> Package: gparted 0.12.1-1
> ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
> Uname: Linux 3.5.0-6-generic i686
> ApportVersion: 2.4-0ubuntu5
> Architecture: i386
> CasperVersion: 1.320
> Date: Wed Jul 25 21:18:33 2012
> LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120724.2)
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: gparted
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gparted/+bug/1029149/+subscriptions
>

Curtis Gedak (gedakc) wrote :

The blkid command is part of util-linux. See,
http://en.wikipedia.org/wiki/Util-linux

I think you should be able to report a bug against the util-linux package in Ubuntu 12.10.

Phillip Susi (psusi) wrote :

So blkid now hangs when run *without* the -p switch under these conditions?

Curtis Gedak (gedakc) wrote :

Warren, as per Phillip's request, would you be able to test the blkid command with and without the -p switch to see if these commands hang?

E.g.

     sudo blkid

and

    sudo blkid -p

warren (wkclemmons) wrote :

Curtis

I have attached a text document with sudo blkid command results.

warren

Curtis Gedak (gedakc) wrote :

Did the "sudo blkid" command hang for a long period of time, or did it complete quickly?

warren (wkclemmons) wrote :

The sudo blkid command completed quickly.

Curtis Gedak (gedakc) wrote :

Warren, was the BIOS misconfigured when you ran the blkid command tests?
Either way I think the problem is outside of changes that can be made in GParted.

warren (wkclemmons) wrote :

Curtis

I assume the BIOS is misconfigured since this is a recurring problem with
this computer.

warren

Phillip Susi (psusi) wrote :

At the bottom of the gparted window there is a status bar. Does the status bar say anything during the long delay?

Phillip Susi (psusi) wrote :

Also the blkid output does not seem to list the floppy. Does ls /dev/fd0 show it?

warren (wkclemmons) wrote :

Phillip

In response to the questions you asked about gparted. I have attached two
screenshots from Live persistent USB from the Lubuntu 12.10 daily build.

warren

>

Phillip Susi (psusi) wrote :

Oops, it was -c, not -p. Can you try running sudo blkid -c and see if it hangs?

It is odd that /dev/fd0 shows up, but is not reported by blkid. Can you make sure the floppy is disabled in the bios?

Phillip Susi (psusi) wrote :

Ok, after looking at the change log to refresh my memory, gparted used to run blkid -c /dev/null, and this would hang when a floppy was misconfigured, so we changed it to just run blkid by itself.

So warren already said that blkid with no arguments does not hang, which is what we expect. Can you run ps aux | grep blkid while gparted is hung?

warren (wkclemmons) wrote :

Philip

I attached a screenshot of the ps aux | grep blkid command.

warren

Phillip Susi (psusi) wrote :

That looks like it may be a stuck blkid instance, can you check if its parent process is gparted?

warren (wkclemmons) wrote :

How do I check if its parent process is gparted?

Phillip Susi (psusi) wrote :

Use ps alx instead of aux and it will list the PPID, then run ps on that pid and see if it's gparted.

warren (wkclemmons) wrote :

Phillip

I attached a file with some screenshots and text document some of which may
useless. Apparently I need more info as to perform the commands in question.

Phillip Susi (psusi) wrote :

You know how I had you run ps aux | grep blkid? I need you to do the same only use ps alx instead of aux, and then look at the second number listed. That is the parent process id. Then run ps XXX where XXX is that ID and see if it is the gparted process. If it is, and that blkid instance is blocked in the D state like it appeared to be before, then it is hanging again.

warren (wkclemmons) wrote :

I think this what you are looking for in the screenshot

Curtis Gedak (gedakc) wrote :

Warren,

It does appear that the blkid command without any parameter is hung, and that blkid was invoked from gparted.

When you run GParted, has Ubuntu been running for a while, or did you immediately start up GParted as soon as Ubuntu booted?

The reason I ask is I have a hypothesis that internally blkid has to run at least once to build a cache of device information. If the cache has not yet been built, then calls blkid (without the -c /dev/null to bypass the cache) will have to wait until the cache of device information has been built.

Phillip Susi (psusi) wrote :

The cache is supposed to be built as udev spawns blkid on newly detected hardware.

What doesn't make sense is that blkid appears to hang when gparted runs it, but not when run by hand.

Curtis Gedak (gedakc) wrote :

Phillip, I agree that there should be no difference if blkid is run by hand in a terminal, or by gparted.

When GParted spawns the the blkid command, it uses the C locale (e.g., LC_ALL=C). I don't think that this should make any difference.

Assuming my hypothesis is correct, then if Ubuntu is booted and you immediately run blkid by hand, then it should display the same behaviour as if it were run by gparted.

warren (wkclemmons) wrote :

Curtis

I generally open applications in random when testing just to see if the
app will open.
I have Ubuntu and Xubuntu installed on one machine gparted is hung in
Ubuntu but is not hung working normally in Xubuntu. When testing live USBs
in Lubuntu gparted is hung but not Xubuntu is this remotely relevant?

warren

Curtis Gedak (gedakc) wrote :

Warren, your observations are certainly relevant. If I understand correctly, the situation is as follows:

Ubuntu - gparted hangs
Lubuntu - gparted hangs
Xubuntu - gparted works!

To me this means that there is something different between these versions.

Does blkid follow the same pattern in Ubuntu, Lubuntu, and Xubuntu?

Phillip Susi (psusi) wrote :

It would be relevant if they were all on the same machine, but I thought you were testing these on different machines?

And have you tested after making sure the bios is not configured to think it has a floppy when there isn't one?

warren (wkclemmons) wrote :

The screenshot attached to this email are reference to one machine for
comparison purposes.
I have ps alx | grep blkid for Xubuntu and Ubuntu the last one is Lubuntu
form live USB from earlier. Xubuntu from the live USB takes 30 seconds to
finish but when installed to hdd works normally. There is one floppy drive
on this machine. The last screenshot is when clicking the floppy drive in
the home folder.

Phillip Susi (psusi) wrote :

Is there *actually* a floppy, or does it just think it has one?

warren (wkclemmons) wrote :

Actual floppy when disabled in BIOS gparted does not get hung.
Floppy disabled in BIOS no problem with bug# 983681 or bug# 1029149.
This machine is currently on the injured and disabled list since both HDD
failed today.

Phillip Susi (psusi) wrote :

Is there a disk in the drive, and does it light up when you try to start gparted?

Phillip Susi (psusi) wrote :

Oh, and does the drive actually work correctly when you put a disk in? Maybe it is broken?

warren (wkclemmons) wrote :

If you remember this problem was not present with 11.10 or 12.04. But I
will check the floppy.

cryd_be (kridybel) wrote :

Hi there,

I noticed this bug (gparted does not finish scanning) after upgrading my 12.04 ubuntu studio 32 bit (fresh install) to 12.10. The pc is an old dell Dimension 4600. I'm quite sure gparted worked well under 12.04. Another thing that I noticed after the upgrade to 12.10 is that on the desktop there was an incon to a floppy drive a: although there was no floppy drive available in the pc. The floppy icon was not there in 12.04. After reading through this bug's comments I looked into the bios and changed the setting of the floppy drive to "not installed". After the proper Bios setting (not installed, because there is no floppy) gparted worked without a flaw on 12.10. Ubuntu studio uses the XFCE desktop environment. Hope this helps.

To post a comment you must log in.