googleearth has no connection - Google version views to N-Africa

Bug #1196703 reported by JMB on 2013-07-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
googleearth-package (Ubuntu)
Undecided
Unassigned

Bug Description

goole-earth installed via the provided googleearth-package has no connection,
i.e. myplaces still work, search results in error message.
Trying to install google-earth directly from Google site on Xubuntu 13.04
works better - connection error is not present - but has 2 problems:
1) Always crashes on 1st launch
2) Search yields in a view shifted to north Africa - no zooming;
     known workaround is a leading "TO:" in the search field,
     e.g. "TO: Hamburg" works as expected.
Maybe providing an updated package would be nice given the interest and
the usage of google-earth (coordinating with upstreams - Debian and Google).

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: googleearth-package 0.7.0
ProcVersionSignature: Ubuntu 3.8.0-25.37-generic 3.8.13
Uname: Linux 3.8.0-25-generic x86_64
ApportVersion: 2.9.2-0ubuntu8.1
Architecture: amd64
Date: Mon Jul 1 22:43:09 2013
InstallationDate: Installed on 2013-06-29 (2 days ago)
InstallationMedia: Xubuntu 13.04 "Raring Ringtail" - Release amd64 (20130423.1)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: googleearth-package
UpgradeStatus: No upgrade log present (probably fresh install)

JMB (jmb-tux) wrote :
JMB (jmb-tux) wrote :

To add some more info:
The problem with "Invalid HTTP request" is not dependant on Ubuntu 13.04
but the google-earth version provided with the googleearth-packe in Ubuntu reps.
Thus it also effects e.g. 12.04 LTS (and others incl. MINT):
-> googleearth-package:
./googleearth_6.0.3.2197+0.7.0-1_amd64.deb
googleearth -> 6.0.3.2197 (5/13/2011)
"Invalid HTTP request"
See also:
  http://productforums.google.com/forum/#!topic/earth/F3cZRVUJiPA

The latest version doesn't have this error - but other ones.
Getting current version:
  http://www.google.com/earth/index.html
sudo dpkg -i /home2/jbraun/mydownload/google-earth-stable_current_amd64.deb

Unfortunately on my 12.04 LTS it is permanently crashing on start.
That version crashes on 13.04 only at 1st invocation, afterwards it seems stable,
but has problems with search field finding the Location.
"TO:" at the beginning of the search field is one workaround, another valid one
is setting LANG variable:
    LANG=en_US google-earth
see this link:
  https://bugs.launchpad.net/ubuntu/+source/googleearth-package/+bug/1160289

A PPA or a new package for standard repositories would be nice.
Currently, this situation is a mess which has to be resolved by each and any
uers in its own.
This is no valid solution for users who are not familiar with admin tasks and absolutely
not fitting to Ubuntu has it started.

Is someone at Ubuntu/Canonical coordinating things with Debin & Google and could
provide a reasonable (i.e. stable and not buggy) solution for the future?
There would certainly a large number of users who would appreciate that!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers