Google earth search does not zoom onto a location

Bug #1160289 reported by madvinegar on 2013-03-26
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
googleearth-package (Ubuntu)
Undecided
Unassigned

Bug Description

When my OS is logged in Greek Language, (and so Google Earth is also in Greek), if i use the search box and I find the location I am looking for, when I click on this location, instead of been transfered on this location and get the relative zoom in, I am transefered away from this location, without zoom in, and I can only see it by far.
In other words, the search box finds the location but when I click on it, I do not get transfered to it, nor do I get a zoom in.
On the contrary, I am transfered away from it.

If I use my system in English, then the search function operates as it should, i.e. transfers me to the location and zooms in.

My system is ubuntu 12.04 LTS, 64bit.

madvinegar (madvinegar) wrote :

Found a workaround.
If I start google earth from terminal like this:

LANG=en_US google-earth

then the search and zoom function works just fine (and google earth remains in Greek language).

Now, all I need to find is how to set google-earth to always start with this parameter.

new4u (new4u) wrote :

It also happens with German language on Ubuntun 13.04 (release candidate) 64 bit. Google-earth version 7.0.3.8542.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in googleearth-package (Ubuntu):
status: New → Confirmed
new4u (new4u) wrote :

... and it's true, madvinegar's hint worked also out for me. Thank you for this.

madvinegar (madvinegar) wrote :

Complete workaround based on my above solution:

1. I created a script and named it "earth.sh" (without the quotes).

sudo gedit earth.sh

and placed the following lines inside it:

#!/bin/bash
LANG=en_US google-earth

2. Then I placed said script inside /opt/google/earth/free:

sudo cp earth.sh /opt/google/earth/free

3. Then I opened /usr/share/applications/google-earth.desktop:

sudo gedit /usr/share/applications/google-earth.desktop

and changed the "exec" command to "/opt/google/earth/free/earth.sh".

Now google earth opens and the search function works ok even if the language is not US english.

madvinegar (madvinegar) wrote :

Forgot to say that I made the script executable.

Right click on it > properties > permissions tab > tick the box that says "allow executing as a program".

tArKi (djtarki) wrote :

Same problem here under Ubuntu 13.04 64 bits and the latest version of Google Earth 7.1.1.1888

Using the script mentioned above fixes the problem.

I hope this is solved soon.

Thanks.

matiaspar (matiaspar) wrote :

Solución completa para perdida de zoom al hacer una búsqueda de calle en google earth en español (Thanks madvinegar!!):
El problema es que por alguna razón el zoom de búsqueda no funciona con otras configuraciones de lenguaje de sistema...y esta solución mantiene los menúes en español (si los quieres en inglés solo basta con cambiar en el archivo "es_US" por "en_US", todo sin comillas.

1. Crear un archivo de texto "earth.sh" (sin las comillas), así:
abrir terminal luego colocar:
sudo gedit earth.sh copiando el siguiente contenido:

#!/bin/bash
LANG=es_US google-earth

2. Seleccionar guardar y guardarlo en /opt/google/earth/free:

3. luego ir a esa carpet: sudo nautilus: /opt/google/earth/free, buscar el archivo earth.sh y haciendo clic derecho seleccionar la pestaña permisos y tildar "ejecutar este archivo como programa"

4. Ahora abrir el archivo de lanzador de unity asi: sudo gedit /usr/share/applications/google-earth.desktop:

y cambiar la linea "exec" para que quede así"/opt/google/earth/free/earth.sh"(de esta manera le decimos al lanzador que lance nuestro script y no el archivo binario de earth directamente).

marque (vivideo) wrote :

Same bug (still) over here, using a dutch version of Ubuntu 13.10 with Google Earth 7.1.2.2041.

The command suggestion LANG=en_US google-earth helped me out. Thanx!

M.

david widmayer (mayerwid) wrote :

It is 08 April 2015 and I can confirm the bug still has not been eliminated. That's a bad for Google! I can report however that the workaround provided by madvinegar back in 2013(!) continues to function. I use a German version of Ubuntu 14.10. All my menues including those for Google Earth are in German. Fine with me. I hope Google gets around to solving this issue.

I seem to be having something similar happening on my Macbook Pro using OS Mavericks, but that issue is for another forum.

tArKi (djtarki) wrote :

Same here, 2th of May 2015 and the problem remains in Google Earth 7.1.4.1529 running on a Ubuntu 15.04 64 bits.

Best regards.

Geb (gebhard-moser) wrote :

Just tried with Ubuntu-Gnome 15.10 and GE 7.1.4.1529, the search for Vienna (or something else turns the earth to the middle of Africa.
Have System set to US-English.
Feels to me like this bug is open since years, thought Google does not maintain this application any more.

Ari Torhamo (ari-torhamo) wrote :

I'd like to add to madvinegar's instruction that to make the script executable in graphical user interface, you need to start nautilus with root privileges with 'gksu nautilus' (you have to give that command in the terminal). 'Sudo nautilus' doesn't seem to work properly, at least not for me. If you don't have gksu installed, you can find it in Ubuntu Software Center. I'm not an expert, but this worked for me.

Perhaps it would be a good idea include madvinegar's solution to the Google Earth installation instruction in help.ubuntu.com, or some other fitting place, as a large part of the users may suffer from this bug. It might be good to adjust it a little to make it more approachable for users with little command line experience. I hesitate to do it myself, as I'm not so well versed myself.

https://help.ubuntu.com/community/GoogleEarth

onto limbo (onto-limbo) wrote :

This bug seems to apply even if English is default, or "echo $LANG" produces

en_US.UTF-8

In any case, instead of creating a new script, it may be easier just to edit the
existing wrapper script (i.e., the result of

ls -al `which google-earth`

which on my system is /opt/google/earth/free/googleearth) and add the line

export LANG=en_US

between the definition of FindPath and script_path=$(FindPath $0);

Tomas Angelo (tommyangelo) wrote :

@onto-limbo thank's. This solved my problem.

Ubuntu 14.04.4 LTS 64 bit
Google Earth 7.1.4.1529

In attachment I added patch for this bug which applies to file:
/opt/google/earth/free/googleearth

The attachment "diff from /opt/google/earth/free/googleearth" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch

Any locality or city name, any big capital in the world, the search does not act driving me always to the center of the Atlantic Ocean
Ubuntu 16.04 64 bit
Google Earth 7.1.7.2500 for 64 bit

giuliano69 (giuliano-lotta) wrote :

Update
Google eart 7.3 (pro and ec version) and ubuntu 16.04
same problem exist

Fixing is trivial, inserting
export LANG=en_US
in the original bash script
/opt/google/earth/free/googleearth-(pro/ec)

BR

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers