[needs-packaging] Package Golly, cellular automaton simulator

Bug #161067 reported by Earth on 2007-11-08
8
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
golly (Ubuntu)
Wishlist
Sean Hunt

Bug Description

Golly is a simulator for cellular automata.

Actively developed, most recently released version 1.2 April 2007
http://golly.sourceforge.net/

Is more recent and feauturesome than other simulators available in universe, and has gtk interface.

This is in debian unstable now.

Sean Hunt (coppro) wrote :

Going to take on my first try at packaging... hope I don't make a fool of myself!

Earth (matt-h) wrote :

Go for it coppro.

I once tried building golly from source but failed, i run amd64.

Good news, the package in Debian testing installed and ran fine for me (hardy).

http://packages.debian.org/search?keywords=golly&searchon=names&suite=all&section=all

Sean Hunt (coppro) wrote :

Here's my first go at a package.

Bryan Donlan (bdonlan) wrote :

Please attach the source package files (.dsc and .diff.gz) not the binary result. Providing the .diff.gz is required to comply with the GPL, if you have patched the source code. You may also find it convenient to use launchpad's PPA feature: https://help.launchpad.net/PPAQuickStart

Also, note that debian has a golly package: http://packages.qa.debian.org/g/golly.html
It will be automatically synced into ubuntu once the new version (Intrepid) is opened, which will happen in a few days, so it's probably not a good idea to start work on a new package now... (though it's a bit late to be saying this)
The debian package has a number of patches applied to fix 64-bit issues, and provides manpages, among other things. I don't know if you've applied similar ones to your copy, as you didn't provide the source

For future reference when making packages, your package also turns up a large number of lintian warnings - run lintian on your .changes file to see them. Of course, some of them (new-package-should-close-itp-bug, unknown-section universe) can be ignored as debian specific, but ones like "executable-not-elf-or-script ./usr/share/golly/Patterns/Still-Lifes/1998-eater-stamp-collection.rle" ought to be fixed.
That said, again, in this case it's probably best to just wait for the universe sync - there's no need to diverge from debian needlessly.

Albert Damen (albrt) wrote :

golly is now available in Intrepid:

golly (1.3-1) unstable; urgency=low

  * Initial release (Closes: #452026).

$ rmadison golly
     golly | 1.3-5 | intrepid/universe | source, amd64, i386

Vytas (vytas) wrote :

I imported 1.4 from debian, if you need: https://launchpad.net/~vytas/+archive
Seems to work for me, but I'm not very good at debian packaging.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.