Comment 20 for bug 305264

We have 3 ldap servers. 2 running on ubuntu hardy with the gnutls version 2.0.4-1ubuntu2.2 (so not the latest update) and one running under debian etch using openssl.

I've tried using only the debian etch/openssl server and we still have the same problem.

I've tried connecting in TLS and SSL mode - both with the same results.

I think the problem is related to the way the openldap uses gnutls since the gnutls utility gnutls-cli thinks that the certificate is valid.

If you want me to try updating one of the ubuntu hardy ldap servers to use the latest update to see if it works then I can do that tomorrow at 8am GMT.