Bug #1014821 reported by Gitane
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnushogi (Ubuntu)

Bug Description

(1) Linux Mint 13 Maya 64-bit with Mate DE

(2) I downloaded through Synaptic Package Manager shogi, a game commonly found in Debian repositories.

(3) The name of the game appeared in the Menu under All Applications/Games, but nothing happened when the name was clicked.

(4) Shogi is Japanese chess. It is rather a specialist game but has a small but enthusiastic following.
In Debian based distros, the user can download xshogi and gnushogi (the two applications depend on each other) and then click on the icon in the Menu and play a game against the computer. The command as seen in Menu properties is usually just "xshogi".

Shogi can be played without problems on Debian, Linux Mint Debian Gnome and Linux Mint Debian XFCE. When the name or icon is clicked, the game opens and the user, having the first move as "black", commences a game against the computer. l It cannot be played on Linux Mint 13 Maya Mate. When the icon in the Menu is clicked in Mint 13 Mata Mate, nothing happens.

I gave also tried running the command "xshogi" as root in a terminal without success.

(5) More details

Interestingly. after downloading the 2 files xshogi and gnushogi through Synaptic Package Manager, I then could not find the applications in bin or sbin. I tries "locate xshogi" in a terminal and found only information files. If I knew where the application was hidden, perhaps I could give the path to the Menu.

I think the problem could be that there is no link between the application and the Menu. I do not know whether other games are affected because I have not tried downloading other games.

Revision history for this message
Gitane (gtarn) wrote :

This game has its support base and so the bug should really be given some importance rather than completely ignored.
There is a New York Shogi Club and a British Shogi Club, quote:

"The British Shogi Federation (BSF) is the National Representative Organisation of the Federation of European Shogi Associations (FESA) for Shogi players in Britain. The BSF aims to increase public awareness of Shogi and to provide a source of information for its members. It organises the annual British Open Shogi Championships each year, and supports and encourages other British Shogi Tournaments."

Xshogi can be installed via Synaptic Package Manager. On Debian, Linux Mint Debian XFCE and I believe Linux Mint Gnome, the installation is easy: install the 2 packages "gnushogi" and "xshogi" and it has always immediately had a Menu entry and worked out of the box. Why not in Maya Mate? Perhaps it's a Mate problem or a missing library?

Thanks in advance for any help.

Revision history for this message
Gitane (gtarn) wrote :

Problem solved
This bug can be closed at your convenience.

The problem in loading the program is one a missing xfont; once the font is installed, no problem.

To play computer Shogi, the user needs to install the following programs and dependencies in Synaptic Package Manager:

(1) xshogi

(2) gnushogi

(3) xfonts-100dpi-transcoded

(4) xfonts-encodings

(5) xfonts-utils

and the game works immediately.

Best Wishes

Revision history for this message
Gitane (gtarn) wrote :

It may be worthwhile including the font and its dependencies into the next OS or as a patch.


Vlad Orlov (monsta)
affects: linuxmint → gnushogi (Ubuntu)
Revision history for this message
Alex Schreiber (alexschreiber) wrote :

From Ubuntu 15.04 on, these fonts have been added as (recommended; so by default they will be installed) dependencies. See
So this bug could be marked as closed.

Revision history for this message
Marijn Schouten (m-schouten) wrote :

This is not fixed for 14.04 LTS. Also installing xfonts-100dpi-transcoded (the only one of the five listed above that I did not already have installed) does not help. This still happens:

$ xshogi
xshogi: No fonts match pattern -*-helvetica-medium-o-normal--*-*-*-*-*-*-*-*

Of course it is well known that no Ubuntu bug is ever fixed...

Revision history for this message
Marijn Schouten (m-schouten) wrote :

Funnily enough today xshogi starts up without complaint. I already removed xfonts-100dpi-transcoded again, so perhaps a restart fixed something?

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.