mh-e fails to load, "void-variable message-mark-insert-begin"

Bug #26831 reported by Debian Bug Importer on 2005-12-09
16
Affects Status Importance Assigned to Milestone
gnus (Debian)
Fix Released
Unknown
gnus (Ubuntu)
High
Unassigned

Bug Description

Automatically imported from Debian bug report #342326 http://bugs.debian.org/342326

Revision history for this message
In , Christopher J Peikert (cpeikert) wrote : further information on failed load

Hi,

If I try to remove and re-install gnus and mh-e, this time mh-e will not
byte-compile property (due to the same problem: a void variable
message-mark-insert-begin).

A workaround: If I remove the gnus package and just use the one that
comes with emacs21, mh-e compiles fine and everything seems to work
(though with an older version of gnus).

-Chris

- - -- --- ----- -------- ------------- ---------------------
Christopher J Peikert, MIT Computer Science & AI Lab, 32-G608
http://theory.csail.mit.edu/~cpeikert/
                 "A witty saying proves nothing." -- Voltaire

Revision history for this message
In , Steve Langasek (vorlon) wrote : block 342326 with 342521

# Automatically generated email from bts, devscripts version 2.9.9
block 342326 with 342521

Revision history for this message
In , Romain Francoise (rfrancoise) wrote : Reassigning to Gnus

unblock 342326 with 342521
severity 342647 grave
reassign 342647 gnus 5.10.6-1.NO.20051203-1
reassign 342326 gnus 5.10.6-1.NO.20051203-1
merge 342647 342326 342521
thanks, control

--
  ,''`.
 : :' : Romain Francoise <email address hidden>
 `. `' http://people.debian.org/~rfrancoise/
   `-

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #342326 http://bugs.debian.org/342326

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <20051207063808.10822.55673.reportbug@pornstar>
Date: Wed, 07 Dec 2005 01:38:08 -0500
From: Christopher J Peikert <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: mh-e fails to load, "void-variable message-mark-insert-begin"

Package: mh-e
Version: 7.85-1
Severity: grave
Justification: renders package unusable

Having just upgraded a lot of packages, I now get a
"Lisp error: (void-variable message-mark-insert-begin)"
error when trying to load mh-e from my .emacs file.

The full trace has lots of nasty binary data, but the
rough trace goes:

load mh-e -> mh-utils -> mh-customize -> mh-comp -> mh-gnus -> mm-uu

and in mm-uu:

(defvar mm-uu-type-alist ...
where we run into the void-variable message-mark-insert-begin.

Maybe something changed in gnus?

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.14-2-686
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages mh-e depends on:
ii emacs21 [emacsen] 21.4a-3 The GNU Emacs editor
hi nmh 1.1-release-4 A set of electronic mail handling

Versions of packages mh-e recommends:
ii compface 1989.11.11-24 Compress/decompress images for mai
ii gnus 5.10.6-1.NO.20051203-1 A versatile News and mailing list

-- no debconf information

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-Id: <E1Ek67J-0004QJ-Si@pornstar>
Date: Wed, 07 Dec 2005 15:42:21 -0500
From: Christopher J Peikert <email address hidden>
To: <email address hidden>
Subject: further information on failed load

Hi,

If I try to remove and re-install gnus and mh-e, this time mh-e will not
byte-compile property (due to the same problem: a void variable
message-mark-insert-begin).

A workaround: If I remove the gnus package and just use the one that
comes with emacs21, mh-e compiles fine and everything seems to work
(though with an older version of gnus).

-Chris

- - -- --- ----- -------- ------------- ---------------------
Christopher J Peikert, MIT Computer Science & AI Lab, 32-G608
http://theory.csail.mit.edu/~cpeikert/
                 "A witty saying proves nothing." -- Voltaire

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Thu, 8 Dec 2005 02:14:58 -0800
From: Steve Langasek <email address hidden>
To: <email address hidden>
Subject: block 342326 with 342521

# Automatically generated email from bts, devscripts version 2.9.9
block 342326 with 342521

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Fri, 09 Dec 2005 11:36:00 +0100
From: Romain Francoise <email address hidden>
To: <email address hidden>
Subject: Reassigning to Gnus

unblock 342326 with 342521
severity 342647 grave
reassign 342647 gnus 5.10.6-1.NO.20051203-1
reassign 342326 gnus 5.10.6-1.NO.20051203-1
merge 342647 342326 342521
thanks, control

--
  ,''`.
 : :' : Romain Francoise <email address hidden>
 `. `' http://people.debian.org/~rfrancoise/
   `-

Revision history for this message
Debian Bug Importer (debzilla) wrote :

*** Bug 26716 has been marked as a duplicate of this bug. ***

Revision history for this message
Debian Bug Importer (debzilla) wrote :

*** Bug 26832 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Romain Francoise (rfrancoise) wrote : Fixed upstream

tags 342521 upstream fixed-upstream
thanks, control

This bug has now been fixed in CVS.

--
Romain Francoise <email address hidden> | The sea! the sea! the open
it's a miracle -- http://orebokech.com/ | sea! The blue, the fresh, the
                                        | ever free! --Bryan W. Procter

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 12 Dec 2005 19:50:04 +0100
From: Romain Francoise <email address hidden>
To: <email address hidden>
Cc: <email address hidden>
Subject: Fixed upstream

tags 342521 upstream fixed-upstream
thanks, control

This bug has now been fixed in CVS.

--
Romain Francoise <email address hidden> | The sea! the sea! the open
it's a miracle -- http://orebokech.com/ | sea! The blue, the fresh, the
                                        | ever free! --Bryan W. Procter

Revision history for this message
In , Manoj (srivasta) wrote : Bug#342521: fixed in gnus 5.10.6-1.NO.20051213-1

Source: gnus
Source-Version: 5.10.6-1.NO.20051213-1

We believe that the bug you reported is fixed in the latest version of
gnus, which is due to be installed in the Debian FTP archive:

gnus_5.10.6-1.NO.20051213-1.diff.gz
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213-1.diff.gz
gnus_5.10.6-1.NO.20051213-1.dsc
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213-1.dsc
gnus_5.10.6-1.NO.20051213-1_all.deb
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213-1_all.deb
gnus_5.10.6-1.NO.20051213.orig.tar.gz
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213.orig.tar.gz

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Manoj Srivastava <email address hidden> (supplier of updated gnus package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 13 Dec 2005 20:09:09 -0600
Source: gnus
Binary: gnus
Architecture: source all
Version: 5.10.6-1.NO.20051213-1
Distribution: unstable
Urgency: low
Maintainer: Manoj Srivastava <email address hidden>
Changed-By: Manoj Srivastava <email address hidden>
Description:
 gnus - A versatile News and mailing list reader for Emacsen.
Closes: 342326 342521 342647
Changes:
 gnus (5.10.6-1.NO.20051213-1) unstable; urgency=low
 .
   * New upstream CVS HEAD
   * Bug fix: "mh-e fails to load, &quot;void-variable
     message-mark-insert-begin&quot;", thanks to Christopher J Peikert
     This has been fixed in CVS (no longer have mm-uu depend on message)
                                                        (Closes: #342326).
   * Bug fix: "gnus: immediate failure when loading mm-uu", thanks to
     Olivier Lecarme This has been fixed in CVS (no longer have mm-uu
     depend on message) (Closes: #342521).
   * Bug fix: "mh-e: does not configure with emacs-snapshot", thanks to
     Laurent Bonnaud (Closes: #342647).
Files:
 87e01e91a7617b9c35887b500706837c 641 news optional gnus_5.10.6-1.NO.20051213-1.dsc
 0cae1bb9e52ea868b76a2e1698744baf 2480129 news optional gnus_5.10.6-1.NO.20051213.orig.tar.gz
 5a2874d12d107bccf680f5d2f4b9d978 303631 news optional gnus_5.10.6-1.NO.20051213-1.diff.gz
 a89119dc3cbe209432e3e73f01b9bb36 2203448 news optional gnus_5.10.6-1.NO.20051213-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDn4EKIbrau78kQkwRAp6UAKDTZuBWR58bBesEYMnqyqOGh8NwcACfR1R4
iu+ZMcFYqwIgNwwF160MoSw=
=t7uw
-----END PGP SIGNATURE-----

Revision history for this message
In , Manoj (srivasta) wrote : Bug#342326: fixed in gnus 5.10.6-1.NO.20051213-1

Source: gnus
Source-Version: 5.10.6-1.NO.20051213-1

We believe that the bug you reported is fixed in the latest version of
gnus, which is due to be installed in the Debian FTP archive:

gnus_5.10.6-1.NO.20051213-1.diff.gz
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213-1.diff.gz
gnus_5.10.6-1.NO.20051213-1.dsc
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213-1.dsc
gnus_5.10.6-1.NO.20051213-1_all.deb
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213-1_all.deb
gnus_5.10.6-1.NO.20051213.orig.tar.gz
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213.orig.tar.gz

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Manoj Srivastava <email address hidden> (supplier of updated gnus package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 13 Dec 2005 20:09:09 -0600
Source: gnus
Binary: gnus
Architecture: source all
Version: 5.10.6-1.NO.20051213-1
Distribution: unstable
Urgency: low
Maintainer: Manoj Srivastava <email address hidden>
Changed-By: Manoj Srivastava <email address hidden>
Description:
 gnus - A versatile News and mailing list reader for Emacsen.
Closes: 342326 342521 342647
Changes:
 gnus (5.10.6-1.NO.20051213-1) unstable; urgency=low
 .
   * New upstream CVS HEAD
   * Bug fix: "mh-e fails to load, &quot;void-variable
     message-mark-insert-begin&quot;", thanks to Christopher J Peikert
     This has been fixed in CVS (no longer have mm-uu depend on message)
                                                        (Closes: #342326).
   * Bug fix: "gnus: immediate failure when loading mm-uu", thanks to
     Olivier Lecarme This has been fixed in CVS (no longer have mm-uu
     depend on message) (Closes: #342521).
   * Bug fix: "mh-e: does not configure with emacs-snapshot", thanks to
     Laurent Bonnaud (Closes: #342647).
Files:
 87e01e91a7617b9c35887b500706837c 641 news optional gnus_5.10.6-1.NO.20051213-1.dsc
 0cae1bb9e52ea868b76a2e1698744baf 2480129 news optional gnus_5.10.6-1.NO.20051213.orig.tar.gz
 5a2874d12d107bccf680f5d2f4b9d978 303631 news optional gnus_5.10.6-1.NO.20051213-1.diff.gz
 a89119dc3cbe209432e3e73f01b9bb36 2203448 news optional gnus_5.10.6-1.NO.20051213-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDn4EKIbrau78kQkwRAp6UAKDTZuBWR58bBesEYMnqyqOGh8NwcACfR1R4
iu+ZMcFYqwIgNwwF160MoSw=
=t7uw
-----END PGP SIGNATURE-----

Revision history for this message
In , Manoj (srivasta) wrote : Bug#342647: fixed in gnus 5.10.6-1.NO.20051213-1

Source: gnus
Source-Version: 5.10.6-1.NO.20051213-1

We believe that the bug you reported is fixed in the latest version of
gnus, which is due to be installed in the Debian FTP archive:

gnus_5.10.6-1.NO.20051213-1.diff.gz
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213-1.diff.gz
gnus_5.10.6-1.NO.20051213-1.dsc
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213-1.dsc
gnus_5.10.6-1.NO.20051213-1_all.deb
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213-1_all.deb
gnus_5.10.6-1.NO.20051213.orig.tar.gz
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213.orig.tar.gz

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Manoj Srivastava <email address hidden> (supplier of updated gnus package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 13 Dec 2005 20:09:09 -0600
Source: gnus
Binary: gnus
Architecture: source all
Version: 5.10.6-1.NO.20051213-1
Distribution: unstable
Urgency: low
Maintainer: Manoj Srivastava <email address hidden>
Changed-By: Manoj Srivastava <email address hidden>
Description:
 gnus - A versatile News and mailing list reader for Emacsen.
Closes: 342326 342521 342647
Changes:
 gnus (5.10.6-1.NO.20051213-1) unstable; urgency=low
 .
   * New upstream CVS HEAD
   * Bug fix: "mh-e fails to load, &quot;void-variable
     message-mark-insert-begin&quot;", thanks to Christopher J Peikert
     This has been fixed in CVS (no longer have mm-uu depend on message)
                                                        (Closes: #342326).
   * Bug fix: "gnus: immediate failure when loading mm-uu", thanks to
     Olivier Lecarme This has been fixed in CVS (no longer have mm-uu
     depend on message) (Closes: #342521).
   * Bug fix: "mh-e: does not configure with emacs-snapshot", thanks to
     Laurent Bonnaud (Closes: #342647).
Files:
 87e01e91a7617b9c35887b500706837c 641 news optional gnus_5.10.6-1.NO.20051213-1.dsc
 0cae1bb9e52ea868b76a2e1698744baf 2480129 news optional gnus_5.10.6-1.NO.20051213.orig.tar.gz
 5a2874d12d107bccf680f5d2f4b9d978 303631 news optional gnus_5.10.6-1.NO.20051213-1.diff.gz
 a89119dc3cbe209432e3e73f01b9bb36 2203448 news optional gnus_5.10.6-1.NO.20051213-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDn4EKIbrau78kQkwRAp6UAKDTZuBWR58bBesEYMnqyqOGh8NwcACfR1R4
iu+ZMcFYqwIgNwwF160MoSw=
=t7uw
-----END PGP SIGNATURE-----

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Tue, 13 Dec 2005 18:47:12 -0800
From: Manoj Srivastava <email address hidden>
To: <email address hidden>
Subject: Bug#342326: fixed in gnus 5.10.6-1.NO.20051213-1

Source: gnus
Source-Version: 5.10.6-1.NO.20051213-1

We believe that the bug you reported is fixed in the latest version of
gnus, which is due to be installed in the Debian FTP archive:

gnus_5.10.6-1.NO.20051213-1.diff.gz
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213-1.diff.gz
gnus_5.10.6-1.NO.20051213-1.dsc
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213-1.dsc
gnus_5.10.6-1.NO.20051213-1_all.deb
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213-1_all.deb
gnus_5.10.6-1.NO.20051213.orig.tar.gz
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213.orig.tar.gz

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Manoj Srivastava <email address hidden> (supplier of updated gnus package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 13 Dec 2005 20:09:09 -0600
Source: gnus
Binary: gnus
Architecture: source all
Version: 5.10.6-1.NO.20051213-1
Distribution: unstable
Urgency: low
Maintainer: Manoj Srivastava <email address hidden>
Changed-By: Manoj Srivastava <email address hidden>
Description:
 gnus - A versatile News and mailing list reader for Emacsen.
Closes: 342326 342521 342647
Changes:
 gnus (5.10.6-1.NO.20051213-1) unstable; urgency=low
 .
   * New upstream CVS HEAD
   * Bug fix: "mh-e fails to load, &quot;void-variable
     message-mark-insert-begin&quot;", thanks to Christopher J Peikert
     This has been fixed in CVS (no longer have mm-uu depend on message)
                                                        (Closes: #342326).
   * Bug fix: "gnus: immediate failure when loading mm-uu", thanks to
     Olivier Lecarme This has been fixed in CVS (no longer have mm-uu
     depend on message) (Closes: #342521).
   * Bug fix: "mh-e: does not configure with emacs-snapshot", thanks to
     Laurent Bonnaud (Closes: #342647).
Files:
 87e01e91a7617b9c35887b500706837c 641 news optional gnus_5.10.6-1.NO.20051213-1.dsc
 0cae1bb9e52ea868b76a2e1698744baf 2480129 news optional gnus_5.10.6-1.NO.20051213.orig.tar.gz
 5a2874d12d107bccf680f5d2f4b9d978 303631 news optional gnus_5.10.6-1.NO.20051213-1.diff.gz
 a89119dc3cbe209432e3e73f01b9bb36 2203448 news optional gnus_5.10.6-1.NO.20051213-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDn4EKIbrau78kQkwRAp6UAKDTZuBWR58bBesEYMnqyqOGh8NwcACfR1R4
iu+ZMcFYqwIgNwwF160MoSw=
=t7uw
-----END PGP SIGNATURE-----

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Tue, 13 Dec 2005 18:47:12 -0800
From: Manoj Srivastava <email address hidden>
To: <email address hidden>
Subject: Bug#342521: fixed in gnus 5.10.6-1.NO.20051213-1

Source: gnus
Source-Version: 5.10.6-1.NO.20051213-1

We believe that the bug you reported is fixed in the latest version of
gnus, which is due to be installed in the Debian FTP archive:

gnus_5.10.6-1.NO.20051213-1.diff.gz
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213-1.diff.gz
gnus_5.10.6-1.NO.20051213-1.dsc
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213-1.dsc
gnus_5.10.6-1.NO.20051213-1_all.deb
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213-1_all.deb
gnus_5.10.6-1.NO.20051213.orig.tar.gz
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213.orig.tar.gz

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Manoj Srivastava <email address hidden> (supplier of updated gnus package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 13 Dec 2005 20:09:09 -0600
Source: gnus
Binary: gnus
Architecture: source all
Version: 5.10.6-1.NO.20051213-1
Distribution: unstable
Urgency: low
Maintainer: Manoj Srivastava <email address hidden>
Changed-By: Manoj Srivastava <email address hidden>
Description:
 gnus - A versatile News and mailing list reader for Emacsen.
Closes: 342326 342521 342647
Changes:
 gnus (5.10.6-1.NO.20051213-1) unstable; urgency=low
 .
   * New upstream CVS HEAD
   * Bug fix: "mh-e fails to load, &quot;void-variable
     message-mark-insert-begin&quot;", thanks to Christopher J Peikert
     This has been fixed in CVS (no longer have mm-uu depend on message)
                                                        (Closes: #342326).
   * Bug fix: "gnus: immediate failure when loading mm-uu", thanks to
     Olivier Lecarme This has been fixed in CVS (no longer have mm-uu
     depend on message) (Closes: #342521).
   * Bug fix: "mh-e: does not configure with emacs-snapshot", thanks to
     Laurent Bonnaud (Closes: #342647).
Files:
 87e01e91a7617b9c35887b500706837c 641 news optional gnus_5.10.6-1.NO.20051213-1.dsc
 0cae1bb9e52ea868b76a2e1698744baf 2480129 news optional gnus_5.10.6-1.NO.20051213.orig.tar.gz
 5a2874d12d107bccf680f5d2f4b9d978 303631 news optional gnus_5.10.6-1.NO.20051213-1.diff.gz
 a89119dc3cbe209432e3e73f01b9bb36 2203448 news optional gnus_5.10.6-1.NO.20051213-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDn4EKIbrau78kQkwRAp6UAKDTZuBWR58bBesEYMnqyqOGh8NwcACfR1R4
iu+ZMcFYqwIgNwwF160MoSw=
=t7uw
-----END PGP SIGNATURE-----

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Tue, 13 Dec 2005 18:47:12 -0800
From: Manoj Srivastava <email address hidden>
To: <email address hidden>
Subject: Bug#342647: fixed in gnus 5.10.6-1.NO.20051213-1

Source: gnus
Source-Version: 5.10.6-1.NO.20051213-1

We believe that the bug you reported is fixed in the latest version of
gnus, which is due to be installed in the Debian FTP archive:

gnus_5.10.6-1.NO.20051213-1.diff.gz
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213-1.diff.gz
gnus_5.10.6-1.NO.20051213-1.dsc
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213-1.dsc
gnus_5.10.6-1.NO.20051213-1_all.deb
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213-1_all.deb
gnus_5.10.6-1.NO.20051213.orig.tar.gz
  to pool/main/g/gnus/gnus_5.10.6-1.NO.20051213.orig.tar.gz

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Manoj Srivastava <email address hidden> (supplier of updated gnus package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 13 Dec 2005 20:09:09 -0600
Source: gnus
Binary: gnus
Architecture: source all
Version: 5.10.6-1.NO.20051213-1
Distribution: unstable
Urgency: low
Maintainer: Manoj Srivastava <email address hidden>
Changed-By: Manoj Srivastava <email address hidden>
Description:
 gnus - A versatile News and mailing list reader for Emacsen.
Closes: 342326 342521 342647
Changes:
 gnus (5.10.6-1.NO.20051213-1) unstable; urgency=low
 .
   * New upstream CVS HEAD
   * Bug fix: "mh-e fails to load, &quot;void-variable
     message-mark-insert-begin&quot;", thanks to Christopher J Peikert
     This has been fixed in CVS (no longer have mm-uu depend on message)
                                                        (Closes: #342326).
   * Bug fix: "gnus: immediate failure when loading mm-uu", thanks to
     Olivier Lecarme This has been fixed in CVS (no longer have mm-uu
     depend on message) (Closes: #342521).
   * Bug fix: "mh-e: does not configure with emacs-snapshot", thanks to
     Laurent Bonnaud (Closes: #342647).
Files:
 87e01e91a7617b9c35887b500706837c 641 news optional gnus_5.10.6-1.NO.20051213-1.dsc
 0cae1bb9e52ea868b76a2e1698744baf 2480129 news optional gnus_5.10.6-1.NO.20051213.orig.tar.gz
 5a2874d12d107bccf680f5d2f4b9d978 303631 news optional gnus_5.10.6-1.NO.20051213-1.diff.gz
 a89119dc3cbe209432e3e73f01b9bb36 2203448 news optional gnus_5.10.6-1.NO.20051213-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDn4EKIbrau78kQkwRAp6UAKDTZuBWR58bBesEYMnqyqOGh8NwcACfR1R4
iu+ZMcFYqwIgNwwF160MoSw=
=t7uw
-----END PGP SIGNATURE-----

Revision history for this message
Matt Zimmerman (mdz) wrote :

      gnus | 5.10.6-1.NO.20051213-1 | http://us.archive.ubuntu.com dapper/main Packages

Changed in gnus:
status: Unconfirmed → Fix Released
Revision history for this message
In , Steve Langasek (vorlon) wrote : closing 342326

# Automatically generated email from bts, devscripts version 2.9.19
 # get the case of the version number right
close 342326 5.10.6-1.NO.20051213-1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.