Please add gnumeric-dev package

Bug #1006242 reported by Albert Graef
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnumeric (Debian)
Fix Released
Unknown
gnumeric (Ubuntu)
Undecided
Unassigned

Bug Description

The gnumeric packages in Ubuntu currently lack the development files. Apparently (according to a comment in the rules file) libspreadsheet isn't considered mature enough. This is a mistake IMHO. Mature or not, these files are needed, in particular, to build Gnumeric plugins which are not built as part of Gnumeric itself. An example is my PPA here: https://launchpad.net/~dr-graef/+archive/pure-lang. Currently I have to provide an alternative set of Gnumeric packages which includes the development files just in order to build the Gnumeric Pure plugin.

Adding the development package is trivial:

1. Remove these three lines in the rules file:

 rm -f debian/tmp/usr/lib/libspreadsheet*.la
 rm -f debian/tmp/usr/lib/pkgconfig/libspreadsheet-*.pc
 rm -rf debian/tmp/usr/include/libspreadsheet-*

2. Add something like the following package description to the control file:

Package: gnumeric-dev
Architecture: any
Depends: gnumeric (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends},
 libgoffice-0.8-dev
Description: spreadsheet application for GNOME - development files
 Gnumeric is a spreadsheet application that interoperates well
 with other spreadsheets. It comes with plugins that enable it to deal with
 commonly used spreadsheet file formats.
 .
 This package contains the headers and libraries needed for developing
 gnumeric plugins.

3. Add the following file gnumeric-dev.install:

/usr/include
/usr/lib/pkgconfig
/usr/lib/*.la

Revision history for this message
Albert Graef (dr-graef) wrote :

16 months later and this issue is still there and not even a reply. Is anyone reading these bug reports at all? Shoulkd I report the bug somewhere else?

This issue may not be important for many, as there aren't many 3rd party developers of Gnumeric plugins right now, but it's important for me. Not being able to build a Gnumeric plugins out of tree using the stock Ubuntu packages of Gnumeric means that packaging external Gnumeric plugins here on Launchpad is a major pita. This should be fixed. At least if the Gnumeric developers are interested in 3rd party plugin development.

Come on, this should be worth at least a canned reply of the kind "libspreadsheet is still not mature enough and probably it will never be, so you're on your own". Noone?

Revision history for this message
Jackson Doak (noskcaj) wrote : Re: [Bug 1006242] Re: Please add gnumeric-dev package

We can't use .la files, it's against all the policies we have.

On Thu, Sep 19, 2013 at 8:09 PM, Albert Graef <email address hidden> wrote:
> 16 months later and this issue is still there and not even a reply. Is
> anyone reading these bug reports at all? Shoulkd I report the bug
> somewhere else?
>
> This issue may not be important for many, as there aren't many 3rd party
> developers of Gnumeric plugins right now, but it's important for me. Not
> being able to build a Gnumeric plugins out of tree using the stock
> Ubuntu packages of Gnumeric means that packaging external Gnumeric
> plugins here on Launchpad is a major pita. This should be fixed. At
> least if the Gnumeric developers are interested in 3rd party plugin
> development.
>
> Come on, this should be worth at least a canned reply of the kind
> "libspreadsheet is still not mature enough and probably it will never
> be, so you're on your own". Noone?
>
> --
> You received this bug notification because you are a member of Xubuntu
> Bugs Team, which is subscribed to gnumeric in Ubuntu.
> https://bugs.launchpad.net/bugs/1006242
>
> Title:
> Please add gnumeric-dev package
>
> Status in “gnumeric” package in Ubuntu:
> New
>
> Bug description:
> The gnumeric packages in Ubuntu currently lack the development files.
> Apparently (according to a comment in the rules file) libspreadsheet
> isn't considered mature enough. This is a mistake IMHO. Mature or not,
> these files are needed, in particular, to build Gnumeric plugins which
> are not built as part of Gnumeric itself. An example is my PPA here:
> https://launchpad.net/~dr-graef/+archive/pure-lang. Currently I have
> to provide an alternative set of Gnumeric packages which includes the
> development files just in order to build the Gnumeric Pure plugin.
>
> Adding the development package is trivial:
>
> 1. Remove these three lines in the rules file:
>
> rm -f debian/tmp/usr/lib/libspreadsheet*.la
> rm -f debian/tmp/usr/lib/pkgconfig/libspreadsheet-*.pc
> rm -rf debian/tmp/usr/include/libspreadsheet-*
>
> 2. Add something like the following package description to the control
> file:
>
> Package: gnumeric-dev
> Architecture: any
> Depends: gnumeric (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends},
> libgoffice-0.8-dev
> Description: spreadsheet application for GNOME - development files
> Gnumeric is a spreadsheet application that interoperates well
> with other spreadsheets. It comes with plugins that enable it to deal with
> commonly used spreadsheet file formats.
> .
> This package contains the headers and libraries needed for developing
> gnumeric plugins.
>
> 3. Add the following file gnumeric-dev.install:
>
> /usr/include
> /usr/lib/pkgconfig
> /usr/lib/*.la
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/gnumeric/+bug/1006242/+subscriptions

Revision history for this message
Albert Graef (dr-graef) wrote :

On Thu, Sep 19, 2013 at 10:21 PM, Jackson Doak <email address hidden> wrote:
> We can't use .la files, it's against all the policies we have.

Ok, I actually don't need the .la files, so just leave them out. But I
do need the header and pkg-config files
(/usr/include/libspreadsheet-*/spreadsheet and
/usr/lib/pkgconfig/libspreadsheet-*.pc), and these aren't in any
package right now. The rules file in the most recent Debian package at
http://packages.debian.org/unstable/math/gnumeric differs from the
older one my bug report referred to, though. But the latest packages
obviously don't provide the include and pc files either.

If it helps, I can look at the latest source package and see what
changes would be needed there. But I'd first like to get some feedback
on whether the package maintainers would consider this at all.

If excluding those development files from the Debian packages is a
conscious decision, then so be it. But you must be aware that this
makes it really hard if not impossible for 3rd party plugin developers
to maintain Debian packages for their plugins, and this can't be in
the interest of the Gnumeric project.

Albert

--
Dr. Albert Gr"af
Dept. of Music-Informatics, University of Mainz, Germany
Email: <email address hidden>
WWW: https://plus.google.com/111193356966611167754

Revision history for this message
Albert Graef (dr-graef) wrote :

Ok, I actually don't need the .la files, so just leave them out. But I do need the header and pkg-config files (/usr/include/libspreadsheet-*/spreadsheet and /usr/lib/pkgconfig/libspreadsheet-*.pc), and these aren't in any package right now. The rules file in the most recent Debian package at http://packages.debian.org/unstable/math/gnumeric differs from the older one my bug report referred to, though. But the latest packages obviously don't provide the include and pc files either.

If it helps, I can look at the latest source package and see what changes would be needed there. But I'd first like to get some feedback on whether the package maintainers would consider this at all.

If excluding those development files from the Debian/Ubuntu packages is a conscious decision, then so be it. But you must be aware that this makes it really hard if not impossible for 3rd party plugin developers to maintain Debian packages for their plugins, and this can't be in the interest of the Gnumeric project.

Revision history for this message
Jackson Doak (noskcaj) wrote :

Contact the debian maintainer. He's the one to be asking about this.

Revision history for this message
Albert Graef (dr-graef) wrote :

Ok, will try that route, thanks.

Revision history for this message
Albert Graef (dr-graef) wrote :

Just for the record, I've filed a Debian bug report as ticket #723903, see here: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=723903

Jackson Doak (noskcaj)
Changed in gnumeric (Ubuntu):
status: New → Confirmed
Changed in gnumeric (Debian):
status: Unknown → New
Changed in gnumeric (Debian):
status: New → Fix Committed
Changed in gnumeric (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.