Ubuntu

Gnote prevents itself from showing in Dash

Reported by Matthew Babbs on 2011-11-09
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Gnote
Fix Released
Low
gnote (Ubuntu)
Medium
Andrew Starr-Bochicchio
Oneiric
Medium
Andrew Starr-Bochicchio

Bug Description

Gnote does not appear as a launcher in the Unity Dash.

Steps to reproduce:
1. Install Gnote
2. Look for Gnote in the Dash

The cause is a line in /usr/share/applications/gnote.desktop:

Which prevents Gnote from appearing in Unity.

The attached patch corrects this by adding unity to the list of allowed contexts. I've tested it under Oneiric i386 and amd64.

Matthew Babbs (matt-babbs) wrote :
Matthew Babbs (matt-babbs) wrote :

Sorry, that should be -
> The cause is a line in /usr/share/applications/gnote.desktop:
> OnlyShowIn=GNOME;XFCE;
> Which prevents Gnote from appearing in Unity.

The attachment "show_in_unity_dash.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnote (Ubuntu):
status: New → Confirmed
Changed in gnote (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
Changed in gnote (Ubuntu Oneiric):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnote - 0.8.1-1ubuntu1

---------------
gnote (0.8.1-1ubuntu1) precise; urgency=low

  * debian/patches/show_in_unity_dash.patch:
   - Patch by Matthew K Babbs adding Unity to
     OnlyShowIn field of desktop file (LP: #888274).
 -- Andrew Starr-Bochicchio <email address hidden> Tue, 22 Nov 2011 22:33:38 -0500

Changed in gnote (Ubuntu):
status: In Progress → Fix Released

Hello Matthew, or anyone else affected,

Accepted gnote into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnote (Ubuntu Oneiric):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in gnote:
importance: Unknown → Low
status: Unknown → New
Mikael Ståldal (mikaelstaldal) wrote :

I upgraded to the proposed version of gnote, and now my /usr/share/applications/gnote.desktop has this line:
OnlyShowIn=GNOME;Unity;XFCE;

But it still doesn't work.

On Thu, Nov 24, 2011 at 10:42 AM, Mikael Ståldal
<email address hidden> wrote:
> I upgraded to the proposed version of gnote, and now my  /usr/share/applications/gnote.desktop has this line:
> OnlyShowIn=GNOME;Unity;XFCE;
>
> But it still doesn't work.

Could you be a little more specific. Can you still not find it in the
Dash? Or can you not pin it to the launcher? There's really two bugs
here with the same cause. Could you try logging out and then back in?
For me, I can immediately find gnote in the Dash with the package in
proposed. In order to properly pin it in the launcher, I had to log
out and then back in.

Thanks!

Mikael Ståldal (mikaelstaldal) wrote :

Sorry, I have misinterpreted this bug. It does indeed show up in the Dash now, as it should. Pinning seems to be available as well.

It doesn't show up in the notification area (or whatever the right part of the top panel is called in Unity) though. This is what bug https://bugs.launchpad.net/ubuntu/+source/gnote/+bug/880899 is about, someone has incorrectly marked it as duplicate of this one.

Sorry about that. I miss-interpreted the other bug based on a comment on
it. I've unmarked it as a duplicate.

Changed in gnote:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

The comment confirm that it's showing in the dash now, setting to verification-done

tags: added: verification-done
removed: verification-needed
Brian Murray (brian-murray) wrote :

Using gnote version I 0.7.5-1ubuntu1was able to recreate this bug report. Then I installed gnote version 0.7.5-1ubuntu1.1 from oneiric-proposed and gnote showed up in the dash.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnote - 0.7.5-1ubuntu1.1

---------------
gnote (0.7.5-1ubuntu1.1) oneiric-proposed; urgency=low

  * debian/patches/show_in_unity_dash.patch:
   - Patch by Matthew K Babbs adding Unity to
     OnlyShowIn field of desktop file (LP: #888274).
 -- Andrew Starr-Bochicchio <email address hidden> Tue, 22 Nov 2011 22:54:42 -0500

Changed in gnote (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.