Ubuntu

gnomebaker crash when adding multiple files

Reported by razboinik on 2008-12-15
40
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cairo (Ubuntu)
Medium
Unassigned
gnomebaker (Ubuntu)
Undecided
Unassigned

Bug Description

I get this error, im using gnomebaker 0.6.4 which comes with 8.10

*** glibc detected *** gnomebaker: corrupted double-linked list: 0x0a5431f0 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0xb7247f1f]
/lib/tls/i686/cmov/libc.so.6[0xb7249a2d]
/lib/tls/i686/cmov/libc.so.6(__libc_malloc+0x95)[0xb724b865]
/usr/lib/libcairo.so.2(cairo_create+0x39)[0xb77a0279]
/usr/lib/libgdk-x11-2.0.so.0[0xb792abd6]
/usr/lib/libgdk-x11-2.0.so.0[0xb792ad03]
/usr/lib/libgdk-x11-2.0.so.0(gdk_window_begin_paint_region+0x1bb)[0xb792d56b]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main_do_event+0x51e)[0xb7aaf12e]
/usr/lib/libgdk-x11-2.0.so.0[0xb792d9b5]
/usr/lib/libgdk-x11-2.0.so.0(gdk_window_process_all_updates+0xff)[0xb792dfcf]
/usr/lib/libgdk-x11-2.0.so.0[0xb792dffb]
/usr/lib/libgdk-x11-2.0.so.0[0xb791146b]
/usr/lib/libglib-2.0.so.0[0xb75d07c1]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x1e8)[0xb75d26f8]
/usr/lib/libglib-2.0.so.0[0xb75d5da3]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1d2)[0xb75d62c2]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xb9)[0xb7aaf3a9]
gnomebaker(main+0x23e)[0x80564ee]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5)[0xb71ee685]
gnomebaker[0x8056171]
======= Memory map: ========
08048000-0808e000 r-xp 00000000 fe:00 11486 /usr/bin/gnomebaker
0808e000-0808f000 r--p 00046000 fe:00 11486 /usr/bin/gnomebaker
0808f000-08090000 rw-p 00047000 fe:00 11486 /usr/bin/gnomebaker
09fab000-0a574000 rw-p 09fab000 00:00 0 [heap]
b4189000-b4196000 r-xp 00000000 fe:00 99158 /lib/libgcc_s.so.1
b4196000-b4197000 r--p 0000c000 fe:00 99158 /lib/libgcc_s.so.1
b4197000-b4198000 rw-p 0000d000 fe:00 99158 /lib/libgcc_s.so.1
b4198000-b41af000 r--s 00000000 fe:00 231381 /usr/share/mime/mime.cache
b41af000-b41b2000 r-xp 00000000 fe:00 97939 /lib/libattr.so.1.1.0
b41b2000-b41b4000 rw-p 00003000 fe:00 97939 /lib/libattr.so.1.1.0
b41b4000-b41bb000 r-xp 00000000 fe:00 1106267 /usr/lib/libfam.so.0.0.0
b41bb000-b41bc000 rw-p 00006000 fe:00 1106267 /usr/lib/libfam.so.0.0.0
b41bc000-b41c2000 r-xp 00000000 fe:00 97931 /lib/libacl.so.1.1.0
b41c2000-b41c4000 rw-p 00005000 fe:00 97931 /lib/libacl.so.1.1.0
b41da000-b41e6000 r-xp 00000000 fe:00 213680 /usr/lib/gnome-vfs-2.0/modules/libfile.so
b41e6000-b41e7000 r--p 0000b000 fe:00 213680 /usr/lib/gnome-vfs-2.0/modules/libfile.so
b41e7000-b41e8000 rw-p 0000c000 fe:00 213680 /usr/lib/gnome-vfs-2.0/modules/libfile.so
b41e8000-b4248000 rw-s 00000000 00:09 139919383 /SYSV00000000 (deleted)
b4248000-b4249000 ---p b4248000 00:00 0
b4249000-b4a49000 rw-p b4249000 00:00 0
b4a49000-b4aa9000 rw-s 00000000 00:09 139755531 /SYSV00000000 (deleted)
b4aa9000-b4bad000 rw-p b4aa9000 00:00 0
b4bad000-b4c36000 r--p 00000000 fe:00 272113 /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-Bold.ttf
b4c36000-b4d3a000 rw-p b4c36000 00:00 0
b4d3a000-b4dcf000 r--p 00000000 fe:00 272126 /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans.ttf
b4dcf000-b4dd1000 r-xp 00000000 fe:00 419536 /usr/lib/pango/1.6.0/modules/pango-basic-fc.so
b4dd1000-b4dd2000 r--p 00001000 fe:00 419536 /usr/lib/pango/1.6.0/modules/pango-basic-fc.so
b4dd2000-b4dd3000 rw-p 00002000 fe:00 419536 /usr/lib/pango/1.6.0/modules/pango-basic-fc.so
b4dd3000-b4dd9000 r--s 00000000 fe:00 565552 /var/cache/fontconfig/945677eb7aeaf62f1d50efc3fb3ec7d8-x86.cache-2
b4dd9000-b4dda000 r--s 00000000 fe:00 565771 /var/cache/fontconfig/99e8ed0e538f840c565b6ed5dad60d56-x86.cache-2
b4dda000-b4ddd000 r--s 00000000 fe:00 565770 /var/cache/fontconfig/e383d7ea5fbe662a33d9b44caf393297-x86.cache-2
b4ddd000-b4de0000 r--s 00000000 fe:00 565753 /var/cache/fontconfig/6eb3985aa4124903f6ff08ba781cd364-x86.cache-2
b4de0000-b4de2000 r--s 00000000 fe:00 565750 /var/cache/fontconfig/646addb8444faa74ee138aa00ab0b6a0-x86.cache-2
b4de2000-b4de5000 r--s 00000000 fe:00 565749 /var/cache/fontconfig/a755afe4a08bf5b97852ceb7400b47bc-x86.cache-2
b4de5000-b4dec000 r--s 00000000 fe:00 565748 /var/cache/fontconfig/6d41288fd70b0be22e8c3a91e032eec0-x86.cache-2
b4dec000-b4df4000 r--s 00000000 fe:00 565745 /var/cache/fontconfig/e3de0de479f42330eadf588a55fb5bf4-x86.cache-2
b4df4000-b4dff000 r--s 00000000 fe:00 565712 /var/cache/fontconfig/0f34bcd4b6ee430af32735b75db7f02b-x86.cache-2
b4dff000-b4e00000 ---p b4dff000 00:00 0
b4e00000-b5600000 rw-p b4e00000 00:00 0
b5600000-b5621000 rw-p b5600000 00:00 0
b5621000-b5700000 ---p b5621000 00:00 0
b5701000-b5704000 r--s 00000000 fe:00 565747 /var/cache/fontconfig/de156ccd2eddbdc19d37a45b8b2aac9c-x86.cache-2
b5704000-b5711000 r--s 00000000 fe:00 565538 /var/cache/fontconfig/e13b20fdb08344e0e664864cc2ede53d-x86.cache-2
b5711000-b5712000 ---p b5711000 00:00 0
b5712000-b5f12000 rw-p b5712000 00:00 0
b5f12000-b5f29000 r--s 00000000 fe:00 231381 /usr/share/mime/mime.cache
b5f29000-b6233000 r--p 00000000 fe:00 313511 /usr/share/icons/hicolor/icon-theme.cache
b6233000-b6247000 r-xp 00000000 fe:00 1106047 /usr/lib/libbeagle.so.1.0.2
b6247000-b6248000 rw-p 00014000 fe:00 1106047 /usr/lib/libbeagle.so.1.0.2
b6248000-b6250000 r-xp 00000000 fe:00 1103396 /usr/lib/libtrackerclient.so.0.0.0
b6250000-b6251000 r--p 00007000 fe:00 1103396 /usr/lib/libtrackerclient.so.0.0.0
b6251000-b6252000 rw-p 00008000 fe:00 1103396 /usr/lib/libtrackerclient.so.0.0.0
b6252000-b626a000 r-xp 00000000 fe:00 346177 /usr/lib/gio/modules/libgvfsdbus.so
b626a000-b626b000 r--p 00017000 fe:00 346177 /usr/lib/gio/modules/libgvfsdbus.so
b626b000-b626c000 rw-p 00018000 fe:00 346177 /usr/lib/gio/modules/libgvfsdbus.so
b626c000-b6279000 r-xp 00000000 fe:00 1105921 /usr/lib/libgvfscommon.so.0.0.0
b6279000-b627a000 r--p 0000d000 fe:00 1105921 /usr/lib/libgvfscommon.so.0.0.0
b627a000-b627b000 rw-p 0000e000 fe:00 1105921 /usr/lib/libgvfscommon.so.0.0.0
b627c000-b6283000 r--s 00000000 fe:00 565723 /var/cache/fontconfig/d52a8644073d54c13679302ca1180695-x86.cache-2
b6283000-b6291000 r--s 00000000 fe:00 565551 /var/cache/fontconfig/865f88548240fee46819705c6468c165-x86.cache-2
b6291000-b629c000 r-xp 00000000 fe:00 346176 /usr/lib/gio/modules/libgioremote-volume-monitor.so
b629c000-b629d000 r--p 0000a000 fe:00 346176 /usr/lib/gio/modules/libgioremote-volume-monitor.so
b629d000-b629e000 rw-p 0000b000 fe:00 346176 /usr/lib/gio/modules/libgioremote-volume-monitor.so
b629e000-b62e7000 r-xp 00000000 fe:00 1105122 /usr/lib/libtheora.so.0.3.3
b62e7000-b62e9000 rw-p 00049000 fe:00 1105122 /usr/lib/libtheora.so.0.3.3
b62e9000-b62f5000 r-xp 00000000 fe:00 1105514 /usr/lib/libgsm.so.1.0.12
b62f5000-b62f6000 rw-p 0000b000 fe:00 1105514 /usr/lib/libgsm.so.1.0.12
b62f6000-b6301000 r-xp 00000000 fe:00 232049 /usr/lib/i686/cmov/libavutil.so.49.6.0
b6301000-b6302000 r--p 0000a000 fe:00 232049 /usr/lib/i686/cmov/libavutil.so.49.6.0
b6302000-b6303000 rw-p 0000b000 fe:00 232049 /usr/lib/i686/cmov/libavutil.so.49.6.0
b6303000-b6306000 rw-p b6303000 00:00 0
b6306000-b6756000 r-xp 00000000 fe:00 232045 /usr/lib/i686/cmov/libavcodec.so.51.50.0
b6756000-b6757000 r--p 0044f000 fe:00 232045 /usr/lib/i686/cmov/libavcodec.so.51.50.0
b6757000-b675d000 rw-p 00450000 fe:00 232045 /usr/lib/i686/cmov/libavcodec.so.51.50.0
b675d000-b6853000 rw-p b675d000 00:00 0
b6853000-b68f0000 r-xp 00000000 fe:00 232043 /usr/lib/i686/cmov/libavformat.so.52.7.0
b68f0000-b68f1000 r--p 0009c000 fe:00 232043 /usr/lib/i686/cmov/libavformat.so.52.7.0
b68f1000-b68f4000 rw-p 0009d000 fe:00 232043 /usr/lib/i686/cmov/libavformat.so.52.7.0
b68f4000-b6922000 r-xp 00000000 fe:00 419697 /usr/lib/gstreamer-0.10/libgstffmpeg.so
b6922000-b6923000 ---p 0002e000 fe:00 419697 /usr/lib/gstreamer-0.10/libgstffmpeg.so
b6923000-b6924000 r--p 0002e000 fe:00 419697 /usr/lib/gstreamer-0.10/libgstffmpeg.so
b6924000-b6925000 rw-p 0002f000 fe:00 419697 /usr/lib/gstreamer-0.10/libgstffmpeg.so
b6925000-b6930000 r-xp 00000000 fe:00 1106263 /usr/lib/libgstriff-0.10.so.0.15.0
b6930000-b6931000 r--p 0000a000 fe:00 1106263 /usr/lib/libgstriff-0.10.so.0.15.0
b6931000-b6932000 rw-p 0000b000 fe:00 1106263 /usr/lib/libgstriff-0.10.so.0.15.0
b6933000-b6934000 r--s 00000000 fe:00 1096251 /usr/local/share/mime/mime.cache
b6934000-b693a000 r--s 00000000 fe:00 565539 /var/cachAborted

EricDHH (ericdhh) wrote :
Download full text (18.1 KiB)

Confirm on amd64 8.10.

When adding mp3 files to an audio list i get a crash, when adding files one by one the tag listview will do

name title
name name title title
name name name title title title

and so on till crash.

eric@charon:~$ gnomebaker
vendor = TOSHIBA, model = DVD-ROM SD-M1712 device = °Ý¹
vendor = HL-DT-ST, model = DVDRAM GSA-H44N device = à¹
*** glibc detected *** gnomebaker: corrupted double-linked list: 0x0000000001143490 ***
======= Backtrace: =========
/lib/libc.so.6[0x7f3ca94aa83c]
/lib/libc.so.6[0x7f3ca94ac601]
/lib/libc.so.6(__libc_malloc+0x98)[0x7f3ca94ae538]
/usr/lib/libcairo.so.2[0x7f3cab69ba4b]
/usr/lib/libcairo.so.2[0x7f3cab69be7e]
/usr/lib/libcairo.so.2[0x7f3cab68b472]
/usr/lib/libcairo.so.2[0x7f3cab68a6c1]
/usr/lib/libcairo.so.2[0x7f3cab68c2e9]
/usr/lib/libcairo.so.2[0x7f3cab69ae92]
/usr/lib/libcairo.so.2[0x7f3cab697882]
/usr/lib/libcairo.so.2[0x7f3cab680da3]
/usr/lib/libcairo.so.2(cairo_stroke_preserve+0x20)[0x7f3cab67bad0]
/usr/lib/libcairo.so.2(cairo_stroke+0x9)[0x7f3cab67bae9]
/usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so[0x7f3ca38e0c5c]
/usr/lib/libgtk-x11-2.0.so.0[0x7f3caca32631]
/usr/lib/libgtk-x11-2.0.so.0[0x7f3caca2b908]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x16d)[0x7f3caab1b25d]
/usr/lib/libgobject-2.0.so.0[0x7f3caab30c3b]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x63a)[0x7f3caab3248a]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x83)[0x7f3caab32b33]
/usr/lib/libgtk-x11-2.0.so.0[0x7f3cacb2e74e]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main_do_event+0x4ed)[0x7f3caca2559d]
/usr/lib/libgdk-x11-2.0.so.0[0x7f3cac6915b5]
/usr/lib/libgdk-x11-2.0.so.0(gdk_window_process_all_updates+0xf1)[0x7f3cac691b41]
/usr/lib/libgdk-x11-2.0.so.0[0x7f3cac691b69]
/usr/lib/libgdk-x11-2.0.so.0[0x7f3cac67595b]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x23b)[0x7f3caa67ed3b]
/usr/lib/libglib-2.0.so.0[0x7f3caa68250d]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1cd)[0x7f3caa682a3d]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xa7)[0x7f3caca257a7]
gnomebaker(main+0x1d8)[0x4124e8]
/lib/libc.so.6(__libc_start_main+0xe6)[0x7f3ca944e466]
gnomebaker[0x4121b9]
======= Memory map: ========
00400000-0044b000 r-xp 00000000 08:01 195217 /usr/bin/gnomebaker
0064b000-0064c000 r--p 0004b000 08:01 195217 /usr/bin/gnomebaker
0064c000-0064e000 rw-p 0004c000 08:01 195217 /usr/bin/gnomebaker
00997000-011d1000 rw-p 00997000 00:00 0 [heap]
41340000-41341000 ---p 41340000 00:00 0
41341000-41b41000 rwxp 41341000 00:00 0
41b41000-41b42000 ---p 41b41000 00:00 0
41b42000-42342000 rwxp 41b42000 00:00 0
42342000-42343000 ---p 42342000 00:00 0
42343000-42b43000 rwxp 42343000 00:00 0
7f3c97317000-7f3c97389000 r-xp 00000000 08:01 195865 /usr/lib/liboil-0.3.so.0.3.0
7f3c97389000-7f3c97588000 ---p 00072000 08:01 195865 /usr/lib/liboil-0.3.so.0.3.0
7f3c97588000-7f3c97589000 r--p 00071000 08:01 195865 /usr/lib/liboil-0.3.so.0.3.0
7f3c97589000-7f3c975a4000 rw-p 00072000 08:01 195865 /usr/lib/liboil-0.3.so.0.3.0
7f3c975a4000-7f3c975a6000 rw-p 7f3c975a400...

bucker (bucker-nrg) wrote :

Confirm on i386 8.10 too.

$ gnomebaker
vendor = Optiarc, model = DVD RW AD-7170A device = �����
*** glibc detected *** gnomebaker: corrupted double-linked list: 0xb5605788 ***

See attachment for details.

Cruncher (ubuntu-wkresse) wrote :

Confirm. Happens in almost all cases when I try to add files from a vfat partition, not sure whether this is related, though.

This bug occures since my upgrade to 8.10, which installed gnomebaker 0.6.4. The problem never occured with my previous version, 0.6.2-3ubuntu1.

Any volunteers for this?

Cruncher (ubuntu-wkresse) wrote :

Update: This is most probably *not* a bug in gnomebaker itself - after downgrading to 0.6.2-3ubuntu1 I get the same crashes.
So I reverted back to 0.6.4-1, and downgraded libcairo2 instead (see the first relevant backtrace entry in all of the above logs):
libcairo2 1.6.0-0ubuntu2 (hardy-updates) instead of 1.8.0-0ubuntu1.1 (intrepid)

I also had to downgrade libpango since it didn't work with the older libcairo2:
libpango1.0-0 1.20.5-0ubuntu1 (hardy-updates) instead of 1.22.2-0ubuntu1 (intrepid-updates)

*WARNING*, preforming this downgrade causes many broken packages in intrepid, since they depend on libpango1.0-0 >=1.21.6, which again depends on a newer libcairo2 (I tried libpango1.0-0 1.21.6 with libcairo2 1.7.4, but that still causes gnomebaker crashes (although it appears to be less often).

However, gnomebaker 0.6.4-1 does work fine with libcairo2 1.6.0-0ubuntu2.

Changed in gnomebaker:
status: New → Invalid
status: Invalid → New
Cruncher (ubuntu-wkresse) wrote :

oops, sorry, tried to add new package

Changed in cairo:
status: New → Invalid
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a valgrind log following the instructions at https://wiki.ubuntu.com/Valgrind and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in cairo (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
razboinik (razboinik) wrote :

Well running without valgrid crashed

gnomebaker

** (gnomebaker:21520): WARNING **: gbcommon_close_temp_file - Temporary file descriptor [/tmp/GnomeBaker-xxxxxx/gnomebaker-TRMPQU] could not be closed
Segmentation fault

without valgrind it didnt with the same exact steps
log attached

G_SLICE=always-malloc G_DEBUG=gc-friendly valgrind -v --tool=memcheck --leak-check=full --num-callers=40 --log-file=valgrind.log gnomebaker

** (gnomebaker:21538): WARNING **: gbcommon_close_temp_file - Temporary file descriptor [/tmp/GnomeBaker-xxxxxx/gnomebaker-ZMSSQU] could not be closed

** (gnomebaker:21538): WARNING **: gbcommon_close_temp_file - Temporary file descriptor [/tmp/GnomeBaker-xxxxxx/gnomebaker-JYYRQU] could not be closed

Cruncher (ubuntu-wkresse) wrote :

Hm, for obvious Murphy reasons, I can no longer reproduce the crashes, with or without valgrind. Currently installed:
ii gnomebaker 0.6.4-1 application for CD/DVD creation in the GNOME desktop
ii libcairo2 1.7.4-0ubuntu2 The Cairo 2D vector graphics library
ii libcairo2-dbg 1.7.4-0ubuntu2 The Cairo 2D vector graphics library (debugging symbols)
ii libcairo2-dev 1.7.4-0ubuntu2 Development files for the Cairo 2D graphics library
ii libpango1.0-0 1.21.6-1 Layout and rendering of internationalized text
ii libpango1.0-common 1.21.6-1 Modules and configuration files for the Pango
ii libpango1.0-dev 1.21.6-1 Development files for the Pango

On the other hand, earlier today I even got crashes with the libcairo2 1.6.0-0ubuntu2...

And some crashes were even different and didn't happen within cairo. But they might be caused by me keeping installing and removing different versions of those libs all the time (not while gnomebaker was running, though), so something could have been temporarily messed up. Here is an excerpt from such a crash:
*** glibc detected *** gnomebaker: realloc(): invalid pointer: 0x08e82d68 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0xb72c3454]
/lib/tls/i686/cmov/libc.so.6(realloc+0x242)[0xb72c7f22]
/usr/lib/libglib-2.0.so.0(g_realloc+0x3a)[0xb7656c4a]
/usr/lib/libgobject-2.0.so.0(g_object_weak_ref+0xb1)[0xb76de361]
/usr/lib/libgobject-2.0.so.0(g_object_add_weak_pointer+0x92)[0xb76de482]
/usr/lib/libgtk-x11-2.0.so.0[0xb7c014ea]
/usr/lib/libgtk-x11-2.0.so.0[0xb7c02467]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main_do_event+0x1cd)[0xb7b2addd]

And a different one with different message:
*** glibc detected *** gnomebaker: free(): invalid pointer: 0x0a566b60 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0xb7305454]
/lib/tls/i686/cmov/libc.so.6(cfree+0x96)[0xb73074b6]
/usr/lib/libcairo.so.2[0xb7866143]
/usr/lib/libcairo.so.2[0xb78544df]
/usr/lib/libcairo.so.2[0xb785e2b1]
/usr/lib/libcairo.so.2[0xb786b6c7]
/usr/lib/libcairo.so.2[0xb7867e56]
/usr/lib/libcairo.so.2[0xb7858493]
/usr/lib/libcairo.so.2(cairo_fill_preserve+0x2c)[0xb7850a6c]
/usr/lib/libcairo.so.2(cairo_fill+0x12)[0xb7850a92]
/usr/lib/libgdk-x11-2.0.so.0[0xb79cee1b]
/usr/lib/libgdk-x11-2.0.so.0(gdk_window_begin_paint_region+0x1bb)[0xb79d156b]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main_do_event+0x51e)[0xb7b5312e]

Once I get another crash with the double-linked list message, I'll post my valgrind log here.

Sebastien Bacher (seb128) wrote :

the error is very doubtfully a cairo one but reopen if you can get a valgrind log for the issue

Changed in cairo (Ubuntu):
status: Incomplete → Invalid
Cruncher (ubuntu-wkresse) wrote :

I am unable to get gnomebaker to crash with valgrind, or to make gdb logs with the use of gnomebaker-dbgsym (bug #345448).

However, I was able to create crashes and gdb logs compiling gnomebaker from gnomebaker_0.6.4.orig.tar.gz. The first log is with default settings, the second log is with LD_LIBRARY_PATH=/usr/lib/debug/usr/lib/, the third is from the stripped /usr/bin/gnomebaker, but with LD_LIBRARY_PATH=/usr/lib/debug/usr/lib/, to get at least some info.

What else can I do? Is there a way to force valgrind to produce a crash, instead of modifying the behaviour of the program so that it no longer crashes?

Changed in gnomebaker:
status: Invalid → New
Cruncher (ubuntu-wkresse) wrote :

gnomebaker.gdb.log: gnomebaker compiled from source
gnomebaker2.gdb.log: gnomebaker compiled from source, LD_LIBRARY_PATH=/usr/lib/debug/usr/lib/
gnomebaker3.gdb.log: gnomebaker from gnomebaker_0.6.4-1_i386.deb, LD_LIBRARY_PATH=/usr/lib/debug/usr/lib/

libcairo2-dbg and libpango1.0-0-dbg installed

Sebastien Bacher (seb128) wrote :

valgrind often workaround crashes but catch the errors anyway so the log could be useful

JohnBuck (qweqwe12) wrote :

Same problem here on Ubuntu Jaunty. Gnomebaker will crash when adding multiple files. 100% reproducible. However it will not crash with valgrind.

Cruncher (ubuntu-wkresse) wrote :

Here is the gnomebaker bug I opened a while ago. So far there has been no response. However, it seems to be related to using the "Add" button - drag+drop is working.
http://sourceforge.net/tracker/?func=detail&aid=2695036&group_id=127397&atid=708499

Also, you can prevent gnomebaker from crashing most of the time when using the valgrind debug settings, by starting gnomebaker with:
G_SLICE=always-malloc G_DEBUG=gc-friendly gnomebaker

Michalxo (michalxo) wrote :
Download full text (7.3 KiB)

I get similar error in 9.10. All freshly updated and fresh installation 5 days ago.
here's the output:
$ gnomebaker

(gnomebaker:1955): GLib-WARNING **: g_set_prgname() called multiple times
*** glibc detected *** gnomebaker: corrupted double-linked list: 0xb6834d88 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0x15b5ff1]
/lib/tls/i686/cmov/libc.so.6[0x15b623a]
/lib/tls/i686/cmov/libc.so.6[0x15b84b2]
/lib/tls/i686/cmov/libc.so.6(__libc_malloc+0x58)[0x15ba868]
/lib/libglib-2.0.so.0(g_realloc+0x3f)[0x67f1df]
/usr/lib/libpango-1.0.so.0(pango_glyph_string_set_size+0x4f)[0x35e8cf]
/usr/lib/pango/1.6.0/modules/pango-basic-fc.so[0x996ede]
/usr/lib/libpango-1.0.so.0[0x36557a]
/usr/lib/libpango-1.0.so.0(pango_shape+0x5a)[0x377e8a]
/usr/lib/libpango-1.0.so.0[0x36a5ee]
/usr/lib/libpango-1.0.so.0[0x36b010]
/usr/lib/libpango-1.0.so.0[0x36ccb6]
/usr/lib/libpango-1.0.so.0[0x36df54]
/usr/lib/libgtk-x11-2.0.so.0[0x1096659]
/usr/lib/libgtk-x11-2.0.so.0[0x109cbcf]
/usr/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__BOXED+0x88)[0x618068]
/usr/lib/libgobject-2.0.so.0[0x6096f9]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0xd8)[0x60af98]
/usr/lib/libgobject-2.0.so.0[0x6200b0]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x7bd)[0x621b2d]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_by_name+0x192)[0x621e42]
/usr/lib/libgtk-x11-2.0.so.0[0x111c396]
/usr/lib/libgtk-x11-2.0.so.0[0x111c64f]
/usr/lib/libgtk-x11-2.0.so.0(gtk_widget_size_request+0x7f)[0x11d098f]
/usr/lib/libgtk-x11-2.0.so.0[0xfe5263]
/usr/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__BOXED+0x88)[0x618068]
/usr/lib/libgobject-2.0.so.0[0x6096f9]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0xd8)[0x60af98]
/usr/lib/libgobject-2.0.so.0[0x6200b0]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x7bd)[0x621b2d]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_by_name+0x192)[0x621e42]
/usr/lib/libgtk-x11-2.0.so.0[0x111c396]
/usr/lib/libgtk-x11-2.0.so.0[0x111c64f]
/usr/lib/libgtk-x11-2.0.so.0(gtk_widget_size_request+0x7f)[0x11d098f]
/usr/lib/libgtk-x11-2.0.so.0[0xfd9961]
/usr/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__BOXED+0x88)[0x618068]
/usr/lib/libgobject-2.0.so.0[0x6096f9]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0xd8)[0x60af98]
/usr/lib/libgobject-2.0.so.0[0x6200b0]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x7bd)[0x621b2d]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_by_name+0x192)[0x621e42]
/usr/lib/libgtk-x11-2.0.so.0[0x111c396]
/usr/lib/libgtk-x11-2.0.so.0[0x111c64f]
/usr/lib/libgtk-x11-2.0.so.0(gtk_widget_size_request+0x7f)[0x11d098f]
/usr/lib/libgtk-x11-2.0.so.0[0x11d9fca]
/usr/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__BOXED+0x88)[0x618068]
/usr/lib/libgobject-2.0.so.0[0x6096f9]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x1b2)[0x60b072]
/usr/lib/libgobject-2.0.so.0[0x6200b0]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x7bd)[0x621b2d]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_by_name+0x192)[0x621e42]
/usr/lib/libgtk-x11-2.0.so.0[0x111c396]
/usr/lib/libgtk-x11-2.0.so.0[0x111c64f]
/usr/lib/libgtk-x11-2.0.so.0(gtk_widget_size_request+0x7f)[0x11d098f]
/usr/lib/libgtk-x11-2.0.so.0[0x1185f83]
/usr/lib/libgtk-x11-2.0.so.0[0x118626c]
/usr/lib/libgdk-x11-...

Read more...

mucku (dereinsameberg) wrote :

Also Ubuntu 9.10_64 bit here crashes.

See attachment for terminal output.

(gnomebaker:7330): GLib-WARNING **: g_set_prgname() called multiple times
*** glibc detected *** gnomebaker: corrupted double-linked list: 0x00000000010c4040 ***

bowtie (kevin-dawson) wrote :

try the following, from a terminal, enabled me to cut cd.

export GDK_NATIVE_WINDOWS=true

G_SLICE=always-malloc gnomebaker

regards.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.