baobab is confused by bind mounts

Bug #99521 reported by Peter Berry on 2007-03-31
54
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-utils
Confirmed
Medium
gnome-utils (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: baobab

I have a bind mount from /home to /chroot32/home, i.e. my home directory is remounted under the 32 bit chroot jail. These are obviously the same object, but baobab thinks they are different. So it counts both, but obviously they take up exactly the same space, so essentially the same directory is being counted twice, leading to incorrect totals.

It should probably recognise them as different filesystems.

ski (skibrianski) wrote :

I'm having this problem too. I've included a screenshot showing output of mount, df -h, and baobab

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 alpha/beta?

Changed in baobab:
status: New → Incomplete
Peter Berry (pwberry) wrote :

I haven't installed Intrepid yet so I can't say. I do have something related to say about it in Hardy though. df says / has 21 GB (49%) used, 22 GB available. /dev/sda3 (my Windows partition) is mounted at /media/sda3, and df says it has 27 GB (92%) used, 2.4 GB available. baobab apparently ignores the fact that /media/sda3 is a different filesystem, adds together 21 and 27 to get 48, and thinks / is therefore full. It also says at the top "used: 67.4 GB available: 50.5 GB" thus contradicting itself. Seems the problem is more general than just bind mounts, it just doesn't know about mount points at all!

Peter Berry (pwberry) wrote :

Upgraded to Intrepid just now, and Baobab still thinks / is full and simultaneously thinks it has 25.1 GB free.

Changed in baobab:
status: Incomplete → New
Hew (hew) wrote :

Baobab is part of gnome-utils, changing sourcepackage.

Fabio Marzocca (thesaltydog) wrote :

If you check in Prefernces, you will see all mounted and selected partitions. All of them concurrently add their spacce in the Total Filesystem usage number.

Peter Berry (pwberry) wrote :

Okay, that's a workaround. But it should still automatically recognise bind mounts and not include them.

I don't think that this is a bug in the way it was reported. I think this should be a request to change the default options to that stated by Fabio.

Changed in gnome-utils:
status: New → Invalid
Hew (hew) on 2009-02-11
Changed in gnome-utils:
status: Invalid → New
Peter Berry (pwberry) wrote :

Arguing over whether it's a "bug" or not is unhelpful. What we can presumably agree on is that at present, baobab gives totals that are manifestly wrong, because of what is admittedly a rather uncommon use case. If this is a feature request, it's a feature that must be added for baobab to behave correctly.

Fabio Marzocca (thesaltydog) wrote :

There is also an open bug upstream. Patches are welcome!

Changed in gnome-utils:
status: Unknown → New
Changed in gnome-utils:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged

Has any progress been made on this bug? It's been idle for a rather long time.

Just a note, some work has been done upstream but the issue seems to have been put on the back burner. Personally, I only mount what I actually use. My /vm, /boot, /media/windows only get mounted when I need them.

I'm wondering if this should be marked as Confirmed and not Triaged considered they haven't even marked it confirmed in the upstream bugtracker.

Changed in gnome-utils (Ubuntu):
status: Triaged → Confirmed
Hew (hew) wrote :

This is marked as Triaged since it's an upstream issue and an upstream bug has been filed. Fixing the bug should be discussed at the upstream report.

Changed in gnome-utils (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-utils:
importance: Unknown → Medium
Changed in gnome-utils:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.