gnome-screenshot (Alt-Printscreen) black/blanks out top of windows in multi monitor xinerama

Bug #379382 reported by Niall Gallagher on 2009-05-22
80
This bug affects 16 people
Affects Status Importance Assigned to Milestone
gnome-utils
Fix Released
Medium
gnome-utils (Ubuntu)
Low
Unassigned
Lucid
Medium
Unassigned
Maverick
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

I have Ubuntu 9.04 configured in a multi-monitor Xinerama setup of a centre monitor 1600x1200 and two smaller monitors 1280x1024 on either side i.e. different resolutions across the screens.

In Ubuntu 9.04 gnome-screenshot now black/blanks-out the top 210 pixels of any screenshot I take of an individual window (i.e. Alt-Printscreen) regardless of which monitor I take it on. The number of pixels blanked out seems dependent on the difference in the y-offset across the screens as configured in xorg.conf. Taking a screenshot of the whole desktop works properly. The problem did not occur at all in Ubuntu 8.10.

Here's the relevant extract from my xorg.conf:
Section "ServerLayout"
 Identifier "Layout0"
 Screen 0 "ScreenCentre" 1280 0
 Screen 1 "ScreenLeft" 0 210
 Screen 2 "ScreenRight" 2880 210
 Option "Xinerama" "On"
EndSection

Note that the left and right monitors are slightly lower on my desk than the centre monitor so I've set their y-offsets in xorg.conf to 210 pixels (from what otherwise should be 1200-1024=176 pixels) so that when I drag windows between monitors the widows appear at the same level.

I'll attach a screenshot of the whole desktop to illustrate the xorg offsets, and screenshots of individual windows which illustrate the problem.

STATUS UPDATE: what's left to be done is the lucid SRU, thank you.

Niall Gallagher (npgall) wrote :

Screenshot of whole desktop

Niall Gallagher (npgall) wrote :

Screenshot of individual window on the left screen

Niall Gallagher (npgall) wrote :

Screenshot of individual window on the centre screen

Niall Gallagher (npgall) wrote :

Screenshot of individual window on the right screen

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The ubuntu team doesn't have the ressources to work on this specific issue but it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in gnome-utils (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Edwin Grubbs (edwin-grubbs) wrote :

I have the exact same issue with taking screenshots in Jaunty with multiple monitors, and I have found a workaround.
If I align the top edge of all my monitors, the black bar no longer appears in screenshots of a window or an area of the screen.

I have also opened this bug in gnome's bugtracker.
http://bugzilla.gnome.org/show_bug.cgi?id=587101

Changed in gnome-utils:
status: Unknown → New
Pedro Villavicencio (pedro) wrote :

Thanks for sent this upstream.

Changed in gnome-utils (Ubuntu):
status: New → Triaged
Rolf Leggewie (r0lf) on 2010-03-12
summary: - Ubuntu 9.04 gnome-screenshot (Alt-Printscreen) black/blanks out top of
- windows in multi monitor xinerama
+ gnome-screenshot (Alt-Printscreen) black/blanks out top of windows in
+ multi monitor xinerama
tags: added: lucid
tags: added: jaunty karmic
tags: added: regression
Changed in gnome-utils:
importance: Unknown → Medium
Milton (miltonlaufer) wrote :

I have the same problem in Maverick.

Rolf Leggewie (r0lf) on 2011-02-01
tags: added: maverick
Changed in gnome-utils:
status: New → Confirmed
Reinis Ivanovs (dabas) wrote :

I still see this problem in 11.04.

Christian Reis (kiko) wrote :

For the record, there is a patch in the upstream bug tracker that seems to address the issue.

Changed in gnome-utils (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Rolf Leggewie (r0lf) wrote :

Thanks, Kiko. The patch applies cleanly to the source up until natty, but not oneiric. Will have a closer look later on.

Rolf Leggewie (r0lf) wrote :

For what it's worth, here is a debdiff ready for a lucid SRU, based on the patch from the upstream bug tracker. It works as advertised for me and has been given the green light from one of the upstream devs.

Curiously enough, my locally compiled package is about 400K bigger than the one in the archive. Inspection with debdiff reveals that there are a bunch of files under /usr/share/gnome/help/, /usr/share/locale and /usr/share/omf which are not in the current deb file from the archive. I suppose that's due to changes/bugfixes. The debdiff certainly has nothing in it that would trigger this.

Can anybody please comment whether or not oneiric is affected as well so we can start the SRU process?

Rolf Leggewie (r0lf) wrote :

"I suppose that's due to changes/bugfixes IN THE LUCID BUILD SYSTEM" ;-)

tags: added: patch
Changed in gnome-utils:
status: Confirmed → In Progress
Rolf Leggewie (r0lf) wrote :

Can somebody please verify whether or not this affects oneiric as well so that we can move on?

Changed in gnome-utils:
status: In Progress → Fix Released
Rolf Leggewie (r0lf) wrote :

Michael Biena in upstream comment 24 confirmed this affects gnome-screenshot 3.1.2-0ubuntu2 in oneiric as well. The patch has recently been applied upstream. Let's get this fixed in Ubuntu.

Changed in gnome-utils (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
status: Triaged → In Progress
Rolf Leggewie (r0lf) wrote :

Here is an oneiric debdiff. It would be very nice if attribution to my work survived intact and wasn't butchered as in 3.1.5-0ubuntu2 just because I'm not one of the "in-crowd" with a @ubuntu address

Rolf Leggewie (r0lf) wrote :

And here is a debdiff for lucid-proposed

Rolf Leggewie (r0lf) wrote :

handing over to the sponsor team

Changed in gnome-utils (Ubuntu):
assignee: Rolf Leggewie (r0lf) → nobody
Rolf Leggewie (r0lf) wrote :
Jani Monoses (jani) wrote :

Seems to be fixed in the oneiric 3.2 version.

Rolf Leggewie (r0lf) wrote :

requesting lucid SRU now that the fix has landed in oneiric

description: updated
Rolf Leggewie (r0lf) on 2011-09-30
Changed in gnome-utils (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Medium
milestone: none → lucid-updates
Rolf Leggewie (r0lf) wrote :

closing the oneiric task as fixed

Changed in gnome-utils (Ubuntu):
status: In Progress → Fix Released
Stéphane Graber (stgraber) wrote :

Uploaded to lucid-proposed, SRU team will take it from there.

Unsubscribing ubuntu-sponsors as there's nothing else to sponsor.

Changed in gnome-utils (Ubuntu Lucid):
status: Triaged → Fix Committed
Rolf Leggewie (r0lf) wrote :

Thanks, Stéphane!

Hello Niall, or anyone else affected,

Accepted gnome-utils into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Rolf Leggewie (r0lf) wrote :

verification before and after successful for lucid. please release.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-utils - 2.30.0-0ubuntu1.1

---------------
gnome-utils (2.30.0-0ubuntu1.1) lucid-proposed; urgency=low

  * gnome-screenshot produces a black bar in certain multi-head
    situations. backport 56f50c7 from upstream git. LP: #379382
 -- Rolf Leggewie <email address hidden> Mon, 19 Sep 2011 03:30:41 +0800

Changed in gnome-utils (Ubuntu Lucid):
status: Fix Committed → Fix Released
dino99 (9d9) on 2013-05-18
Changed in gnome-utils (Ubuntu Natty):
status: New → Invalid
Changed in gnome-utils (Ubuntu Maverick):
status: New → Invalid
monomakh (monomakh) wrote :

I have the same problem with one display. Looks like that problem in compiz or intel driver. After compiz restart screnshot is well.

Rolf Leggewie (r0lf) wrote :

Vladimir, this ticket is closed as fixed. It's best you submit a new bug describing your problem.

"[Bug 379382] Re: gnome-screenshot (Alt-Printscreen) black/blanks out top of windows in multi monitor xinerama"
Rolf Leggewie doc

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.