Update to 2.25.92

Bug #337270 reported by Ken VanDine on 2009-03-03
4
Affects Status Importance Assigned to Milestone
gnome-user-share (Ubuntu)
Undecided
Ken VanDine

Bug Description

Binary package hint: gnome-user-share

Latest upstream release

Ken VanDine (ken-vandine) wrote :

Attached debdiff

Changed in gnome-user-share:
assignee: nobody → ken-vandine
status: New → In Progress
Daniel Holbach (dholbach) wrote :

Can you please attach the .diff.gz of your source package? The debdiff when a new upstream version is involved is never really helpful.

Ken VanDine (ken-vandine) wrote :

As requested

Daniel Holbach (dholbach) wrote :

It did not build for me - I built it in pbuilder which is helpful to find if things in the build-depends are missing: https://wiki.ubuntu.com/PbuilderHowto

Can you document in debian/changelog why you removed this portion of debian/rules:
clean::
       rm -f data/dav_user_2.2.conf

Also the changes in the dependencies.

Ken VanDine (ken-vandine) wrote :

Updated diff.gz

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-user-share - 2.25.92-0ubuntu1

---------------
gnome-user-share (2.25.92-0ubuntu1) jaunty; urgency=low

  * New upstream release (LP: #337270)
    - Update Swedish help manual, add Greek manual,
    - Fix httpd configuration file
    - Use mod_dnssd 0.6 to export the user TXT record, necessary to work
      with the latest gvfs
    - Check for httpd version and binary location at run-time, rather than
      compile-time
    - Documentation updates
    - Use Apache's mod_dnssd module instead of doing the work ourselves
    - Refuse to run as root, so as to avoid sensitive files being shared
    - Add end-user documentation, and UI changes to match
    - Make it possible for build daemons to build without Apache installed
    - Port to BlueZ 4.x API
    - UI fixes in the preferences dialogue
    - Fix web file sharing on some distributions
  * debian/patches/02_bluez4-update.patch:
    - removed, merged upstream
  * debian/rules:
    - Don't remove dav_user_2.2.conf in clean, it is needed for the build
      and is not a generated file
  * debian/control.in:
    - Added a dependency on libapache2-mod-dnssd (>=0.6)
  * Specify httpd binary instead of version

  [ Daniel Holbach ]
  * debian/control.in: added gnome-doc-utils (>= 0.3.2), rarian-compat to
    Build-Depends.

 -- Ken VanDine <email address hidden> Tue, 03 Mar 2009 10:58:43 -0500

Changed in gnome-user-share:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers