gnome-twitch crashes when starting a stream

Bug #1777049 reported by Jan Morten Schrag on 2018-06-15
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-twitch (Debian)
Unknown
Unknown
gnome-twitch (Ubuntu)
High
Unassigned
Bionic
Undecided
Unassigned

Bug Description

Gnome-twitch doesn't work on Ubuntu 18.04 as it always crashes when starting a stream. The player backend has no influence over the behaviour.

Example terminal output (personal informations edited out):

[04:43:04] Message - GNOME-Twitch : {GtApp:370} Startup, running version '0.4.1'
[04:43:04] Message - GNOME-Twitch : {GtApp:339} Activate
[04:43:04] Message - GNOME-Twitch : {GtPlayer:132} Loading chat settings
[04:43:04] Message - GNOME-Twitch : {GtPlayer:999} Loaded player backend 'MPV OpenGL player backend'
[04:43:04] Message - GNOME-Twitch : {GtPlayerBackendMpvOpenGL:401} Init
[04:43:04] Message - GNOME-Twitch : {GtApp:147} Succesfully fetched oauth info with name 'xxxxxx', id 'xxxxxxx' and oauth token 'xxxxxxxxxxxxxxxxxxxxx'
[04:43:05] Message - GNOME-Twitch : {GtApp:182} Succesfully fetched user info with name 'xxxxxxx', id 'xxxxxxxx' and oauth token 'xxxxxxxxxxxxxxxxxxxxx'
[04:43:05] Message - GNOME-Twitch : {GtFollowsManager:519} Loaded '21' follows from Twitch
[04:43:06] Message - GNOME-Twitch : {GtPlayer:1310} Opening stream 'ninja' with quality 'source'
[04:43:06] Warning - GNOME-Twitch : {GtTwitch:336} Received unsuccessful response from url 'http://api.twitch.tv/api/channels/ninja/access_token' with code '400' and body '{"error":"Bad Request","status":400,"message":"Requests must be made over SSL"}'
[04:43:06] Warning - GNOME-Twitch : {GtTwitch:594} Error getting stream access token for channel 'ninja' because: Received unsuccessful response from url 'http://api.twitch.tv/api/channels/ninja/access_token' with code '400' and body '{"error":"Bad Request","status":400,"message":"Requests must be made over SSL"}'
Speicherzugriffsfehler (Speicherabzug geschrieben)
####[German for Memory access error]####

description: updated
Bin Li (binli) wrote :
Bin Li (binli) wrote :

In debian, it had fixed this issue.

gnome-twitch (0.4.1-3) unstable; urgency=medium

  * Use https to talk to Twitch servers, because
    Twitch deprecated some http APIs (Closes: 898768)
  * Bump standards version from 4.1.1 to 4.1.4.1
  * Bump debhelper compat version to 11

 -- Tim Dengel <email address hidden> Tue, 15 May 2018 21:30:42 +0200

Changed in gnome-twitch (Debian):
importance: Undecided → Unknown
status: New → Unknown
Sebastien Bacher (seb128) wrote :

That's fixed in the Debian version which is synced in cosmic

Changed in gnome-twitch (Ubuntu):
importance: Undecided → High
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

SRU uploads to bionic as well

* Impact

The service changed starting refusing non ssl connection, which made the software stop working

* Test case

Start gnome-twitch and try to play some stream

* Regression potential

Check that the service is working

Hello Jan, or anyone else affected,

Accepted gnome-twitch into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-twitch/0.4.1-2ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-twitch (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Volodymyr Koval (moonflyer) wrote :

The error is still in place, namely

Warning - GNOME-Twitch : {GtTwitch:594} Error getting stream access token for channel 'shroud' because: Received unsuccessful response from url 'http://api.twitch.tv/api/channels/shroud/access_token' with code '400' and body '{"error":"Bad Request","status":400,"message":"Requests must be made over SSL"}'

While parsing the binary to validate that the fix is in place, it became clear that the fix is not complete and at least two URLs are still using HTTP:

/usr/bin$ strings gnome-twitch | grep http
...
https://api.twitch.tv/kraken/streams/followed?limit=%d&offset=%d&oauth_token=%s&stream_type=live
https://api.twitch.tv/kraken/users/%s/follows/channels?limit=%d&offset=%d
http://api.twitch.tv/api/channels/%s/access_token
...
http://api.twitch.tv/api/channels/%s/panels
...

Volodymyr Koval (moonflyer) wrote :

Sorry, I forgot to write the package version. Also, I seem to be not able to change tags(maybe I am too new to this place).

/usr/bin$ apt list gnome-twitch
gnome-twitch/bionic,now 0.4.1-2 amd64

Amr Ibrahim (amribrahim1987) wrote :

Please follow the instructions from comment #7 and update to the version in bionic-proposed.

Sebastien Bacher (seb128) wrote :

installing 0.4.1-2ubuntu0.18.04.1 it plays videos and display chats where the bionic version is segfaulting, marking as verified

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic

The verification of the Stable Release Update for gnome-twitch has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-twitch - 0.4.1-2ubuntu0.18.04.1

---------------
gnome-twitch (0.4.1-2ubuntu0.18.04.1) bionic; urgency=medium

  * Backport the https fix to bionic (lp: #1777049):
    - Use https to talk to Twitch servers, because Twitch deprecated some http
      APIs

 -- Sebastien Bacher <email address hidden> Tue, 03 Jul 2018 10:45:07 +0200

Changed in gnome-twitch (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.