Ubuntu

[Gutsy] blurry menu icons

Reported by Craig Duquette on 2007-09-20
42
Affects Status Importance Assigned to Milestone
gnome-themes (Baltix)
Undecided
Unassigned
gnome-themes (Ubuntu)
Undecided
Unassigned
Declined for Gutsy by Pedro Villavicencio
Declined for Hardy by Chris Cheney
human-icon-theme (Ubuntu)
Undecided
Unassigned
Declined for Gutsy by Pedro Villavicencio
Declined for Hardy by Chris Cheney
openoffice.org (Baltix)
Undecided
Unassigned
openoffice.org (Ubuntu)
Undecided
Unassigned
Declined for Gutsy by Pedro Villavicencio
Declined for Hardy by Chris Cheney

Bug Description

Many menu icons are extremely blurry when using themes from gnome-themes package (Clearlooks, Tango, Tangerine, etc.). It appears to occur because of a default 22x22 size used by the themes, although applications only ship 24x24 ones.

Craig Duquette (cduquette) wrote :

Shot of blurry icons in the Clearlooks theme.

Craig Duquette (cduquette) wrote :

This issue occurs in Ubuntu 7.10.

Kenneth Wimer (kwwii) wrote :

This sounds like an upstream bug in the icon set you are using. I would guess that it cannot find the right size icon and is therefor scaling them from other sizes.

TJ (tj) wrote :

Same as with bug #141229, looks okay here, using Gutsy 64-bit nvidia-glx-new, compiz.

Craig Duquette (cduquette) wrote :

I wanted to keep this bug seperate from bug #141229 because they're seperate packages, but these are similar issues.

Gert Kulyk (gkulyk) wrote :

Gnome-panel requires icons with the size of 22x22px, e.g. ooo-icons are only available in 24x24px size. Human-Theme is doing the following: it is adding a "gtk-icon-sizes = "panel-menu=24,24"" entry in gtkrc, so scaling is not necessary. When using Clearlooks-theme, the "hack" is not applied by default, therefore all icons that are not available in 22x22px-size are looking blurry. You can prevent this by creating a ~/.gtkrc-2.0 file with the "gtk-icon-sizes = "panel-menu=24,24"" entry in it (or "hacking" the system-wide gtkrc in the /usr/share/themes/YOURTHEME/gtk-2.0). This should work, at least it works for me.

Craig Duquette (cduquette) wrote :

Gert, this fixed the issue for me. I think the developers should do something similar to this to resolve this bug. The only icon that gives me an issue is Rhythmbox, it doesn't look as sharp as the 22x22px counterpart, but other than that things look great.

Milan Bouchet-Valat (nalimilan) wrote :

Removing OpenOffice.org and adding icon themes, because this needs to be fixed either on each theme or at a system-wide level.

Changed in openoffice.org:
status: New → Invalid
description: updated
Milan Bouchet-Valat (nalimilan) wrote :

This was already reported in Bug 134144, which was set as 'Invalid' by Sebastien Bacher:
"Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find. That's because /usr/share/themes/Human/gtk-2.0/gtkrc has 'gtk-icon-sizes = "panel-menu=24,24"' to work with the human icon theme. You should use ubuntulooks with human, or modify your gtkrc to use 22x22 for icons"

The problem is, *no theme except Human seems to work without blurry icons*. IndustrialTango, Clearlooks, etc. are all affected. Sebastien, could you explain this issue, please?

Sebastien Bacher (seb128) wrote :

You need to use matching gtk and icons themes

I was meaning: even when you choose a standard *complete* theme (with controls, icons, window borders...) like Clearlooks (default GNOME theme), some icons are blurry. This is no customization at all! Try yourself: most notably, OO.o icons are strange, "Preferred applications" icons is too.

Sebastien Bacher (seb128) wrote :

those might be due to applications not shipping the right icons variants, this bug is not precise enough to be useful though

Craig Duquette (cduquette) wrote :

I filed this bug specifically for OpenOffice.org, I understand there are several other applications out there that have the same situation. I filed a similar bug request for Synaptic and it's icons.I filed this bug thinking it'd be an easy fix, where we could swap the icons out for icons that fit the pixel width of the majority of the gtk theme sizes out there. It'd be annoying to patch this on an icon theme level, it should be done at the application level. In order to get that done (for other applications) I'd suggest filing a separate, unique bug report for each application with a blurry icon.

I think it's a theme issue, because I can see many apps with blurry icons: OpenOffice.org, Bluetooth Analyser, Conduit, Grisbi, Baobab, Avant Window Navigator, gThumb, GNU Solfege, GNOME-RDP, GNOME Sound recorder, Thoggen and so on, and some administration apps too. Can this be a bug in all these apps?

I don't understand the point here: don't you see the same as me when you use themes other than Human?! I'm feeling like a mad guy who imagines bugs everywhere; but I'm only seeing a devastated Desktop in Gutsy and I wonder how we can avoid loosing all your work. But maybe this is only a local issue on my box due to an upgrade error. Please confirm this. Thanks ;-)

Sebastien Bacher (seb128) wrote :

I use the Human theme and don't have most of the applications you list installed. That's like a bug of those software not shipping correct icons though, baobab for example ships a 24x24 icons and not a 22x22 one

*Please* make this test to tell me whether it's a local bug:
- change your theme to Clearlooks (or Tango or anything)
- take a look at your System ->Preferences and -> Administration menu
You should see blurry icons here. And you surely have OpenOffice.org, Bluetooth Analyser (by default) and Baobab...
If you don't see this I'll try to check what's wrong on my box.

Sebastien Bacher (seb128) wrote :

did you read my previous comment? those applications likely ship 24x24 icons and no 22x22 variant and clearlooks is a 22x22 theme

Craig Duquette (cduquette) wrote :

Anyone know how other distros are handling this issue? There has to be other distros out there doing things to fix this issue. I haven't tried Fedora recently, but I can take a look at their live CD and see if they're using 24px themes or if they're putting in their own icons to fix the issue.

OK, I hadn't got your point. So why is this new in Gutsy? Were these 22x22 icons there in Feisty, or did the themes' icon size change? Is it possible to revert to 24x24? Or is it easy to correct all the wrong packages before the release? In short: have you any ideas about how to fix it? I can't imagine the stable release will ship blurry icons...
If this can/has to be fixed in each app involved, I'm ready to add an 'Affect' entry for each of these.
[And sorry for the repeated posts due to my misunderstanding. I'll be more cautious next time.]

Sebastien Bacher (seb128) wrote :

Not sure, you should check with upstream. The default theme is Human which doesn't have blurry icons, we don't have the ressources to fix every other themes around though

I tried a dirty hack: adding gtk-icon-sizes = "panel-menu=24,24" to /usr/share/themes/Clearlooks/gtk-2.0/gtkrc. And now all my Clearlooks icons are perfect in the menus. Should we only fix the erroneous themes (they are in gnome-themes)? Would you set the importance of this bug and confirm it? I can easily imagine you don't have time to waste, but for sure there's somebody that has and cares about it. You can't simply assume that all users stay with Human.

description: updated
Changed in human-icon-theme:
status: New → Invalid
Sebastien Bacher (seb128) wrote :

Are you sure that doesn't make 22x22 icons being blurry?

Sebastien Bacher (seb128) wrote :

and nobody assumes that all the users stay with Human, what do you try to insinuate?

Nothing. ;-) I just meant that surely Ubuntu developers doesn't have time to fix every GNOME bug, but that this is still high priority and deserves a little triaging for upstream to fix this quickly...
I can't see any strange icons now, using Clearlooks. I guess all packages have 24x24 icons together with 22x22 ones (the contrary is false, clearly). Though I can't be completely sure; at least this has to be investigated upstream.
So could you set a significant priority to this bug (maybe people are looking around here)? If you confirm we can and have to do something here, I'll open an upstream bug.

Antonio Sampaio (antls) wrote :

I can confirm the bug too. With me happens the same since Gutsy Beta.
I thought that it was only a bug in my upgrade from feisty, but now with a fresh install of Gutsy final the problem persists.

Here's a screenshot. Using the complete clearlooks theme.

michelem (michele-marcucci) wrote :

You could workaround the bug creating a file ~/.gtkrc-2.0 with inside the row:
gtk-icon-sizes = "panel-menu=24,24"

That's worked for me

unggnu (unggnu) wrote :

I can confirm this issue and the work around.

Antonio Sampaio (antls) wrote :

The workaround worked for me too.
Thanks!

Achim (ach1m) wrote :

So I don't know why it is a problem to add one line to the /usr/share/themes/Clearlooks/gtk-2.0/gtkrc file and create a new package.
I mean the Human theme is doing the same thing, Why should it be a problem for the clearlooks theme ?
It would be nice if this could be fixed before Hardy will be release. Because the clearlooks-engine is much faster then the ubuntu-looks-engine.
So clearlooks is my favourite engine.

This is how the beginning of the Human gtkrc-file looks.
/usr/share/themes/Human/gtk-2.0/gtkrc
#################################
# Ubuntu Human Colorscheme
#
# Authors:
# Richard Stellingwerff <email address hidden>
# Daniel Borgmann <email address hidden>
# Billy Cantrell <email address hidden>
#
# Feel free to modify and share!

gtk-icon-sizes = "panel-menu=24,24"

style "clearlooks-default"
{
#################################

This is the line (gtk-icon-sizes = "panel-menu=24,24") which will be added to the /usr/share/themes/Clearlooks/gtk-2.0/gtkrc file.

I have created a diff. I am not sure if it is the right way but it works for me.

Just copy the attached patch to your user directory for examle "/home/username/"

start a terminal and type sudo -s

and copy the following line to the terminal.

sudo cat gtkrc.patch | patch /usr/share/themes/Clearlooks/gtk-2.0/gtkrc

It should look like this.

root@home:~# sudo cat gtkrc.patch | patch /usr/share/themes/Clearlooks/gtk-2.0/gtkrc
patching file /usr/share/themes/Clearlooks/gtk-2.0/gtkrc
root@home:~#

now you have to reload the theme. You can do this by choosing another theme and switch back to clearlooks.

So let me know if it works for you.

Best wishes
Achim

Craig Duquette (cduquette) wrote :

I believe in the next release of Gnome (2.22) the developers made it a goal to finish the new Tango-ized icon theme. Artists have been redoing program icons and submitting changes to developers to bundle into their applications. I believe with 2.22 we'll see the majority of the icons with a 22px version. Because of this I think it's beneficial to keep Clearlooks 22px and let users modify their ~gtkrc themselves. Sure you'll have blurry menu icons, but the next release of Gnome (6 months) we won't have to file a bug trying to revert the 24px gtkrc line back to the default 22px. Of course I have no say in the matter, I'm just the bug filer and I didn't think it was a theme related issue, just developers putting more focus on the human theme.

Achim (ach1m) wrote :

So then we need a bug report which is related to the "human-icon-theme (Ubuntu)"

I have attached a screenshot where you can see on the left side standard humen theme with humen-icon-theme.
On the right side you can see the clearlooks theme in combination with the humen-icon-theme.

As everybody can see the human-icon-theme is partly blurry.

Then we have to say that the human-icon-theme is incomplete or something like that.
I have restarted the computer to be sure that everything is out of the cache.
(If somebody wants to test this problem he should also do.)

Don't get me wrong, I only want a good solution.

Best wishes
achim

Craig Duquette: There's no talk here about hampering GNOME developers to improve their icon themes for future versions. We only need a correct workaround for the next 6 months, since it was working in Feisty and (hopefully) will be in Hardy, it is no acceptable we destroy all our optional themes in Gutsy. The fix is harmless, easy to implement and doesn't raise any problem for future versions since it will be automatically replaced.

Going the other way is not possible: asking all users to modify manually their ~/.gtkrc will cause future improvements not to be applied since the customized file will still be there. Patching Ubuntu packages is the right way to correct bugs, even temporarily.

Craig Duquette (cduquette) wrote :

Milan: I agree this should be fixed this release, I've just had bad experiences with bug fixes when it's come to art in the past. For example I filed a bug against GPM in Ubuntu because the icons were using the SVG icons instead of the fixed pixel icons. This was causing blurry icons, but since the Human theme had its own icons for GPM (that were nonblurry) this issue was put on the backburner. It wasn't even a trivial issue, the Gnome icon theme needed to use hicolor's icon theme as a fallback, the fixed pixel icons existed in hicolor the whole time. 1 line in a themerc file to fix this issue...

Well now a similar issue has come up. We need 1 line in a theme file to fix the icons by displaying 24px icons which many applications have. I'm just afraid that if we fix something it'll take another 3 distro releases to revert the quick fix.

I agree it's impossible to ask users to edit their .gtkrc file, but if this bug really annoys them they've probably done it by now. My fix was just to hide all applications with blurry icons because I never used them anyway. Synaptic is the only blurry icon in my menu.

I'm sure by the time someone looks at this bug Gnome 2.22 will be released anyway. Sorry for the lack of optimism.

Sebastien Bacher (seb128) wrote :

No need to keep adding comments about workarounds, we will not modify the gtkrc of other themes to not be correct, the issue there looks like a GTK one, the resizing of icons should not make them blurry

Achim (ach1m) wrote :

So I don't want to get on your nerves, but isn't it a normal thing that pixel based pictures (icons in png-format) get blurry if they get shrinked.

So why is this problem related to GTK?
And why is the human theme using the "workaround" and the clearlooks theme isn't allowed to use it?

Maybe someone can explain me what I am getting wrong.

best wishes
Achim

Sebastien Bacher (seb128) wrote :

try to resize an icon with gimp and you will likely notice that it's not as blurry. An another option which is suggested on an upstream bug is to make the panel use 24x24 icons and add padding aroung 22x22 icons. The Human theme uses the workaround because it's a 24x24 theme where Clearlooks has been converted to the tango style and use 22x22 icons

Achim (ach1m) wrote :

thank you for your quick reply.

I have tested your suggestion and you are right. Now I understand the situation.

dull menu icons - especially hard to distinguish OOo apps :\
OOo would better use their older launch-iconset (ass 22x22 the many details in icons are useless and cause more trouble )
in the fashion of http://en.wikipedia.org/wiki/Image:OOoCalc.svg
(they are also common to people swithcing from win ;)

(my Theme is Aquativo-1.5, bus as I understood that doesn't matter in this case)

sorry, for the "nominate" action, probably it is not for what I expected.
I thought it is kind of "vote for the issue"

Pedro Villavicencio (pedro) wrote :

Declination for gutsy, based on the nominator last comments, thanks.

Fixed in Hardy.

Changed in gnome-themes:
status: New → Fix Released
Changed in gnome-themes:
status: New → Fix Released
Changed in openoffice.org:
status: New → Fix Released
Changed in gnome-themes (Ubuntu):
status: Fix Released → Incomplete
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.