Comment 34 for bug 787465

Daniel Hahler (blueyed) wrote :

I have still experienced this buggy using gnome-terminal and its menubar after upgrading to Ubuntu Precise.

I have fixed it now by installing any missing recommends, using "sudo apt-get install --fix-policy --install-recommends".

One or multiple of the packages this installed appears to have fixed it. And it is likely to be a package which is present when installing Oneiric from scratch (where this is a non-issue for me).

Here's the list of packages containing "menu" or "indicator" in its name:
appmenu-gtk3 0.3.0-0ubuntu1
gir1.2-dbusmenu-gtk-0.4 0.5.1-0ubuntu2
gnome-menus 3.2.0-0ubuntu2
indicator-status-provider-mc5 0.5.0-1

And here's the full list of packages this pulled in:
% awk '/2011-12-17 14:1.*status installed/ {print $5 " " $6}' /var/log/dpkg.log | sort -u
apg 2.2.3.dfsg.1-2
appmenu-gtk3 0.3.0-0ubuntu1
automake1.4 1:1.4-p6-13.1
bamfdaemon 0.2.104-0ubuntu1
c2esp 21-1
colord 0.1.15-1
cowbuilder 0.65ubuntu1
cowdancer 0.65ubuntu1
cpu-checker 0.7-0ubuntu1
cups 1.5.0-13bzr1
deja-dup 21.2-0ubuntu2
desktop-file-utils 0.18-1ubuntu3
dma-migrate 0.0.2010.06.17-11
doc-base 0.10.3
docutils-doc 0.8.1-4
duplicity 0.6.17-0ubuntu1
ebtables 2.0.9.2-2ubuntu2
enchant 1.6.0-6
erlang-syntax-tools 1:14.b.4-dfsg-1ubuntu1
firefox-locale-de 9.0~b6+build1-0ubuntu1
florence 0.5.0-2
fontconfig 2.8.0-3ubuntu2
fonts-horai-umefont 434-1
fonts-kacst 2.01+mry-3
fonts-nanum 3.010-2
gconf2 3.2.3-1ubuntu1
gir1.2-dbusmenu-gtk-0.4 0.5.1-0ubuntu2
gir1.2-gst-plugins-base-0.10 0.10.35.2-2build1
gir1.2-gstreamer-0.10 0.10.35.2-1ubuntu1
gir1.2-panelapplet-3.0 1:2.32.1-0ubuntu6.5
gir1.2-panelapplet-4.0 1:3.2.0-0ubuntu1
gir1.2-rb-3.0 2.90.1~20111126.89c872b0-0ubuntu2
gir1.2-wnck-3.0 3.2.1-1
gnome-applets 3.2.0-0ubuntu1
gnome-menus 3.2.0-0ubuntu2
gnome-online-accounts 3.2.1-2
gnome-orca 3.3.2-0ubuntu2
gnome-panel 1:3.2.0-0ubuntu1
gnome-session-fallback 3.2.1-0ubuntu4
gnome-themes-standard 3.2.1-0ubuntu2
hicolor-icon-theme 0.12-1ubuntu1
ibus-gtk3 1.4.0-1ubuntu3
icoutils 0.29.1-2
indicator-status-provider-mc5 0.5.0-1
install-info 4.13a.dfsg.1-8ubuntu1
iw 3.1-1
kompare 4:4.7.3-0ubuntu1
kubuntu-debug-installer 11.10ubuntu1
kvm-ipxe 1.0.0+git-2.149b50-1ubuntu3
libalgorithm-c3-perl 0.08-1
libcanberra-gtk3-module 0.28-0ubuntu12
libcanberra-gtk-module 0.28-0ubuntu12
libc-bin 2.13-23ubuntu1
libclass-c3-perl 0.23-1
libclass-c3-xs-perl 0.13-1build2
libclass-method-modifiers-perl 1.08-1
libclutter-1.0-common 1.8.2-2ubuntu1
libcogl-common 1.8.2-1
libcommons-codec-java 1.5-1
libdmapsharing-3.0-2 2.9.14-1
libdom4j-java 1.6.1+dfsg.2-5
libfile-rsyncp-perl 0.68-1.1build6
libfolks-eds25 0.6.5-2
libftdi1 0.19-3
libgail-gnome-module 1.20.3-1
libgd-gd2-noxpm-perl 1:2.46-2build1
libglib2.0-0 2.31.4.tested-0ubuntu3
libgphoto2-l10n 2.4.11-3.1
libgtk-3-0 3.3.4-0ubuntu2
libhtml-form-perl 6.00-1
libio-dirent-perl 0.04-2build2
libjaxme-java 0.5.2+dfsg-5
libjpeg-progs 8c-2ubuntu4
liblog4j1.2-java 1.2.16-2ubuntu2
libltdl-dev 2.4.2-1ubuntu1
libmagickcore4-extra 8:6.6.9.7-5ubuntu2
libmail-sendmail-perl 0.79.16-1
libmono-i18n4.0-cil 2.10.5-1ubuntu1
libmono-i18n-west4.0-cil 2.10.5-1ubuntu1
libmro-compat-perl 0.11-1
libmtp-runtime 1.1.1-1
libnetpbm10 2:10.0-15
libnet-snmp-perl 6.0.1-2
libpackage-stash-xs-perl 0.24-1build1
libpam-winbind 2:3.5.11~dfsg-4ubuntu3
libpanel-applet2-0 1:2.32.1-0ubuntu6.5
libpanel-applet-3-0 1:2.32.1-0ubuntu6.5
libpanel-applet-4-0 1:3.2.0-0ubuntu1
libqapt1 1.2.65-0ubuntu1
libqapt-runtime 1.2.65-0ubuntu1
libqt4-sql-sqlite 4:4.7.4-1ubuntu6
librhythmbox-core4 2.90.1~20111126.89c872b0-0ubuntu2
librsync1 0.9.7-8
libsctp1 1.0.11+dfsg-2
libssl-doc 1.0.0e-2ubuntu4
libsys-hostname-long-perl 1.4-2
libvirtodbc0 6.1.3+dfsg1-1ubuntu3
libx11-doc 2:1.4.4-4
libxom-java 1.2.1-3
libxpp2-java 2.1.10-7
libxpp3-java 1.1.4c-2
linux-headers-3.2.0-5-generic 3.2.0-5.11
linux-headers-generic 3.2.0.5.5
lirc 0.9.0-0ubuntu1
lksctp-tools 1.0.11+dfsg-2
lzma 4.43-14ubuntu2
man-db 2.6.0.2-3
msr-tools 1.2-3
netpbm 2:10.0-15
odbcinst1debian2 2.2.14p2-5ubuntu2
odbcinst 2.2.14p2-5ubuntu2
orbit2 1:2.14.19-0.1
printer-driver-c2esp 21-1
ptouch-driver 1.3-0ubuntu11
python-chameleon 2.6.1-1
python-iniparse 0.4-2.1
python-paramiko 1.7.7.1-2
python-prctl 1.1.1-1build1
python-support 1.0.14ubuntu2
qapt-batch 1.2.65-0ubuntu1
qt-at-spi 0.0~git20110628-0ubuntu2
rastertosag-gdi 0.1-0ubuntu3
rhythmbox 2.90.1~20111126.89c872b0-0ubuntu2
rhythmbox-plugin-cdrecorder 2.90.1~20111126.89c872b0-0ubuntu2
rhythmbox-plugins 2.90.1~20111126.89c872b0-0ubuntu2
safecat 1.13-1build1
samba-dsdb-modules 4.0.0~alpha17.dfsg2-1
setserial 2.17-46
sni-qt 0.2.5-0ubuntu3
ssh-import-id 2.6-0ubuntu1
thunderbird-gnome-support 9.0~b5+build1-0ubuntu1
tsclient 0.150-4ubuntu2
ttf-sazanami-gothic 20040629-8ubuntu1
ttf-umefont 434-1
ubuntuone-client-gnome 2.0.1-0ubuntu3
ubuntuone-couch 0.3.0-0ubuntu2
ureadahead 0.100.0-11
virtuoso-minimal 6.1.3+dfsg1-1ubuntu3
virtuoso-opensource-6.1-bin 6.1.3+dfsg1-1ubuntu3
virtuoso-opensource-6.1-common 6.1.3+dfsg1-1ubuntu3
winbind 2:3.5.11~dfsg-4ubuntu3
xz-lzma 5.1.1alpha+20110809-3