Reflow terminal contents when resizing the window

Bug #298385 reported by Markus Amalthea Magnuson on 2008-11-15
202
This bug affects 43 people
Affects Status Importance Assigned to Milestone
GNOME Terminal
Fix Released
Wishlist
gnome-terminal (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-terminal

Currently, if I resize a terminal window with text content that wraps, the text
block size stays. The reason for resizing a terminal window with wrapping
content is 99% of the time because I want to reflow the text, to which the only
solution now is to rerun the last command, possibly with different results (=
useless).

See corresponding gnome bug report for more info.

Arnaud Soyez (weboide) wrote :

Confirmed in Intrepid, gnome-terminal 2.24.1.1-0ubuntu1

Changed in gnome-terminal:
status: New → Confirmed
Changed in gnome-terminal:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Confirmed → Triaged
Changed in gnome-terminal:
status: Unknown → New
Changed in gnome-terminal:
status: New → Invalid

Upstream bug has been marked as duplicate of bug https://bugzilla.gnome.org/show_bug.cgi?id=336238.

Changed in gnome-terminal:
status: Invalid → Unknown
Changed in gnome-terminal:
status: Unknown → Confirmed
Changed in gnome-terminal:
importance: Unknown → Wishlist
Egmont Koblinger (egmont-gmail) wrote :

I'm making great progress in implementing this. Please see the upstream bug at https://bugzilla.gnome.org/show_bug.cgi?id=336238 , feel free to try my patch if you're a hacker kind. In case of any feedback, please comment in that upstream bug, thanks!

Changed in gnome-terminal:
status: Confirmed → Incomplete
Changed in gnome-terminal:
status: Incomplete → Confirmed
Egmont Koblinger (egmont-gmail) wrote :

vte 0.35 implements this feature.

Changed in gnome-terminal:
status: Confirmed → Fix Released

Is there any way for a regular user to start using the new version with the fix?

Changed in gnome-terminal (Ubuntu):
status: Triaged → Fix Released
Miklos Juhasz (mjuhasz) wrote :

Despite the Fix Released status I can confirm that this bug is not fixed in Ubuntu 14.04, most probably because vte 0.35 implements this feature while Ubuntu 14.04 has only 0.34.

Sorry, I should have added that you need to enable the Gnome-team PPA to have the fix. It is present in this package version:

Package: libvte-2.90-9
Version: 1:0.36.0-1ubuntu1~trusty1

Manuel Seelaus (seelaman) wrote :

I am still seeing this issue on vivid:

$ dpkg -l libvte-2.90-9
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-======================-================-================-==================================================
ii libvte-2.90-9 1:0.36.3-1ubuntu amd64 Terminal emulator widget for GTK+ 3.0 - runtime fi

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.