unable to write ~ and ^ chars in the terminal

Bug #1790100 reported by Matthieu Baerts on 2018-08-31
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Undecided
Unassigned
vte2.91 (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

I am using Ubuntu 18.10 and since the last update, I am unable to write ~ and ^ chars in the terminal, in both gnome-terminal and Geany (both using libvte2.91).

I don't have this issue with other applications (terminator, xterm, Firefox, Gedit, etc.). But note that now, when I type ^ for the first time in Gedit for example, I see this char but underlined. If I type it a second type (or press space), it is transformed in ^ without line under it. This is a new behaviour that can cause this bug in libvte.

Please tell me if I need to join other info!

Thanks!

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: libvte-2.91-0 0.52.2-1ubuntu1
ProcVersionSignature: Ubuntu 4.17.0-9.10-generic 4.17.17
Uname: Linux 4.17.0-9-generic x86_64
ApportVersion: 2.20.10-0ubuntu9
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Aug 31 11:17:43 2018
InstallationDate: Installed on 2015-08-10 (1116 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
SourcePackage: vte2.91
UpgradeStatus: Upgraded to cosmic on 2016-04-29 (854 days ago)

Matthieu Baerts (matttbe) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vte2.91 (Ubuntu):
status: New → Confirmed
giannione (giannione) wrote :

I have the same problem on ubuntu 18.10 on gnome terminal (the problem appeared after upgrading from an 17.04ubuntu).

*xev gnome terminal output (in gnome terminal ^ doesn't work)*

KeyPress event, serial 37, synthetic NO, window 0x2c00001,
    root 0x2ac, subw 0x0, time 12476575, (1386,-67), root:(1426,349),
    state 0x11, keycode 21 (keysym 0x5e, asciicircum), same_screen YES,
    XLookupString gives 1 bytes: (5e) "^"
    XmbLookupString gives 1 bytes: (5e) "^"
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x2c00001,
    root 0x2ac, subw 0x0, time 12476723, (1386,-67), root:(1426,349),
    state 0x11, keycode 21 (keysym 0x5e, asciicircum), same_screen YES,
    XLookupString gives 1 bytes: (5e) "^"
    XFilterEvent returns: False

*xev terminator output (in terminator ^ works perfectly)*

KeyPress event, serial 37, synthetic NO, window 0x2a00001,
    root 0x2ac, subw 0x0, time 12700278, (680,1395), root:(756,1613),
    state 0x11, keycode 21 (keysym 0x5e, asciicircum), same_screen YES,
    XLookupString gives 1 bytes: (5e) "^"
    XmbLookupString gives 1 bytes: (5e) "^"
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x2a00001,
    root 0x2ac, subw 0x0, time 12700465, (680,1395), root:(756,1613),
    state 0x11, keycode 21 (keysym 0x5e, asciicircum), same_screen YES,
    XLookupString gives 1 bytes: (5e) "^"
    XFilterEvent returns: False

giannione (giannione) wrote :

gnome says that it's not their problem
https://gitlab.gnome.org/GNOME/gnome-terminal/issues/48

Matthieu Baerts (matttbe) wrote :

> gnome says that it's not their problem

The problem was fixed for me a while ago but I forgot to update the status of this bug report.

@giannione Did you restart your session in between?

For me, it was not an issue in gnome-terminal, more in libvte used by gnome-terminal and others: https://gitlab.gnome.org/GNOME/vte

Matthieu Baerts (matttbe) wrote :

@giannione: as it is fixed for me, I propose to close this bug report. Feel free to re-open it or a new one if you have this bug again after a restart of your session.

Changed in vte2.91 (Ubuntu):
status: Confirmed → Fix Released
giannione (giannione) wrote :

I still have the problem in gnome terminal, it didn't go away...

Matthieu Baerts (matttbe) wrote :

@giannione: may you create a new bug report? I guess you don't have the same configuration as me, maybe not the same bug then.

Before doing that, may you check if you also have the problem with other applications using libvte?

Pick one from:

$ apt-cache rdepends libvte-2.91-0
libvte-2.91-0
Reverse Depends:
  mssh
  xfce4-terminal
  xcfa
  vinagre
  tilda
  termit
  synaptic
  sakura
  nemiver
  mate-terminal
  qemu-system-gui
  lxterminal
  lilyterm
  libvted-3-0
  gtkterm
  gnome-color-manager
  gnome-builder
  giggle-terminal-view-plugin
  deepin-terminal
  cairo-dock-terminal-plug-in
  anjuta
  aghermann
  remmina
  gnome-terminal
  libvte-2.91-dev
  gir1.2-vte-2.91

and:

$ apt-cache rdepends libvte9
libvte9
Reverse Depends:
  stjerm
  libvte-2.90-common
  python-vte
  rasmol
  libvte-common
  libvte-dev
  geany

I remember I checked with geany and I also had the bug.

Feel free to report your bug here on launchpad and there: https://gitlab.gnome.org/GNOME/vte

giannione (giannione) wrote :

synaptic works
remmina works

giannione (giannione) wrote :

gedit works

Matthieu Baerts (matttbe) wrote :

@giannione: that's interesting, that maybe means that the bug is not in vte2.91. May you give this information to gnome-terminal devs?

They don't want to hear about it and say that it's Ubuntu's fault....

Il venerdì 9 novembre 2018, Matthieu Baerts <email address hidden> ha scritto:

> @giannione: that's interesting, that maybe means that the bug is not in
> vte2.91. May you give this information to gnome-terminal devs?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1790100
>
> Title:
> unable to write ~ and ^ chars in the terminal
>
> Status in vte2.91 package in Ubuntu:
> Fix Released
>
> Bug description:
> Hello,
>
> I am using Ubuntu 18.10 and since the last update, I am unable to
> write ~ and ^ chars in the terminal, in both gnome-terminal and Geany
> (both using libvte2.91).
>
> I don't have this issue with other applications (terminator, xterm,
> Firefox, Gedit, etc.). But note that now, when I type ^ for the first
> time in Gedit for example, I see this char but underlined. If I type
> it a second type (or press space), it is transformed in ^ without line
> under it. This is a new behaviour that can cause this bug in libvte.
>
> Please tell me if I need to join other info!
>
> Thanks!
>
> ProblemType: Bug
> DistroRelease: Ubuntu 18.10
> Package: libvte-2.91-0 0.52.2-1ubuntu1
> ProcVersionSignature: Ubuntu 4.17.0-9.10-generic 4.17.17
> Uname: Linux 4.17.0-9-generic x86_64
> ApportVersion: 2.20.10-0ubuntu9
> Architecture: amd64
> CurrentDesktop: ubuntu:GNOME
> Date: Fri Aug 31 11:17:43 2018
> InstallationDate: Installed on 2015-08-10 (1116 days ago)
> InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
> SourcePackage: vte2.91
> UpgradeStatus: Upgraded to cosmic on 2016-04-29 (854 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/vte2.91/+bug/
> 1790100/+subscriptions
>

Please understand: It's not that we (vte and gnome-terminal developers) don't want to hear about it. We've heard about it and we are pretty certain that this is a bug somewhere elsewhere. Vte's and gnome-terminal's source code has absolutely no sign of treating ^ or any other similar simple character specially.

Matthieu Baerts (matttbe) wrote :

@Egmont: thank you for your input. I just added "gnome-terminal" package in Ubuntu. I hope it is alright for you.

Note that I no longer have this issue on my side.

@giannione: do you have this bug with Wayland too?
I think you can send a few useful info by using a command like "ubuntu-bug -u 1790100" (I don't remember if you need do add "-p gnome-terminal").

ProblemType: Bug
ApportVersion: 2.20.9-0ubuntu7.4
Architecture: amd64
CurrentDesktop: GNOME
DistroRelease: Ubuntu 18.04
InstallationDate: Installed on 2017-10-25 (387 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
Package: gnome-terminal 3.28.2-1ubuntu1~18.04.1
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 4.15.0-38.41-generic 4.15.18
Tags: bionic wayland-session
Uname: Linux 4.15.0-38-generic x86_64
UpgradeStatus: Upgraded to bionic on 2018-10-13 (34 days ago)
UserGroups: adm cdrom dip libvirt lpadmin plugdev sambashare sudo vboxusers
_MarkForUpload: True

tags: added: apport-collected bionic

apport information

apport information

apport information

giannione (giannione) wrote :

hello, I run that command
"ubuntu-bug -u 1790100"

ProblemType: Bug
ApportVersion: 2.20.9-0ubuntu7.4
Architecture: amd64
CurrentDesktop: GNOME
DistroRelease: Ubuntu 18.04
InstallationDate: Installed on 2017-10-25 (387 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
Package: gnome-terminal 3.28.2-1ubuntu1~18.04.1
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 4.15.0-38.41-generic 4.15.18
Tags: bionic wayland-session
Uname: Linux 4.15.0-38-generic x86_64
UpgradeStatus: Upgraded to bionic on 2018-10-13 (34 days ago)
UserGroups: adm cdrom dip libvirt lpadmin plugdev sambashare sudo vboxusers
_MarkForUpload: True

apport information

apport information

giannione (giannione) wrote :

still can't type ^
... :-(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers