"New Tab" disappeared from the GNOME Terminal menu

Bug #1747171 reported by AsciiWolf on 2018-02-03
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Medium
Unassigned
Bionic
Medium
Unassigned

Bug Description

Impact
------
GNOME Terminal removed the New Tab menu option before Ubuntu 16.04 LTS. Tabs are a really popular feature in terminals and it's annoying to have this feature hidden.

Test Case
---------
Install the update.
Close all terminals.
Open a terminal.
In the File menu should be New Tab and New Window menu items. Both should work.

Regression Potential
--------------------
Restoring the previous behavior is now a one-line hidden configure option.

Enabling that option removes the "Open new terminals in" option mentioned in the workaround.

This build option is set in Fedora (and other distros that use the Fedora tweaks) and is not believed to have any negative consequences.

Other Info
----------
There are no plans at this time to try to backport this change to Ubuntu 16.04 LTS or 17.10 because it would not be a simple one-line change there. (The configure flag was enabled in git commit 0820b385 .)

https://debarshiray.wordpress.com/2018/05/11/gnome-terminal-separate-menu-items-for-opening-tabs-and-windows/

Workaround
----------
In Edit > Preferences (General) you can set "Open new terminals in Tab". Now, the File > New Window menu item opens a new tab instead of a new window.

Original Bug Report
-------------------
There is not a "New Tab" option in the file menu of GNOME Terminal anymore on Ubuntu Bionic. It looks like it disappeared after some recent update. However, the CTRL + Shift + T shortcut works as expected.

AsciiWolf (asciiwolf) wrote :

(The "New Tab" option is present in the upstream GNOME Terminal so this is not an upstream issue.)

Egmont Koblinger (egmont-gmail) wrote :

Hi,

I'm not sure what makes you believe there's a "New Tab" in mainstream GNOME Terminal, it's not the case. "New Window" and "New Tab" were merged quite some time ago into a single "New Terminal". The two actions are still available as separate shortcuts. The menu entry behaves according to Edit -> Preferences -> General -> Open new terminals in: Window/Tab.

AsciiWolf (asciiwolf) wrote :

Oops, didn't know that! The "New Tab" menu option is there in Fedora.

Egmont Koblinger (egmont-gmail) wrote :

Yup, it's *their* patch :)

Actually I think gnome-terminal is just a

Egmont Koblinger (egmont-gmail) wrote :

(sorry)

I think gnome-terminal is just a "define DISUNIFY_NEW_TERMINAL_SECTION" away from the previous behavior... dunno, haven't tried.

Egmont Koblinger (egmont-gmail) wrote :

Yup, tried it now. Just compile with
  CPPFLAGS=-DDISUNIFY_NEW_TERMINAL_SECTION ./configure --blahblah
and you'll get two separate entries.

I have no idea why the upstream change was made.

Jeremy Bicha (jbicha) on 2018-05-11
description: updated
Changed in gnome-terminal (Ubuntu):
status: New → Fix Committed
importance: Undecided → Medium
Changed in gnome-terminal (Ubuntu Bionic):
importance: Undecided → Medium
status: New → Triaged
Jeremy Bicha (jbicha) on 2018-05-11
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-terminal - 3.28.1-1ubuntu2

---------------
gnome-terminal (3.28.1-1ubuntu2) cosmic; urgency=medium

  * Restore File > New Tab menu item. Thanks Debarshi Ray for the suggestion.
    (LP: #1747171)

 -- Jeremy Bicha <email address hidden> Fri, 11 May 2018 17:15:21 -0400

Changed in gnome-terminal (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2018-05-12
description: updated
Changed in gnome-terminal (Ubuntu Bionic):
status: Triaged → In Progress

Hello AsciiWolf, or anyone else affected,

Accepted gnome-terminal into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-terminal/3.28.1-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-terminal (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

It's probably not a real concern since I'm sure it's all covered, but could we make sure the new menu item is translated correctly for non-EN languages?

The new menu items are there in mainstream gnome-terminal's source (behind a configure flag; so they aren't added by Ubuntu). Hence they are translated (or not) according to the mainstream GNOME translators' work.

Jeremy, Łukasz,

If you're about to release an update for Bionic, could you please backport the trivial
  https://git.gnome.org/browse/gnome-terminal/commit/?h=gnome-3-28&id=1828cb6d5
as well?

At one place the strings are accidentally left untranslated on the UI, even though at some other place these same strings appear properly translated (that is, the translations are already present accoding to translators' work, just remain unused at one place).

Technically it's absolutely independent from the current "New Tab" issue; however, I think we should optimize for releasing as few updates as possible, hence I'm trying to sneak it in here. Thanks!

Jeremy Bicha (jbicha) wrote :

Egmont, thank you for comment. comment #8 is the template message indicating that this update has already landed in bionic-proposed so I think we'll wait for the next Stable Release Update (SRU) for that fix. You're welcome to open a new bug for that issue and you can read about the process at
https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Jeremy Bicha (jbicha) wrote :

I verified that the New Tab menu option is present after installing gnome-terminal 3.28.1-1ubuntu1.1 on Ubuntu 18.04 LTS.

I also installed language-pack-gnome-fr, switched my language to French (France) in Settings > Region and Language. I logged out and logged back in. I opened the Terminal and verified that the New Tab option is translated (Nouvel onglet) and works.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic

Well, since it's in "proposed", which I guess means waiting for feedback, and is not an urgent update at all, my feedback was maybe you should hold it off and release along with that other fix to save an update for users :-) Anyway, filed that as bug 1771290, rest is up to you. Thanks a lot! :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers