changing user password causes hang in users-admin

Bug #661272 reported by xteejx on 2010-10-15
70
This bug affects 14 people
Affects Status Importance Assigned to Milestone
gnome-system-tools (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-system-tools

I tried to change my password to Ubuntu in the usual manner; System>Administration>Users and Groups.
When I done this, the window hanged and I don't know if it actually completed (I have work to do and can't logout just yet).
Info should be attached.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-system-tools 2.32.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Fri Oct 15 15:52:25 2010
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/users-admin
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate i386 (20100928)
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: gnome-system-tools

Milan Bouchet-Valat (nalimilan) wrote :

If it hung, it's likelly that the change wasn't performed. Could you please run 'passwd' in a terminal, try to change your password that way, and copy/paste the full output here? Thanks!

Changed in gnome-system-tools (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete

Yes, the password did change that way and was left as the old one:

$ passwd xxxxxx
Changing password for xxxxxx.
(current) UNIX password:
Enter new UNIX password:
Retype new UNIX password:
passwd: password updated successfully

Milan Bouchet-Valat (nalimilan) wrote :

> Yes, the password did change that way and was left as the old one
What do you mean? I really don't understand this sentence as its two parts sound antithetic to me.

My general idea is that users-admin hangs when 'passwd' fails with an error message we don't handle. Which doesn't seem to be the case here. Did you use the same new password? Are you able to reproduce the hang in users-admin? Have you tried with different values for the new password?

The password, when changed through users-admin when it crashed was not changed.
Using passwd <user> in the terminal changed it, so the problem is with users-admin.

Milan Bouchet-Valat (nalimilan) wrote :

You didn't answer my other questions...

Rastislav Galia (rachotilko) wrote :

I encountered the bug too after I performed an system update this morning (15. October) via update-manager.

Your other questions:

1, No, actual and new passwords differed, I was careful enough to perform the correct steps that should have led to successful password change.

2, The hanging behaviour is password-independent and happens always - it means it's perfectly reproducible. It effectively means it is not possible to change the password in a GUI way.

3, It does occur only if I try to change my own password, not other users.

4, 'passwd' succeeded in changing my password without any trouble.

What additional input is needed to change the bug's status from 'incomplete' to 'assigned' ?

Oops, I should really have a coffee before replying.
I didn't use the same password, and I did try other passwords with the same result. It is reproducible every time as far as I can tell.
I will run through DebuggingProgramCrash on the wiki and see if I can some kind of trace (now I'm awake).

Managed to grab a backtrace (attached)

Changed in gnome-system-tools (Ubuntu):
status: Incomplete → New

Why have you changed this to New. Please don't.

Changed in gnome-system-tools (Ubuntu):
status: New → Incomplete

Teej: thanks for the trace, but that's not really what I need since I know where the problem happens in the code (where it waits for a reply from the 'passwd' program), but I need to know why it waits. (And BTW, you'd need to install more debugging symbols packages to get a useful trace.)

Ratislav: could you copy/paste the output of 'passwd' when you change your password? Just to be sure I can't find anything wrong with it.

Rastislav, Teej: Could you try to change your password using the 'About Me' program from System->Preferences? It should fail if users-admin fails, but I'd need to be sure. I'm running out of ideas, because I'm not able to reproduce the bug here, and yet it seems everything works the same as you...

Another question: please open two terminals, and:
- in the first one, run 'passwd', type your *old* password, hit RETURN, and let the terminal in this state
- then, in the second one, try to change your password using 'passwd' the normal way

Then, please copy/paste the output of the second terminal if anything weird appears.

Nope, that works as it should, perhaps it's just the call to passwd from gtk that causes the problem.

And how about my comment #11?

Launchpad Janitor (janitor) wrote :

[Expired for gnome-system-tools (Ubuntu) because there has been no activity for 60 days.]

Changed in gnome-system-tools (Ubuntu):
status: Incomplete → Expired
Chris Seickel (cseickel) wrote :

Milan: I tried the test in comment #11 and had no unusual output. The password changed successfully in the second terminal.

Using the GUI, it hangs every time and does not change my password. I tried this from a fresh install first, and the problem continued after several after running all updates on Feb 26, 2011.

UPDATE: After successfully changing my password from the terminal, the GUI utility works fine for subsequent changes. In case any of this info helps: When I had the problem, it was the first time trying to change my password since the install, and I did fail the first attempt because I was just changing the case. I have my system set to auto login.

Fabio Marconi (fabiomarconi) wrote :

Reopened because afflict natty

Changed in gnome-system-tools (Ubuntu):
status: Expired → Confirmed
tags: added: natty

Chris: Are you able to reproduce the problem now? If I change my password from lowercase to uppercase, I get an error message, not a hang. Are you using Maverick? Could you try the procedure from comment #12 too?

Fabio: How can you say it affects Natty? Do you experience the bug there too? If so, I need details, merely reopening is pointless.

delki8 (delki8) wrote :

This bug is also present on the 12.04 final.

rogue-spectre (rogue-spectre) wrote :

Hi,

     bug append also in Xubuntu 14.04.03.

It is a very annoying bug for people who install distros with a generic password. Once the pc is delivered, the first thing to do is to change the password and a lot of time the user make a "fatal" mistake…

Some informations i gathered for now :

One can make errors like password too short ( len < 6 ) or not identical ( errors handled in src/users/user-password.c ). If a good one is given after the change is done.

But if it is an other type of error ( tried password similar to the current one, simple - errors that seemed to be handle in src/users/run-password.c ), giving a good password after that just freeze users-admin.

rogue-spectre (rogue-spectre) wrote :

some infos :

Test :
fill current password
fill new password with current password
fill confirmation with current password
click ok
get the error message that new password is the same
fill new password with a new password
fill confirmation with a new password ( without error ! )

Here two case
  1 - if click ok > freeze
  2 - if focus on current password, then click ok > password changed successfully

rogue-spectre (rogue-spectre) wrote :

update to previous test

fill current password
fill new password with current password
fill confirmation with current password
click ok
get the error message that new password is the same
focus on current password
fill new password with a new password
fill confirmation with a new password ( without error ! )
click ok
change is done

so after one error if focus is set on current password before or after typing and confirming the new password, there is no freeze.

rogue-spectre (rogue-spectre) wrote :

On Ubuntu 16.06 (daily build 23/02/2016), the interface is not the same as in gnome-system-tools, but one can see that
the file src/users/run-passwd.c present in gnome-system-tools
was reused in panels/user-accounts/run-passwd.c in ubuntu-control-center
with some modifications. maybe it can help

rogue-spectre (rogue-spectre) wrote :

so it seems for my case that we are stuck in "case PASSWD_STATE_NEW" of io_watch_stdout, because of an error of "Authentication token manipulation error".

If i force the state to go to PASSWD_STATE_RETYPE by adding

           else if(is_string_complete (str->str, "token", NULL)) {
                /* Advance to next state */
    passwd_handler->backend_state = PASSWD_STATE_RETYPE;
                reinit = TRUE;
            }

in the if of case PASSWD_STATE_NEW of io_watch_stdout, the interface doesn't freeze, but prompt me the same error message that i had the first time, i must so retype a second time the right new password.

rogue-spectre (rogue-spectre) wrote :

Hi,

    here a patch of src/users/run-passwd.c that allows me to do multiples mistakes when trying to change my password.

The attachment "patch for src/users/run-passwd.c" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
miyod (miyod) wrote :

I just encountered what looks like this bug, but it worked a little bit differently:
1) Attempted to change admin account's password (xxx to yyy) using Users and Groups. It was rejected for being too similar to the one to be changed.
2) Tried changing to an automatically generated password (AUTOGEN). Seemed to succeed.
3) Copy&pasted the automatically generated password and tried changing from that one to yyy+a space
4) Window hanged. I closed all other windows but no luck. Closing that window (leaving open the Users and Groups one) and reopening it showed it was still not responding.
5) Changed the password from AUTOGEN to yyy+space from the terminal. First time it threw an error (authentication token...). Tried again, success. Users and Groups window for my user started responding again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers