time-admin crashes when selecting time-zone

Bug #58629 reported by Matti Lindell on 2006-09-02
70
This bug affects 10 people
Affects Status Importance Assigned to Milestone
GST
Fix Released
Critical
gnome-system-tools (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Edgy Knot2
Architecture: i386
Version: 2.15.2-0ubuntu5

time-admin crashes right after I press "Select Time Zone.." button. I'll attach the backtrace.

Matti Lindell (mlind) wrote :

Crash backtrace

Matti Lindell (mlind) wrote :

I'm using debootstrapped Edgy install. Using tzconfig, I noticed that timezone was set to 'Unknown' as default.

$ tzconfig
Your current time zone is set to Unknown
Do you want to change that? [n]: y

After I changed the value to 'Europe/Helsinki', time-admin doesn't crash anymore.
This bug should be reproducible if timezone is set to Unknown first.

description: updated
Colin Watson (cjwatson) wrote :

This also happens when time-admin is launched from Ubiquity on a current Edgy i386 desktop CD.

Changed in gnome-system-tools:
importance: Untriaged → High
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

I've forwarded that issue upstream: http://bugzilla.gnome.org/show_bug.cgi?id=356761

Changed in gnome-system-tools:
assignee: nobody → desktop-bugs
Changed in gst:
status: Unknown → Unconfirmed
Sebastien Bacher (seb128) wrote :

This upload fixes the issue:

" gnome-system-tools (2.15.5-0ubuntu1) edgy; urgency=low
 .
   * New upstream version:
     Common:
     - add a --disable-gnome option to disable GNOME dependencies
     - Show an "Access denied" dialog if g-s-t can't access s-t-b
     Shares:
     - remove unneeded GNOME-VFS dependency
     - fix a crasher
     Time:
     - optimize the map dot blink timeout to be only executed when the map
       is shown
     - Fix a crasher when there is no timezone (Ubuntu: #58629)
     Translations:
     - fi
   * debian/control.in:
     - Build-Depends on libart-2.0-dev and new liboobs-1-dev (>= 0.5.0)
   * debian/patches/90_from_cvs_fix_shares_admin_crasher.dpatch:
     - fixed with the new version
   * debian/patches/98_automake.dpatch:
     - updated"

Changed in gnome-system-tools:
status: Confirmed → Fix Released
Changed in gst:
status: Unconfirmed → Fix Released
Tux (peter-hoogkamer) wrote :

I have a brand new install of Karmic alpha 3, but my time zone crashes. This looks like regression, because I did not have this issue on jaunty. The world map is black with yellow dots and the list with timezones is empty. After opening that selection list, time-admin crashes.
Attachements show console output form time-admin and screenshot from black timezone screen.

Tux (peter-hoogkamer) wrote :

Here is my screenshot of black time zone world map.

Pedro Villavicencio (pedro) wrote :

you need to report a new bug with apport, a screenshot doesn't help at all with a crash.

Ok, well I did a bug report with apport, but I saw this report and reacted.

2009/8/5 Pedro Villavicencio <email address hidden>:
> you need to report a new bug with apport, a screenshot doesn't help at
> all with a crash.
>
> --
> time-admin crashes when selecting time-zone
> https://bugs.launchpad.net/bugs/58629
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Flavelle (flavelle.ballem) wrote :

The report describing the empty timezone and black time zone world map is exactly what occurred to me in Karmic Alpha 4 (clean install).

I got to this bug through apport, and didn't want to report a new bug.

Changed in gst:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.