gnome-network-admin on UbuntuStudio doesnt allow to configure either wired networks or wireless

Bug #570828 reported by Ricardo Lameiro on 2010-04-27
64
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gnome-system-tools (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: gnome-system-tools

Systems were the problem is found

UbuntuStudio 10.04 - i386/AMD64

After installation, there is no easy way to setup networking, either wireless or wired.

the networking management tool doesn't give options or tools to configure networks.

I leave here 3 links with screenshots of the only networks setup that can be done after clean install.
http://dl.dropbox.com/u/1333955/net1.png
http://dl.dropbox.com/u/1333955/net2.png
http://dl.dropbox.com/u/1333955/net3.png

If more information is needed please let me know.

P.S.: I didn't filed this bug via apport, because i don't have networking due to the bug :D

tags: added: iso-testing
Milan Bouchet-Valat (nalimilan) wrote :

network-admin (the program you're using) is not provided by default in Ubuntu. It has to be installed manually with the gnome-network-admin package, and it's not the recommended way of setting up connections.

You should rather use NetworkManager, which is available from System->Administration->Network Connections (or start it with nm-connection-editor.

have you upgraded from Hardy?

Changed in gnome-system-tools (Ubuntu):
status: New → Invalid
Ricardo Lameiro (rlameiro) wrote :

This is for Ubuntu Studio, not Vanilla Ubuntu.
UbuntuStudio doesn't use network manager.

Changed in gnome-system-tools (Ubuntu):
status: Invalid → New
Milan Bouchet-Valat (nalimilan) wrote :

Ugh... So there's a clear conflict with the current Ubuntu package, which has a patch specially cooked to hide interfaces from the GUI, to avoid conflicts with NetworkManager. Why the hell doesn't UbuntuStudio use NetworkManager? Have artists special needs in that regard?!

Scott Lavender (slavender) wrote :

Milan,

Please review this bug again. It is for Ubuntu Studio Lucid 10.04.

In Ubuntu Studio gnome-network-admin is installed by default.

Perhaps this is not the right place to discuss this, but Milan's question of why does UbuntuStudio diverge from stock with regard to NetworkManager is a legitimate one. Is the reasoning documented somewhere?

Milan Bouchet-Valat (nalimilan) wrote :

Well, if NetworkManager can't be used by default (I agree that's a bit late :-), I think we need to revert the patch. See:
http://bazaar.launchpad.net/%7Eubuntu-branches/ubuntu/lucid/gnome-system-tools/lucid/annotate/head%3A/debian/patches/10_disable_interfaces.patch

But you'd need to discuss this with one of the core devs responsible for that, since they introduced this patch intentionnally, and reverting it will be a kind of regression for all other Ubuntu flavours.

As of karmic, network-manager is on the CD for those who wish to use it. Network-manager is not installed by default, as it was found to cause latency issues with audio recording in the past. Things may be different now, but I wouldn't e surprised if the same issues occur with the latest network manager code in lucid.

Milan Bouchet-Valat (nalimilan) wrote :

Luke: so UbuntuStudio really needs to get the interfaces tab back. It's too bad for other flavours that we have to drop this patch, but I guess you should go on ASAP.

For Maverick, I really think you should test NetworkManager again, and if the problem is still there, work with upstream to fix it.

Changed in gnome-system-tools (Ubuntu):
importance: Undecided → High
milestone: none → lucid-updates
status: New → Triaged
Mike Taylor (mike-miketaylor) wrote :

Is there a workaround in the mean time? I have a newly installed Ubuntu Studio 10.4 box, with a USB wireless dongle which the kernel is correctly recognising, but no way to make it actually connect. This despite installing the vanilla Ubuntu 10.4 NetworkManager from .debs laboriously copied across on a thumb drive -- it can run System->Administration->Network Connections and it can see the USB network card, but there seems to be no way to activate it.

You have to install nm-applet (network-manager-gnome) package, and maybe run it using 'nm-applet'.

Steven Shiau (stevenshiau) wrote :

I has the similar problem here. With gnome-network-admin installed, if I use "System" -> "Administration" -> "Network Tools", and choose network device eth0 or eth1 then choose "Configure", no IP address, network mask or gateway I can configure.
I knew I can manually edit the file /etc/network/interfaces, but for newbie...
It will be great if the configure function for wired and wireless network card can be the same as that in Ubuntu 8.04, 8.10, 9.04, and 9.10. This function has been in gnome-network-admin for many years...
Thanks.

Steven Shiau (stevenshiau) wrote :

BTW, I'd like to emphasize that network-manager is not a good solution for assigning static IP address. Sometimes due to some reason, the network link is down a few secs ONLY, then network-manager will make the service, e,g, dhcpd not working. A dhcpd service restart is required to make work again. This is really annoying especially when the machine is some kind of server. This is why the function to configure network settings in gnome-network-admin is very crucial.
My 2 cents.

Steven Shiau (stevenshiau) wrote :

Forgot to mention, my Lucid is a fresh installation.

dlotton (yellow56) wrote :

I think I reported the same bug (#580744).

In my case with a wired interface I am able to run 'sudo dhclient eth0' to get my network interface up and running with a dynamic ip address.

dlotton (yellow56) wrote :

Also, adding the following to '/etc/network/interfaces' brings the interface up on boot. However, I'm not sure this is the 'right' way to fix the problem since my other Lucid machines do no have this entry.

auto eth0
iface eth0 inet dhcp

On Sun, May 16, 2010 at 08:04:44PM -0000, dlotton wrote:
> Also, adding the following to '/etc/network/interfaces' brings the
> interface up on boot. However, I'm not sure this is the 'right' way to
> fix the problem since my other Lucid machines do no have this entry.
>
> auto eth0
> iface eth0 inet dhcp

I believe that's exactly what gnome-network-admin would do, if it worked.

It is however not needed for systems utilizing NetworkManager. Are these other
Lucid machines of yours such systems?

--
Jaska

dlotton (yellow56) wrote :

Yes, actually, my other machines are are Kubuntu Lucid, the KDE flavor of Ubuntu. However, I did boot a regular Ubuntu Lucid live CD disc on the machine that is now running Lucid Studio and the same was true, no entries other than 'lo' in '/etc/network/interfaces'.

I installed gnome-network-admin, and now I don't have wired internet connection! No eth0 interface is detected at all. I removed it but problem still persist. How can I make network-manager-gnome to auto configure my eth0 interface?

Przemysław: edit /etc/network/interfaces (e.g. with 'sudo pico /etc/network/interfaces'), and remove everything BUT the first lines:
auto lo
iface lo inet loopback

Then you can add the interface using System->Preferences->Network Connections

Tom H. (hoyt-itteki) wrote :

Same software, but my problem is the Connections tab is missing from network-admin, so I have no way to make a dial-up connection. The computer I installed Ubuntu on is in rural areas most of the week and I need dial-up.

Scott Lavender (slavender) wrote :

Debdiff attached that removes the 10_disable_interfaces.patch from gnome-system-tools-2.30.0-0ubuntu2.

tags: added: patch
Scott Lavender (slavender) wrote :

I removed the patch as it only worked on gnome-system-tools-2.30.2 (maverick).

If the patch was applied to gnome-system-tools-2.30.0 (lucid) the application failed to build. See buildlog: http://launchpadlibrarian.net/52373996/buildlog_ubuntu-lucid-i386.gnome-system-tools_2.30.0-0ubuntu3~ppa1_FAILEDTOBUILD.txt.gz

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-tools - 2.30.2-1ubuntu4

---------------
gnome-system-tools (2.30.2-1ubuntu4) maverick; urgency=low

  * Fix LP: #570828 - gnome-network-admin on UbuntuStudio doesnt allow
    to configure either wired networks or wireless. Expose the
    connections tab and locations combo box on derivatives that don't use
    Network Manager
    - update debian/patches/10_disable_interfaces.patch
  * Fix LP: #529744 - When creating a new user, "Shortname" should
    really be "Username"
    - add debian/patches/12_users_string_change.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Mon, 23 Aug 2010 17:04:08 +0100

Changed in gnome-system-tools (Ubuntu):
status: Triaged → Fix Released
csotomayor (guitarlos00) on 2010-09-01
Changed in gnome-system-tools (Ubuntu):
status: Fix Released → Fix Committed

csotomayor: Please don't change the bug status without reason.

Changed in gnome-system-tools (Ubuntu):
status: Fix Committed → Fix Released
sudhir gaikwad (zissshh) wrote :

but i am a beginner in ubuntu studio when i get to this page i dont get what to do where to do?
the status of the bug is solved but how am i going to solve it by downloading what and installing what ?
very confusing
i have a dsl and network connection in ubuntu studio 10.04 doesnt have and add connection tabs
 is this problem really solved
pls excuse me if i have asked a nonsensical question?

dlotton (yellow56) wrote :

sudhir,

See my posts above. In post #14 I give a command you can run on the command line which should get networking up and going. This solution is only temporary. It does not carry over on reboot.

You should now be able to update packages. If the issue is fixed in the update packages, you should be able to go in and configure a network interface.

In post #15 I give a more permanent fix. If the updates don't fix the problem you can use this one.

sudhir gaikwad (zissshh) wrote :

nothing is fixed there is nothing working

sudhir gaikwad (zissshh) wrote :

i have no modem and dsl connection with username and have to create it,,,,any solutions

LoReNicolò (god121-p-l) on 2010-10-22
description: updated
sudhir gaikwad (zissshh) wrote :

i have solved it myself the whole problem seemed to be with the applet which i tried to load from the ubuntustudio 10.04 cd but showed some dependencies wgich i searched in pool and finally got it installed ,,,thats it,,,thank u

B T (sahara090312) wrote :

so does ANYONE have a CLEAR method to enable networking? I'm ready to give up on this -wasted many hours trying to make it work. Read all the so-called "fixes" online and nothing works. Doesn't seem to be worth the effort at this point

Kangarooo Jānis (kangarooo) wrote :

sTILL not fixed. i have installed gnome-system-tools & gnome-network-admin and still not showing up Connections tab.
Its is needed for doing step 3.5.1 & 3.5.2 in https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper#Configuring_Wireless_Network_Settings

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers