Ubuntu

Network Admin Tool Missing Connection Tab

Reported by Carey Sublette on 2010-05-02
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-system-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-network-admin

Installed 10.04 LTS on a wiped-clean Toshiba Satellite Pro.

The network admin tool was not installed neither on the Admin menu, nor could I start it from the command line - the OS offered to install it with apt-get):
cayley@cayley-laptop:~$ network-admin
The program 'network-admin' is currently not installed. You can install it by typing:
sudo apt-get install gnome-network-admin

The Lucid documentation seems to think it should be present (and gnome-system-tools 2.30.0 was installed).

I installed gnome-network-admin from Synaptic Package Manager (also version 2.30.0). The "Network" menu item now appears, but it lacks the Connections tab, which is the most important one. I do not know how to configure wifi connections without it.

I repeated the 10.04 install, but the effects were exactly the same.

Note that bug #566811 filed against package gnome-nettool (and marked incomplete- ready for deletion) sounds identical.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-network-admin 2.30.0-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
Date: Sun May 2 16:07:44 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-system-tools

Carey Sublette (careysub) wrote :
Milan Bouchet-Valat (nalimilan) wrote :

Thanks for your report. This is not a bug but a design decision. NetworkManager is now the default in Lucid, and network-admin doesn't play well with it. NetworkManager provides everything you may find in network-admin, but less buggy, so please use that tool.

The connections tab has been removed to avoid misleading users, since configuring interfaces there would conflict with NetworkManager, and break your network in unexpected ways.

network-admin is indeed part of the gnome-network-admin binary package, not gnome-system-tools.

Changed in gnome-system-tools (Ubuntu):
status: New → Invalid
Tomáš Cícha (tomas-cicha) wrote :

I can't help myself, but I have to comment here.

If this is a design decision, it is really a very poor one. Ubuntu documentation suggests using network-admin for modem connection to the Internet, because NetworkManager doesn't support it.

So now:

a) Documentation is misleading users.
b) There's no sensible way to connect using a modem.

Quite nice desgin you have here :)

Milan Bouchet-Valat (nalimilan) wrote :

Ah, indeed. Documentation shouldn't mention it as the solution to set up modems. Note you can use System->Preferences->Network Connections for that. I've filed bug 575694.

Linuxonlinehelp_de (linuxhelp) wrote :

Not possible to change/set Manual IP !!

zeonite (mligeza) wrote :

This is one of the strangest decisions made by the powers that be.

Now that they have removed the necessary tools, how does one go about setting a fixed IP address??

Milan Bouchet-Valat (nalimilan) wrote :

If you're not using Ubuntu Studio, you have NetworkManager, else you can install it, or wait for the tab to come back (hopefully). The decision was made by developers that didn't know Studio wasn't installing NetworkManager, and nobody complained until the release was very close. Anyway, see the duplicate.

Kangarooo Jānis (kangarooo) wrote :

sTILL not fixed. i have installed gnome-system-tools & gnome-network-admin and still not showing up Connections tab.
Its is needed for doing step 3.5.1 & 3.5.2 in https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper#Configuring_Wireless_Network_Settings

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers