users-admin pretends logged in users can be removed, while they aren't

Bug #349453 reported by Ara Pulido on 2009-03-27
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GST
Fix Released
Undecided
Unassigned
gnome-system-tools (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-system-tools

Steps to reproduce:

1) In a system with only one user ( 'user1' with admin privileges), go to users-admin
2) Create a new user 'user2' with admin privileges
3) Delete 'user1'. You get a warning stating "This user is currently using this computer", but nothing saying that you cannot delete the account
3) The account seems deleted from the list.
4) Log out and log in again with 'user1'. BUG: You can log in again with user1 (the deleted user)

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: gnome-system-tools 2.22.2-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_NZ.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-system-tools
Uname: Linux 2.6.28-11-generic i686

Ara Pulido (ara) wrote :
Caleb (caleb-marcus) wrote :

I've confirmed this in Karmic, and would like to add that it also appears to let you delete other logged-in users, and warns you that they're logged in, but the deletion doesn't go through.

Changed in gnome-system-tools (Ubuntu):
status: New → Confirmed
summary: - users-admin does not delete the current user
+ users-admin pretends logged in users can be removed, while they aren't
Martin Gamache (martin-gamache) wrote :

Same thing in Karmic, I'm trying to delete a test user I created, it seems to work, but if I restart, the test user still appears in the login screen.

Logging in with it doesn't really work, though, I get several errors before ending up on a blank screen...

Milan Bouchet-Valat (nalimilan) wrote :

Yeah, should not be too hard to fix (i.e. refuse to remove logged in users), for the next Ubuntu version I guess.

Note that if you can't remove a user that is not currently logged in *and* you're using a completely up-to-date (as of today) Karmic system, then it's another bug that I'd really like you to report separately. And BTW, the errors with blank screen may not be related at all, there's a bug with newly created users and compiz.

hamacker (sirhamacker) wrote :

users-admin dont remove any user in any cirscunstance.

When remove user from list, everything appears OK, but you close users-admin e re-open again and...surprise : deleted user come back. This problem force to go terminal and execute 'deluser'.

Milan Bouchet-Valat (nalimilan) wrote :

hamacker: See bug 458883, which is now fixed in Karmic. But please don't comment on bugs that are not directly related to your problem, this generates unnecessary noise. Better is to make a research, and then to file a new bug.

Changed in gnome-system-tools (Ubuntu):
importance: Undecided → Medium
Milan Bouchet-Valat (nalimilan) wrote :

This is now fixed upstream. Since deluser does not remove active users, we simply refuse to delete them, showing a dialog: "John Doe is currently using this computer. Please ensure the user has logged out before deleting this account."

Feel free to suggest a better formulation if you find one... ;-)

Changed in gst:
status: New → Fix Committed
Changed in gnome-system-tools (Ubuntu):
status: Confirmed → Triaged
Milan Bouchet-Valat (nalimilan) wrote :

Fixed in 2.29.2.

Changed in gst:
status: Fix Committed → Fix Released
Changed in gnome-system-tools (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-tools - 2.29.3-0ubuntu1

---------------
gnome-system-tools (2.29.3-0ubuntu1) lucid; urgency=low

  * New upstream release (LP: #506365)
    - Move to new System Tools Backends protocol (new liboobs API).
      We now only commit changes to one user at a time, reducing the
      risk for dangerous bugs.
    - Include default profiles configuration file (user-profiles.conf).
      Distributors should modify it to suit their needs and send them
      back for inclusion.
    - When creating an user, don't force UID, main group, home directory
      and shell: these parameters are now handled (better) by the platform
      tools (LP: #488158, LP: #313990)
    - Allow removing home directory when deleting an user (LP: #426125).
    - Don't allow deleting the last administrator account, and warn when
      the user is losing its own admin rights. Same for active users
      (LP: #25947, LP: #349453)
    - Don't allow creating a group with an existing GID (LP: #491434)
    - Use UID and GID ranges defined by liboobs, depending on the platform's
      abilities.
    - Clear suggested login entry when Real name is emptied in the new user
      dialog.
    - Change GConf "showall" option to apply only on users. System groups are
      always shown, since they are the most interesting ones.
    - Various UI and string improvements.
    - Change password for current user by running 'passwd', to avoid
      breaking keyrings and encrypted dirs
    - Ask for PolicyKit authentication when it most makes sense, i.e.
      when showing dialogs
    - Option to set encrypted home directories when creating users (on
      platforms that support it) (LP: #302870)
    - When editing one group, only commit changes to that group
    - When changing Real name, update it in the users list (LP: #498970)
    - Select current user on start, and the first one after selected user
      has been deleted
    - Don't force updating configuration twice on start
  * Also fixes LP: #344182, LP: #208057, LP: #188757, LP: #372695,
    LP: #99276, LP: #160862
  * debian/control:
    - Bump liboobs-dev build-dep to 2.29.3
  * debian/gnome-system-tools.install:
    - Don't install debian/profile
    - Install upstream user-profiles.conf instead
  * Delete debian/profiles
  * Refreshed patches:
    - 25_sambashare_group_definition.patch
    - 90_relibtoolize.patch
  * Dropped debian/patches/85_user_gnome_about_me_for_password.patch:
    - The change is obsolete in the new version
  * debian/patches/82_gst-packages-time-admin.patch:
    - Updated to remove superfluous UI file changes, causing focus issues
      in the users-admin password change dialog. Thanks to Will for
      spotting this (LP: #501976)
 -- Chris Coulson <email address hidden> Fri, 05 Feb 2010 15:30:10 +0000

Changed in gnome-system-tools (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers