Ubuntu

Shared Folders Administration Tool does not show Nautilus Shares

Reported by Onno Benschop on 2008-11-13
4
Affects Status Importance Assigned to Milestone
gnome-system-tools (Baltix)
Undecided
Unassigned
gnome-system-tools (Ubuntu)
Undecided
Unassigned
nautilus-share (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-system-tools

When a folder is shared by right-clicking on the folder in Nautilus and sharing it, the folder is shared, but it does not show up in shares-admin.

File sharing is hard enough for novice users without adding an extra layer of confusion. The list of shared folders should be representative of the actual folders that are visible to the outside world.

The /etc/samba/smb.conf file does *not* show the Nautilus shares either!

Steps to reproduce:
1. Up to date Intrepid.
2. Share a folder in Nautilus.
3. Launch shares-admin.
4. Notice that there are no shares.
5. Browse the network.
6. Goto WORKGROUP -> Machine and see the Nautilus shared folder.

Onno Benschop (onno-itmaze) wrote :

After removing the tick box from the Nautilus sharing option and sharing the folder through the shares-admin tool, the folder is once again shared.

Nautilus does not show that the folder is shared.

Sharing the folder in Nautilus, while it is shared using shares-admin, results in a shared folder.

Stopping the folder from being shared in Nautilus, while the folder is still shared in shares-admin results in the folder vanishing from the network. /etc/samba/smb.conf and shares-admin both show the folder as shared, but it's not visible. Reloading samba does not fix this problem.

Resharing the folder in shares-admin results in the folder being available.

The workgroup remains the same (WORKGROUP), even if it's changed in shares-admin.

Onno Benschop (onno-itmaze) wrote :

No wonder the results are so confusing, there are many smbd processes running:

onno@tinkerbell:~$ ps -ealf | grep smb
5 S root 6227 1 0 80 0 - 3411 select 07:38 ? 00:00:00 /usr/sbin/smbd -D
1 S root 6237 6227 0 80 0 - 3411 pause 07:38 ? 00:00:00 /usr/sbin/smbd -D
0 S onno 14682 1 0 80 0 - 5706 poll 08:15 ? 00:00:00 /usr/lib/gvfs/gvfsd-smb-browse --spawner :1.5 /org/gtk/gvfs/exec_spaw/3
5 S root 14684 6227 0 80 0 - 3415 select 08:15 ? 00:00:00 /usr/sbin/smbd -D
5 S root 14695 6227 0 80 0 - 3415 select 08:15 ? 00:00:00 /usr/sbin/smbd -D
5 S root 14698 6227 0 80 0 - 3444 select 08:15 ? 00:00:00 /usr/sbin/smbd -D
0 S onno 15399 1 0 80 0 - 5551 poll 08:29 ? 00:00:00 /usr/lib/gvfs/gvfsd-smb --spawner :1.5 /org/gtk/gvfs/exec_spaw/6
5 S root 15401 6227 0 80 0 - 3421 select 08:29 ? 00:00:00 /usr/sbin/smbd -D
0 S onno 15967 14148 0 80 0 - 811 pipe_w 08:37 pts/0 00:00:00 grep smb

The process to reproduce the above:
1. Up to date Intrepid
2. Share a folder in Nautilus
3. Install samba
4. Restart Session
5. Re-share the folder in Nautilus
6. Un-share the folder in Nautilus
7. Share the folder in shares-admin
8. Share the folder in Nautilus
9. Un-share the folder in Nautilus
10. /etc/initi.d/samba reload
11. ps -ealf

Chow Loong Jin (hyperair) wrote :

Marking as invalid, because nautilus-share does not have anything to do with the Shared Folders administration tool. For this to work, the shares-admin tool will have to be patched to show all usershares.

Changed in nautilus-share:
status: New → Invalid
nico9julio (nico9julio) wrote :

Chow Loong Jin, don't you think that nautilus-share would have to do everything with shares-admin? Why are you avoiding that someone submit a patch for showing shared folder from nautilus in shares-admin?

nico9julio (nico9julio) wrote :

please review this desition

Changed in nautilus-share (Ubuntu):
status: Invalid → Opinion
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers