/etc/gnome-system-tools/users/profiles contains untranslated strings

Bug #208057 reported by Gabor Kelemen on 2008-03-28
4
Affects Status Importance Assigned to Milestone
GST
Fix Released
Undecided
Unassigned
gnome-system-tools (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: gnome-system-tools

In the file describing distribution-specific default profiles, the profile names are not marked for translation. The name= lines in the debian/profiles file need to be marked for translation and added to POTFILES.in.

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 9.04?

Changed in gnome-system-tools:
importance: Undecided → Wishlist
status: New → Incomplete
Gabor Kelemen (kelemeng) wrote :

Probably yes, last I checked it on Intrepid and it was still there.

Gabor Kelemen (kelemeng) wrote :

Ok, after some investigation:
-localizing these is not possible with the X-Gettext-Domain-Ubuntu= trick. That does not care about anything not under [Desktop Entry] and not having one of the Name, Comment, GenericName keys.
-the above means we would have to merge translations back with intltool-merge.
-the above means packagers have to export the translations before packaging :)

Besides those, it's reletively easy, rename profiles to profiles.in, mark the name key for translation, add
[type: gettext/ini]debian/profiles
to POTFILES.in, export translations and run
LC_ALL=C /usr/bin/intltool-merge -d -u -c ./po/.intltool-merge-cache ./po debian/profiles.in debian/profiles
 while packaging. Brr.

Or, we could change the code and make it a bit more dinamical, not expecting translated names in the profiles file, but translating them on the fly. This would make the translation export unnecessary and the intltool-merge symbolic.

Gabor Kelemen (kelemeng) wrote :

Also, during the build, it's necessary to run
LC_ALL=C /usr/bin/intltool-merge -d po debian/profiles.in debian/profiles
so that it removes the _ mark from the name key and creates the profiles file to install.

István Nyitrai (sianis) on 2009-03-02
Changed in gnome-system-tools:
status: Incomplete → Triaged
Milan Bouchet-Valat (nalimilan) wrote :

Hey, thanks for the patch, but we needed a little more than that to make the file translated: Makefile.am had to be changed too, that was a little tricky. See http://git.gnome.org/browse/gnome-system-tools/commit/?id=4b3806048a0e0913b78615c85db6c43853151d1f.

Feel free to suggest other patches in the future, I'd be glad to review them!

Changed in gst:
status: New → Fix Released
Changed in gnome-system-tools (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-tools - 2.29.3-0ubuntu1

---------------
gnome-system-tools (2.29.3-0ubuntu1) lucid; urgency=low

  * New upstream release (LP: #506365)
    - Move to new System Tools Backends protocol (new liboobs API).
      We now only commit changes to one user at a time, reducing the
      risk for dangerous bugs.
    - Include default profiles configuration file (user-profiles.conf).
      Distributors should modify it to suit their needs and send them
      back for inclusion.
    - When creating an user, don't force UID, main group, home directory
      and shell: these parameters are now handled (better) by the platform
      tools (LP: #488158, LP: #313990)
    - Allow removing home directory when deleting an user (LP: #426125).
    - Don't allow deleting the last administrator account, and warn when
      the user is losing its own admin rights. Same for active users
      (LP: #25947, LP: #349453)
    - Don't allow creating a group with an existing GID (LP: #491434)
    - Use UID and GID ranges defined by liboobs, depending on the platform's
      abilities.
    - Clear suggested login entry when Real name is emptied in the new user
      dialog.
    - Change GConf "showall" option to apply only on users. System groups are
      always shown, since they are the most interesting ones.
    - Various UI and string improvements.
    - Change password for current user by running 'passwd', to avoid
      breaking keyrings and encrypted dirs
    - Ask for PolicyKit authentication when it most makes sense, i.e.
      when showing dialogs
    - Option to set encrypted home directories when creating users (on
      platforms that support it) (LP: #302870)
    - When editing one group, only commit changes to that group
    - When changing Real name, update it in the users list (LP: #498970)
    - Select current user on start, and the first one after selected user
      has been deleted
    - Don't force updating configuration twice on start
  * Also fixes LP: #344182, LP: #208057, LP: #188757, LP: #372695,
    LP: #99276, LP: #160862
  * debian/control:
    - Bump liboobs-dev build-dep to 2.29.3
  * debian/gnome-system-tools.install:
    - Don't install debian/profile
    - Install upstream user-profiles.conf instead
  * Delete debian/profiles
  * Refreshed patches:
    - 25_sambashare_group_definition.patch
    - 90_relibtoolize.patch
  * Dropped debian/patches/85_user_gnome_about_me_for_password.patch:
    - The change is obsolete in the new version
  * debian/patches/82_gst-packages-time-admin.patch:
    - Updated to remove superfluous UI file changes, causing focus issues
      in the users-admin password change dialog. Thanks to Will for
      spotting this (LP: #501976)
 -- Chris Coulson <email address hidden> Fri, 05 Feb 2010 15:30:10 +0000

Changed in gnome-system-tools (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers