Gconf tweak to show all users / groups on system in Users and Groups tool has no effect

Bug #124993 reported by Mike MacCana on 2007-07-10
54
Affects Status Importance Assigned to Milestone
GST
Fix Released
Medium
gnome-system-tools (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-system-tools

Even using the hidden gconf tweak to show all the users on the system (really, this should be part of the tool - with the appropriate warning that these are system accounts and should not be modified unless necessary - see system-config-users as an example), some users and groups are not shown in this tool - eg, the disk group.

The gconf tweak in fails to do what it is documented to do in its description.

Can be reproduced by;
Opening gconf-editor, visiting
/apps/gnome-system-tools/users and enabling showall.

Clicking System -> Administration -> Users and Groups. Looking for an a group called disk.

Compare with results of 'getent group disk' on command line.

Áron Sisak (asisak) on 2007-07-24
Changed in gnome-system-tools:
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug. What version of Ubuntu do you use?

Changed in gnome-system-tools:
assignee: nobody → desktop-bugs
status: Confirmed → Incomplete
Áron Sisak (asisak) wrote :

I can confirm this behavior is still present in up-to-date gutsy x86. I don't know what version the original reporter used.

Sebastien Bacher (seb128) wrote :
Changed in gnome-system-tools:
status: Incomplete → Triaged
Changed in gst:
status: Unknown → New
Sebastien Bacher (seb128) wrote :

The bug has been fixed upstream now

Changed in gnome-system-tools:
status: Triaged → Fix Committed
Changed in gst:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

gnome-system-tools (2.20.0-0ubuntu1) gutsy; urgency=low

  * New upstream version
    Users
    - Actually obbey the "show_all" gconf key (LP: #124993)
    Translations

 -- Sebastien Bacher <email address hidden> Mon, 17 Sep 2007 15:18:26 +0200

Changed in gnome-system-tools:
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

There is a new duplicate, reopening the bug

Changed in gnome-system-tools:
status: Fix Released → Triaged
Changed in gst:
status: Fix Released → New
Changed in gst:
status: New → Fix Released
Loïc Minier (lool) wrote :

Brian, did you use "/apps/gnome-system-tools/users/show_all" or "/showall"? Could you please try with "showall" at this is the correct key name?

@Sébastien: Perhaps change the "show_all" in the debian/changelog into "showall" with the next upload so that people don't think it's "show_all"?

Loïc Minier (lool) wrote :

Brian, it turns out it should work if you set the GConf key as root. That's not the intended behavior, only a workaround.

The long term fix would probably be to use PolicyKit or a similar solution, but it's not something we can do for gutsy.

I'm leaving this bug open to let us remember that we need to switch to PolicyKit because of such bugs and to document the workaround.

Loïc Minier (lool) wrote :

Another option in case PolicyKit isn't ready for hardy would be to "sg stb" (or whatever group is allowed to make changes, perhaps even the "root" group) or "gksg stb", but gksu doesn't support this. This would basically gain the user additional group credentials as protected by whatever tool is picked to switch group, and these credentials would be lost when the command ends; the GConf settings would still be opened as $user.

Brian Murray (brian-murray) wrote :

In Gutsy it was necessary to set the gconf key for root using 'sudo gconf-editor'. However, in Hardy PolicyKit looks at the user's gconf key so the key, "/apps/gnome-system-tools/users/showall", needs to be set for the user using users-admin.

I have verified this works using 2.21.92-0ubuntu1 on Hardy Heron. Can anyone else verify this works? Thanks in advance.

Yep, just installed Hardy, trick works, setting the user gconf key is enough, no need to mess with root.

Changed in gnome-system-tools:
status: Triaged → Fix Released
Changed in gst:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.