Message "Cannot change the priority of process" is displayed when a normal user selects a high priority process

Bug #910845 reported by shubham
66
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Gnome System Monitor
Fix Released
Medium
gnome-system-monitor (Ubuntu)
Medium
Robert Roth

Bug Description

TEST CASE
1. Launch gnome-system-monitor as a normal user
2. Scroll down the list and select the process 'pulseaudio'
OR
   Select the first process and scroll down to the bottom of the list

EXPECTED RESULT
Nothing special happens

ACTUAL RESULT
A popup appears with the following message:
"Cannot change the priority of process with PID 2640 to -20.
Permission denied"

=== Original Description ===
open system monitor switch to tab processe
select any process
press down and up key continusaly
a popup will appear
this is a 32-bit problem
see the images:
http://ubuntuforums.org/attachment.php?attachmentid=210046&d=1325422483
http://ubuntuforums.org/attachment.php?attachmentid=210106&stc=1&thumb=1&d=1325500407
http://ubuntuforums.org/attachment.php?attachmentid=210115&d=1325512351
may 32-bit users are facing problem
see the threads:
http://ubuntuforums.org/showthread.php?p=11581200#post11581200
http://ubuntuforums.org/showthread.php?t=1902931
this bug is for 32-bit ubuntu users dont know about other vairants many are facing(32-bit users)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-system-monitor 3.3.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
Uname: Linux 3.2.0-7-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Mon Jan 2 19:19:20 2012
ExecutablePath: /usr/bin/gnome-system-monitor
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcEnviron:
 LANGUAGE=en_IN:en
 PATH=(custom, no user)
 LANG=en_IN
 SHELL=/bin/bash
SourcePackage: gnome-system-monitor
UpgradeStatus: Upgraded to precise on 2011-12-25 (7 days ago)

Revision history for this message
shubham (shubhammaheshwariy) wrote :
description: updated
Chris (fabricator4)
Changed in gnome-system-monitor (Ubuntu):
status: New → Confirmed
Revision history for this message
Chris (fabricator4) wrote :

This confirmed for 32 bit 12.04 alpha 1. It happens 100% of the time.

To recreate the error:
Open System monitor
Click to select a process (any process)
Use up or down arrow keys to move the selection bar to pulse-audio
As soon as the selection bar hits pulse-audio the error message pops up.

*New Info********************
I can also re-create this problem by selecting pulse-audio with the mouse

Observations:

*Pulse-audio has a very high priority set. All other processes are "normal"

*This is mostly being reported by 32 bit users, however some 64 bit users are reporting it happening sometimes
---> Could this be because they are just not hitting "pulse-audio" during testing?

Chris

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

This dialog pops up when the user scrolls over a process with a priority set higher than 'Normal' and doesn't have privileges to set it.
This is a usability issue which doesn't impact functionality.

Changed in gnome-system-monitor (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
description: updated
Revision history for this message
sojourner (itsmealso2) wrote :

this bug affects my 64 bit sys every time I select pulse-audio in gnome-system-monitor either by scrolling or direct mouse click , scrolling with the arrow keys it does not occur until I reach pulse-audio but does randomly occur on other files after that .

summary: - system monitor throws error 32-bit
+ Message "Cannot change the priority of process" is displayed with a
+ normal user selects a high priority process
Revision history for this message
Stephen Cradock (s-cradock) wrote : Re: Message "Cannot change the priority of process" is displayed with a normal user selects a high priority process

Confirming this occurs reliably on 64-bit systems too. It is NOT 32-bit specific.

In addition, if you dismiss the warning message the priority of "pulse-audio' CAN BE CHANGED by a user with normal privileges, to NOrmal. After that, the priority cannot be changed back to "Very High" by such a user.

That sounds like a functionality error, not just a usability problem.

Revision history for this message
Chris (fabricator4) wrote :

There may still be a difference on 32 bit systems: I can NOT change the priority on a process at all - the normal user does not have access to do so.

To test this further I changed the view to "all processes" and found that the error occurs for any process with the priority set to "very high"

I then ran top as superuser and changed the niceness of pulse-audio to 0 (normal). The problem did not occur when selecting the pulse-audio process in 'system monitor'. I then changed the niceness back to -20 in top and found I could _still_not_get_the_error_ to occur.

I then rebooted and proved the error could still be created.
I then logged out and logged back in selecting Unity2d - the niceness is set to 0 (default) and the problem can not be recreated
I then logged out and back in with Unity3d and though the niceness is now -20 the problem can still not be created.

There seems to be a problem with the way the niceness is being set on boot.

Chris

Revision history for this message
shubham (shubhammaheshwariy) wrote :

yes this problem occrus after pulse audio

Revision history for this message
Chris (fabricator4) wrote :

@Jean-Baptiste
"This is a usability issue which doesn't impact functionality".

If it were as simple as that then changing the priority should not in itself alter the ability to recreate the bug. The fact that after changing the priority to normal and then back to very high makes the problem disappear completely seems to indicate that there is something much deeper going on.

Chris

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

Chris, the original bug report is about a popup displayed when a user scrolls over a process which he is not allowed to change priority.

You're describing 2 other defects:
1. a problem with the way the niceness is being set on boot
2. The fact that a normal user cannot increase priority (lower nice value) of their own process. This is expected and documented in the man pages of setpriority and renice (even if it is in the BUG section of renice) But in that case gnome-system-monitor is supposed to open a dialog and prompt for root access.

Could you please file a new report for both issues ?
It would be nice if someone could report this bug and point 2 to the upstream bug tracker (bugzilla.gnome.org)

Thanks for your help.

summary: - Message "Cannot change the priority of process" is displayed with a
+ Message "Cannot change the priority of process" is displayed when a
normal user selects a high priority process
Revision history for this message
Robert Roth (evfool) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: https://bugzilla.gnome.org/show_bug.cgi?id=667227.
I have created a patch for this bug and attached it upstream, hopefully it will get into the next upstream release.

Changed in gnome-system-monitor:
importance: Unknown → Medium
status: Unknown → New
Robert Roth (evfool)
Changed in gnome-system-monitor (Ubuntu):
assignee: nobody → Robert Roth (evfool)
status: Triaged → In Progress
Changed in gnome-system-monitor:
status: New → In Progress
Changed in gnome-system-monitor:
status: In Progress → Fix Released
Changed in gnome-system-monitor (Ubuntu):
importance: Low → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-monitor - 3.3.4-0ubuntu1

---------------
gnome-system-monitor (3.3.4-0ubuntu1) precise; urgency=low

  * New upstream unstable release.
    - New process properties dialog (LP: #249237)
    - Case insensitive quick search (LP: #915973)
    - Fixed cannot change priority dialogs for root processes (LP: #910845)
    - Sorting numeric columns fixed (LP: #206239)
    - Fixed crashes caused when application icon is not found (LP: #700900)
    - CPU chart colors saved for all CPUs (LP: #705505, LP: #874997)
  * debian/patches/02_lpi.patch: Refreshed.
  * debian/control.in: Require librsvg2-dev >= 2.35.0 to match configure.in.
 -- Robert Roth <email address hidden> Wed, 19 Jan 2012 19:10:15 +0200

Changed in gnome-system-monitor (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Nikos Kalantas (mitsest) wrote :

I got 3.6.0 on linux mint and the problem still occurs when I try to change vlc's priority.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.