same color for cpu 5 cpu 6 cpu 7 cpu 8

Bug #705505 reported by L_d_v_c@
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Gnome System Monitor
Fix Released
Medium
gnome-system-monitor (Ubuntu)
Low
Robert Roth

Bug Description

Binary package hint: gnome-system-monitor

These cpu 5 to 8 are red color...
Thanks

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-system-monitor 2.28.1-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-23.41-generic 2.6.35.7
Uname: Linux 2.6.35-23-generic x86_64
Architecture: amd64
Date: Thu Jan 20 17:05:27 2011
ExecutablePath: /usr/bin/gnome-system-monitor
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
SourcePackage: gnome-system-monitor
XsessionErrors:
 (polkit-gnome-authentication-agent-1:2198): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2192): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed

Revision history for this message
L_d_v_c@ (l-d-v-c) wrote :
Changed in gnome-system-monitor:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-system-monitor (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Revision history for this message
Robert Roth (evfool) wrote :

Thank you for reporting this bug. How many processors do you see listed on the system monitor's system tab?
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Revision history for this message
L_d_v_c@ (l-d-v-c) wrote :

The computer is a bi-Quad with TYAN S2915A2NRF-E

Processeur 0: Quad-Core AMD Opteron(tm) Processor 2356
Processeur 1: Quad-Core AMD Opteron(tm) Processor 2356
Processeur 2: Quad-Core AMD Opteron(tm) Processor 2356
Processeur 3: Quad-Core AMD Opteron(tm) Processor 2356
Processeur 4: Quad-Core AMD Opteron(tm) Processor 2356
Processeur 5: Quad-Core AMD Opteron(tm) Processor 2356
Processeur 6: Quad-Core AMD Opteron(tm) Processor 2356
Processeur 7: Quad-Core AMD Opteron(tm) Processor 2356

Thanks.

Revision history for this message
Joseph Walton (h-launchpad-kafsemo-org) wrote :

The settings keys for the colors use:

    g_strdup_printf ("cpu-color%d", i%4);

so CPUs 4-7 share their colors with 0-3. Looks like this is due to this patch:

    http://git.gnome.org/browse/gnome-system-monitor/commit/?id=bb8c0a89cae435ad12734c2d8fca3a16f94a26bf

as a workaround for:

    https://bugzilla.gnome.org/show_bug.cgi?id=645662)

Revision history for this message
L_d_v_c@ (l-d-v-c) wrote :

So it's perfect.
I also discovered that we can change the colors manually.

Changed in gnome-system-monitor:
status: New → Fix Released
Robert Roth (evfool)
Changed in gnome-system-monitor (Ubuntu):
assignee: nobody → Robert Roth (evfool)
status: Triaged → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-monitor - 3.3.4-0ubuntu1

---------------
gnome-system-monitor (3.3.4-0ubuntu1) precise; urgency=low

  * New upstream unstable release.
    - New process properties dialog (LP: #249237)
    - Case insensitive quick search (LP: #915973)
    - Fixed cannot change priority dialogs for root processes (LP: #910845)
    - Sorting numeric columns fixed (LP: #206239)
    - Fixed crashes caused when application icon is not found (LP: #700900)
    - CPU chart colors saved for all CPUs (LP: #705505, LP: #874997)
  * debian/patches/02_lpi.patch: Refreshed.
  * debian/control.in: Require librsvg2-dev >= 2.35.0 to match configure.in.
 -- Robert Roth <email address hidden> Wed, 19 Jan 2012 19:10:15 +0200

Changed in gnome-system-monitor (Ubuntu):
status: In Progress → Fix Released
Changed in gnome-system-monitor:
status: Fix Released → Confirmed
Changed in gnome-system-monitor:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.