gnome-software spams error messages to journald and causes 100% CPU usage

Bug #1723362 reported by Martin Weißhaupt on 2017-10-13
242
This bug affects 49 people
Affects Status Importance Assigned to Milestone
GNOME Software
Unknown
High
gnome-software (Ubuntu)
High
Unassigned
Xenial
Undecided
Unassigned
Artful
Undecided
Unassigned
Bionic
High
Unassigned
snapd-glib (Ubuntu)
High
Robert Ancell
Xenial
Undecided
Unassigned
Artful
Undecided
Unassigned
Bionic
High
Robert Ancell

Bug Description

gnome-software spams this message to journald:

Okt 13 11:00:19 zenbook gnome-software[3582]: g_byte_array_remove_range: assertion 'index_ + length <= array->len' failed
Okt 13 11:00:19 zenbook gnome-software[3582]: Ignoring unexpected response

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gnome-software 3.26.1-0ubuntu1
ProcVersionSignature: Ubuntu 4.13.0-15.16-generic 4.13.4
Uname: Linux 4.13.0-15-generic x86_64
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
CurrentDesktop: GNOME
Date: Fri Oct 13 10:58:38 2017
InstallationDate: Installed on 2016-10-25 (352 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
InstalledPlugins:
 gnome-software-plugin-flatpak N/A
 gnome-software-plugin-limba N/A
 gnome-software-plugin-snap 3.26.1-0ubuntu1
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-software
UpgradeStatus: Upgraded to artful on 2017-10-04 (8 days ago)

Martin Weißhaupt (mweisshaupt) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
Max D (maxdesp) wrote :

Same error shortly after boot and upgrade (could be coincidental):

Oct 15 15:38:08 XXX dbus-daemon[2685]: Activating service name='com.intel.dleyna-renderer'
Oct 15 15:38:08 XXX dleyna-renderer-service[5506]: dLeyna core version 0.4.0
Oct 15 15:38:08 XXX dleyna-renderer-service[5506]: dleyna-renderer-service version 0.4.0
Oct 15 15:38:09 XXX gnome-software[4142]: g_byte_array_remove_range: assertion 'index_ + length <= array->len' failed
Oct 15 15:38:09 XXX gnome-software[4142]: Ignoring unexpected response

then the last two lines again and again :

Oct 15 15:38:10 XXX gnome-software[4142]: Ignoring unexpected response
Oct 15 15:38:10 XXX gnome-software[4142]: g_byte_array_remove_range: assertion 'index_ + length <= array->len' failed

It filled my /var partition with a 5g syslog file in less than an hour. Computer almost completely freeze (gradually, up to nothing responding at all). I managed to figure out that syslog was the issue, save it and delete it from /var just in time. "apt upgrade" was stuck for 10/15 minutes at " Generating /boot/initrd.img" step.

This bug might have had serious consequences.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gnome-software (Ubuntu):
importance: Undecided → High
Janne Moren (jan-moren-gmail) wrote :

Any workaround to stop this for now? I deleted syslog so it won't fill my disk, but systemd-journal and syslogd eats all my cpu.

Javier Hernández (kodrete) wrote :

Me too. GIMP is not working anymore, is this issue related?

Facundo (facundov60i) wrote :
Sebastien Bacher (seb128) wrote :

Thanks for sending it to GNOME

Changed in gnome-software (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-software:
importance: Unknown → High
status: Unknown → Confirmed
The Bright Side (me-knowingme) wrote :

Same issue here! Note that it also causes the syslog file to grow indefinitely and thus fills up your root.

The Bright Side (me-knowingme) wrote :

Oops, sorry for the unnecessary comment, I should have read this bug closer before repeating the info about syslog.

Robert Ancell (robert-ancell) wrote :

This is occurring in snapd-glib and is likely to be fixed in version 1.24 which is the current candidate for a SRU.

If you have this issue, could you please try the SRU candidate?
$ sudo apt-add-repository ppa:ubuntu-desktop/gnome-software
$ sudo apt update
$ sudo apt upgrade

Facundo (facundov60i) wrote :

I tried the SRU candidate and it worked for me. Thanks!

Changed in gnome-software:
status: Confirmed → Unknown
Changed in gnome-software (Ubuntu):
status: Triaged → Invalid
Changed in snapd-glib (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
importance: Undecided → High
status: New → In Progress
Derek L (ddl-lp) wrote :

Is an SRU fixing this likely to get pushed to artful? It bites me several times a week (it's filling my syslog with errors as I write this).

bj mccormick (bjmccormick) wrote :

I tried the PPA in comment #11, but just got a recurrence of this bug. Took about 12 hours before it manifested.

bj mccormick (bjmccormick) wrote :

Actually, disregard that last comment. I never rebooted after updating snap using the ppa. I didn't think it was needed, but after a reboot this morning and running the updated software fresh I have not had a recurrence of the bug.

Marcus Schopen (marcus-5) wrote :

Same here, #11 fixed it.

Russell Phillips (ignissport) wrote :

I'll try #11, but at the time of writing, syslog file is 4GB (with 90 minutes uptime), and the gnome-software process has already been killed after my machine was completely unresponsive for several minutes (SSD activity light on solid).

From dmesg:

[ 2416.663271] Out of memory: Kill process 3116 (gnome-software) score 806 or sacrifice child
[ 2416.663279] Killed process 3116 (gnome-software) total-vm:10527540kB, anon-rss:6346396kB, file-rss:0kB, shmem-rss:0kB
[ 2416.972964] oom_reaper: reaped process 3116 (gnome-software), now anon-rss:16kB, file-rss:0kB, shmem-rss:0kB

Changed in snapd-glib (Ubuntu Bionic):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu Artful):
status: New → Confirmed
Changed in gnome-software (Ubuntu Xenial):
status: New → Confirmed
Changed in snapd-glib (Ubuntu Artful):
status: New → Confirmed
Changed in snapd-glib (Ubuntu Xenial):
status: New → Confirmed
Jason (jprokopowich) wrote :

This also affects me,

May 5 17:45:33 hulk gnome-software[8798]: g_byte_array_remove_range: assertion 'index_ + length <= array->len' failed
May 5 17:45:33 hulk gnome-software[8798]: Ignoring unexpected response
May 5 17:45:33 hulk gnome-software[8798]: g_byte_array_remove_range: assertion 'index_ + length <= array->len' failed
May 5 17:45:33 hulk gnome-software[8798]: Ignoring unexpected response
May 5 17:45:33 hulk gnome-software[8798]: g_byte_array_remove_range: assertion 'index_ + length <= array->len' failed
May 5 17:45:33 hulk gnome-software[8798]: Ignoring unexpected response

Continues to fill up /var/log file system.

Sébastien (sebastien-arod) wrote :

Is there any workaround for this issue?

Aidan Skinner (aidan-skinner) wrote :

i just went for dpkg -r gnome-software gnome-software-plugin-snap ubuntu-software as a workaround :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.