ubuntu 17.04 gnome-software install button not working

Bug #1640741 reported by corrado venturini on 2016-11-10
62
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned
gnome-software (Ubuntu)
Critical
Unassigned

Bug Description

on ubuntu 17.04 gnome-software install button does nothing.
try with different applications: UFRaw, Shutter, Entangle ...

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: gnome-software 3.22.2+git20161108.0.a58dfc7-0ubuntu1
ProcVersionSignature: Ubuntu 4.8.0-26.28-generic 4.8.0
Uname: Linux 4.8.0-26-generic x86_64
ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Nov 10 11:08:48 2016
ExecutablePath: /usr/bin/gnome-software
InstallationDate: Installed on 2016-11-06 (3 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20161106)
SourcePackage: gnome-software
UpgradeStatus: No upgrade log present (probably fresh install)

Ubuntu sotware fails with the above problem on my installation "corrado-HP-zesty" - zesty proposed enabled
but seems working on a different installation "corrado-HP-zesty2" - zesty proposed NOT enabled running on the same hardware, different partition.
Output from inxi attached.

Jeremy Bicha (jbicha) on 2016-11-18
Changed in gnome-software (Ubuntu):
importance: Undecided → Critical
status: New → Confirmed
tags: added: block-proposed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1640741

tags: added: iso-testing

Is this definitely a downstream issue or would it be worth reporting upstream as well?

Changed in ubuntu-gnome:
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

I would not report it upstream because when gnome-software is built with the PackageKit backend, this bug disappears so it appears to be specific to Ubuntu's apt backend.

The few times I was able to open it (prior to it doing nothing whatsoever) nothing ever happened or you had to install the application more than once.

Iain Lane (laney) wrote :

There was an extremely suspicious critical being output when clicking the button. That was the way in to fixing this bug.

Not uploading right away; g-s is stuck in proposed independently anyway.

https://git.gnome.org/browse/gnome-software/commit/?id=acc4a0f7b02dfe61534c2de07900d4f81dcb4e1c

Changed in gnome-software (Ubuntu):
status: Confirmed → Fix Committed
Jeremy Bicha (jbicha) on 2016-12-17
Changed in ubuntu-gnome:
status: Confirmed → Fix Committed
Jeremy Bicha (jbicha) on 2016-12-17
tags: removed: block-proposed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.22.2+git20161108.0.a58dfc7-0ubuntu5

---------------
gnome-software (3.22.2+git20161108.0.a58dfc7-0ubuntu5) zesty; urgency=medium

  * Add git_adopt-system-packages.patch:
    - Copy patch from wip/ubuntu-zesty branch to fix Install button.
      Thanks Iain Lane! (LP: #1640741)

 -- Jeremy Bicha <email address hidden> Fri, 16 Dec 2016 20:19:08 -0500

Changed in gnome-software (Ubuntu):
status: Fix Committed → Fix Released
rahmadani (rahmadani) on 2017-04-08
Changed in ubuntu-gnome:
assignee: nobody → rahmadani (rahmadani)
Changed in gnome-software (Ubuntu):
assignee: nobody → rahmadani (rahmadani)
Jeremy Bicha (jbicha) on 2017-04-08
Changed in ubuntu-gnome:
assignee: rahmadani (rahmadani) → nobody
Changed in gnome-software (Ubuntu):
assignee: rahmadani (rahmadani) → nobody
Changed in ubuntu-gnome:
status: Fix Committed → Fix Released

Hi,
Hi,
Hi, is it really fixed?

I've installed clean Ubuntu GNOME 17.04 (Zesty Zapus) and have the same issue. When you download any .deb file like Chrome, Virtualbox and etc and double click on it - it opens Software Center. But clicking on Install button does nothing. But if you select any app from Software Center, for example Caffeine - Install button works just fine. So the issue is only with downloaded .deb files. If you try to use Gdebi for the same files - everything works fine.

I've tried reinstalling it by doing:

$ sudo apt-get --purge remove gnome-software
$ sudo apt-get install gnome-software

But the problem remains.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 17.04
Release: 17.04
Codename: zesty

$ dpkg -s gnome-software
Package: gnome-software
Status: install ok installed
Priority: optional
Section: gnome
Installed-Size: 1371
Maintainer: Ubuntu Developers <email address hidden>
Architecture: amd64
Version: 3.22.7-0ubuntu3
Replaces: gnome-packagekit-session (<< 3.16.0-2~)
Depends: appstream, aptdaemon, gnome-software-common (= 3.22.7-0ubuntu3), gnome-software-plugin-snap, gsettings-desktop-schemas (>= 3.18), packagekit (>= 1.1.4), software-properties-gtk, dconf-gsettings-backend | gsettings-backend, libappstream-glib8 (>= 0.6.9), libapt-pkg5.0 (>= 1.2), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.14), libcairo2 (>= 1.2.4), libfwupd1 (>= 0.7.3), libgcc1 (>= 1:3.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.46), libgnome-desktop-3-12 (>= 3.18), libgtk-3-0 (>= 3.22.4), libgtkspell3-3-0, libgudev-1.0-0 (>= 146), libjson-glib-1.0-0 (>= 0.13.2), liboauth0 (>= 0.9.1), libpango-1.0-0 (>= 1.14.0), libpolkit-gobject-1-0 (>= 0.99), libsecret-1-0 (>= 0.7), libsoup2.4-1 (>= 2.52), libsqlite3-0 (>= 3.5.9), libstdc++6 (>= 5.2)
Recommends: libgtk2-perl
Suggests: fwupd, gnome-software-plugin-flatpak, gnome-software-plugin-limba
Breaks: gnome-packagekit-session (<< 3.16.0-2~)
Conffiles:
 /etc/apt/apt.conf.d/60gnome-software 5674c7f56873f7747749e9691c6f322e
 /etc/xdg/autostart/gnome-software-service.desktop a96b13d13b4342bb9b0a23ae40d936ca
Description: Software Center for GNOME
 Software lets you install and update applications and system extensions.
 .
 Software uses a plugin architecture to separate the frontend from the
 technologies that are used underneath. Currently, a PackageKit plugin provides
 data from a number of traditional packaging systems, such as rpm or apt. An
 appdata plugin provides additional metadata from locally installed data in the
 appdata format.
Homepage: https://wiki.gnome.org/Apps/Software
Original-Maintainer: Debian GNOME Maintainers <email address hidden>

Jeremy Bicha (jbicha) wrote :

Stanislav, that is a different bug. See https://launchpad.net/bugs/1672424

Ajit Mutalik (ajit-m) wrote :

please fix this

Robert (robert.r.hansen) on 2017-05-11
Changed in gnome-software (Ubuntu):
assignee: nobody → Robert (robert.r.hansen)
assignee: Robert (robert.r.hansen) → nobody

I've just made a fresh install of Linux Ubuntu GNOME 17.04 Zasty Zesty Zapus, and I immediately ran into the same problem while installing the Opera browser on my system.

The install button STILL DOES NOTHING. The bug status claimes "fixed". I doubt it.

Confirming on gnome-software 3.22.7, Ubuntu 17.04 - the issue is NOT FIXED.

Please change the tag back to "not fixed". How is nobody working on this, how is anyone supposed to install software if the "install" button is not working? (yes, dpkg -i works)

$ lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 17.04
Release: 17.04
Codename: zesty

$ dpkg -s gnome-software

Package: gnome-software
Status: install ok installed
Priority: optional
Section: gnome
Installed-Size: 1376
Maintainer: Ubuntu Developers <email address hidden>
Architecture: amd64
Version: 3.22.7-0ubuntu3.17.04.5
Replaces: gnome-packagekit-session (<< 3.16.0-2~)
Depends: appstream, aptdaemon, gnome-software-common (= 3.22.7-0ubuntu3.17.04.5), gnome-software-plugin-snap, gsettings-desktop-schemas (>= 3.18), packagekit (>= 1.1.4), software-properties-gtk, dconf-gsettings-backend | gsettings-backend, libappstream-glib8 (>= 0.6.9), libapt-pkg5.0 (>= 1.2), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.14), libcairo2 (>= 1.2.4), libfwupd1 (>= 0.7.3), libgcc1 (>= 1:3.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.46), libgnome-desktop-3-12 (>= 3.18), libgtk-3-0 (>= 3.22.4), libgtkspell3-3-0, libgudev-1.0-0 (>= 146), libjson-glib-1.0-0 (>= 0.13.2), liboauth0 (>= 0.9.1), libpango-1.0-0 (>= 1.14.0), libpolkit-gobject-1-0 (>= 0.99), libsecret-1-0 (>= 0.7), libsoup2.4-1 (>= 2.52), libsqlite3-0 (>= 3.5.9), libstdc++6 (>= 5.2)
Recommends: libgtk2-perl
Suggests: fwupd, gnome-software-plugin-flatpak, gnome-software-plugin-limba
Breaks: gnome-packagekit-session (<< 3.16.0-2~)
Conffiles:
 /etc/apt/apt.conf.d/60gnome-software 5674c7f56873f7747749e9691c6f322e
 /etc/xdg/autostart/gnome-software-service.desktop a96b13d13b4342bb9b0a23ae40d936ca
Description: Software Center for GNOME
 Software lets you install and update applications and system extensions.
 .
 Software uses a plugin architecture to separate the frontend from the
 technologies that are used underneath. Currently, a PackageKit plugin provides
 data from a number of traditional packaging systems, such as rpm or apt. An
 appdata plugin provides additional metadata from locally installed data in the
 appdata format.
Homepage: https://wiki.gnome.org/Apps/Software
Original-Maintainer: Debian GNOME Maintainers <email address hidden>

Ruben (rubenski) wrote :

Confirmed not fixed on gnome-software 3.22.7. Please fix. Software center is one of the first apps people use after installing Ubuntu. It now feels as if Ubuntu "doesn't work" right off the bat.

Jeremy Bicha (jbicha) wrote :

Ruben, this bug is fixed.

Please file a new bug for your issue by running this command and filling out the form:

ubuntu-bug gnome-software

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers