SRU more minor fixes to GNOME Software

Bug #1590508 reported by William Hua on 2016-06-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned

Bug Description

[Impact]

Improve the usability of GNOME Software by fixing the following bugs:

* Some KDE4 applications cannot be launched (e.g. kolourpaint) (LP: #1575529)
* Added error checking for the case where the ratings and reviews server isn't accessible
* Fix a couple of CSS errors
* Fix calculation of review ratings (LP: #1581938)
* Make the app folder dialog work again (LP: #1590115)
* Remove broken symlink of xdg-app-reviews plugin (LP: #1573052)
* Disable redundant notification (LP: #1592382)
* Disable app folders feature when run outside GNOME (LP: #1590152)

[Test Cases]

* Install, then attempt to launch kolourpaint from the details shell
* Disconnect from the network, then attempt to submit a review
* Run gnome-software from the command line, verify there's no warning "failed to open plugin /usr/lib/gs-plugins-9/libgs_plugin_xdg_app_reviews.so"

[Regression Potential]

Regression potential should be low as the fixes for these bugs are fairly isolated. Some of these changes are simple removal of features that aren't supported under Unity.

William Hua (attente) on 2016-06-08
description: updated
William Hua (attente) wrote :

Fix the changelog to include bug numbers

description: updated

The attachment "gnome-software_3.20.1+git20160608.1.6fbada8-ubuntu-xenial-0ubuntu1.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Changed in gnome-software (Ubuntu):
importance: Undecided → Medium
William Hua (attente) wrote :

Apply recent fix applied upstream for proper dialog destruction

Sebastien Bacher (seb128) wrote :

thanks, the update looks good, small nitpick though ... this bug is not referenced in the changelog, maybe use it for the lines which don't have a bug reference?

William Hua (attente) wrote :

Reference this bug in the changelog

William Hua (attente) wrote :

Add fix for LP: #1573052 as well as curated snaps on the overview

William Hua (attente) wrote :

Feature Shout IRC snap on the overview shell

William Hua (attente) wrote :

Disable app folders feature outside of GNOME (LP: #1590152)
Disable annoying redundant notification (LP: #1592382)

William Hua (attente) on 2016-06-14
description: updated
William Hua (attente) wrote :

Use snap name instead of summary
Don't curate popular snaps

description: updated
William Hua (attente) wrote :

Fix date in debian/changelog

Changed in gnome-software (Ubuntu Xenial):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu Xenial):
status: New → Confirmed
Changed in gnome-software (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1

---------------
gnome-software (3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1) yakkety; urgency=medium

  * New upstream snapshot from the wip/ubuntu-xenial branch at
    git://git.gnome.org/gnome-software.
    - Fix launching various KDE4 applications (LP: #1575529)
    - Guard against review server errors (LP: #1590508)
    - Fix a couple of CSS errors (LP: #1590508)
    - Fix conversion from star ratings (1-5) to G-S rating (0-100) (LP: #1581938)
    - Fix wilson score calulation (LP: #1581938)
    - Make the app folder dialog work again (LP: #1590115)
    - Remove broken symlink of xdg-app-reviews plugin (LP: #1573052)
    - Disable redundant notification (LP: #1592382)
    - Disable app folders feature when run outside GNOME (LP: #1590152)
  * Drop snap_mime_type.patch which is in this release.

 -- William Hua <email address hidden> Fri, 17 Jun 2016 09:47:49 +0100

Changed in gnome-software (Ubuntu):
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

Laney sponsored that one, unsubscribing sponsors

Changed in gnome-software (Ubuntu Xenial):
status: Confirmed → Fix Committed

Hello William, or anyone else affected,

Accepted gnome-software into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

The update works fine, setting as verified

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1

---------------
gnome-software (3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1) xenial; urgency=medium

  * Backport to 16.04, with the world's longest version number.
  * Update Vcs-Bzr for the stable release

gnome-software (3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1) yakkety; urgency=medium

  * New upstream snapshot from the wip/ubuntu-xenial branch at
    git://git.gnome.org/gnome-software.
    - Fix launching various KDE4 applications (LP: #1575529)
    - Guard against review server errors (LP: #1590508)
    - Fix a couple of CSS errors (LP: #1590508)
    - Fix conversion from star ratings (1-5) to G-S rating (0-100) (LP: #1581938)
    - Fix wilson score calulation (LP: #1581938)
    - Make the app folder dialog work again (LP: #1590115)
    - Remove broken symlink of xdg-app-reviews plugin (LP: #1573052)
    - Disable redundant notification (LP: #1592382)
    - Disable app folders feature when run outside GNOME (LP: #1590152)
  * Drop snap_mime_type.patch which is in this release.

 -- Iain Lane <email address hidden> Fri, 17 Jun 2016 10:11:30 +0100

Changed in gnome-software (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-software has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.