Calculated review score is lower on Ubuntu 16.04 than on Ubuntu 14.04

Bug #1581938 reported by Peter on 2016-05-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

I am the author of WireframeSketcher tool for which I distribute debian packages (wireframesketcherstudio). This is a commercial desktop app that we registered through developer.ubuntu.com, and it has accumulated some reviews and scores in the previous years. Ubuntu 14.04 shows 4 stars for WireframeSketcher. The same reviews are also visible under Ubuntu 16.04, however only 2 stars are shown.

I've tried to calculate the score manually using a weighted average formula and the score given on Ubuntu 14.04 is the one that is correct.

If this is a bug then please fix it. However if the score was lowered intentionally, then I'd like to know why.

Peter (petru-severin) wrote :
Peter (petru-severin) wrote :
summary: - Calculated review score is lower in Ubuntu 16.04 than in Ubuntu 14.04
+ Calculated review score is lower on Ubuntu 16.04 than on Ubuntu 14.04
description: updated
Changed in gnome-software (Ubuntu):
importance: Undecided → High
Changed in gnome-software (Ubuntu):
status: New → Confirmed
Robert Ancell (robert-ancell) wrote :

The scoring should use the same algorithm, so that suggests there's a mistake somewhere.

Robert Ancell (robert-ancell) wrote :

Fixed in the git branch.

Changed in gnome-software (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1

---------------
gnome-software (3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1) yakkety; urgency=medium

  * New upstream snapshot from the wip/ubuntu-xenial branch at
    git://git.gnome.org/gnome-software.
    - Fix launching various KDE4 applications (LP: #1575529)
    - Guard against review server errors (LP: #1590508)
    - Fix a couple of CSS errors (LP: #1590508)
    - Fix conversion from star ratings (1-5) to G-S rating (0-100) (LP: #1581938)
    - Fix wilson score calulation (LP: #1581938)
    - Make the app folder dialog work again (LP: #1590115)
    - Remove broken symlink of xdg-app-reviews plugin (LP: #1573052)
    - Disable redundant notification (LP: #1592382)
    - Disable app folders feature when run outside GNOME (LP: #1590152)
  * Drop snap_mime_type.patch which is in this release.

 -- William Hua <email address hidden> Fri, 17 Jun 2016 09:47:49 +0100

Changed in gnome-software (Ubuntu):
status: Fix Committed → Fix Released

Hello Peter, or anyone else affected,

Accepted gnome-software into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-software (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Changed in gnome-software (Ubuntu Xenial):
importance: Undecided → High
Jeremy Bicha (jbicha) wrote :

I am unable to verify this bug because I can't do the described test case.
I do not see wireframesketcherstudio in the Software app in Ubuntu 16.04 LTS.

Sebastien Bacher (seb128) wrote :

It seems only available for trusty ... Peter could you maybe test the update? That bug being verified is the only thing blocking that SRU to be copied to updates

Peter (petru-severin) wrote :

I am not able to test this issue at this moment. wireframesketcherstudio package is not available from default repositories since it's a commercial package registered via Ubuntu developer portal. The issue can be easily tested by installing WireframeSketcher debian package from wireframesketcher.com website which will install wireframesketcherstudio package. Once installed, this package can be checked in Ubuntu Software Center with it's associated reviews and score.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1

---------------
gnome-software (3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1) xenial; urgency=medium

  * Backport to 16.04, with the world's longest version number.
  * Update Vcs-Bzr for the stable release

gnome-software (3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1) yakkety; urgency=medium

  * New upstream snapshot from the wip/ubuntu-xenial branch at
    git://git.gnome.org/gnome-software.
    - Fix launching various KDE4 applications (LP: #1575529)
    - Guard against review server errors (LP: #1590508)
    - Fix a couple of CSS errors (LP: #1590508)
    - Fix conversion from star ratings (1-5) to G-S rating (0-100) (LP: #1581938)
    - Fix wilson score calulation (LP: #1581938)
    - Make the app folder dialog work again (LP: #1590115)
    - Remove broken symlink of xdg-app-reviews plugin (LP: #1573052)
    - Disable redundant notification (LP: #1592382)
    - Disable app folders feature when run outside GNOME (LP: #1590152)
  * Drop snap_mime_type.patch which is in this release.

 -- Iain Lane <email address hidden> Fri, 17 Jun 2016 10:11:30 +0100

Changed in gnome-software (Ubuntu Xenial):
status: Fix Committed → Fix Released
tags: removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers