GNOME Software does not install third-party .deb packages

Bug #1573206 reported by Øystein Steffensen-Alværvik on 2016-04-21
This bug affects 393 people
Affects Status Importance Assigned to Milestone
GNOME Software
Ubuntu GNOME
Ubuntu Studio
gnome-software (Ubuntu)
Robert Ancell

Bug Description

Ubuntu 16.04 LTS (clean install). 64-bit. Final release.
Gnome-software version: 3.20.1+git20160420.1.ca63436.ubuntu-xenial-0ubuntu2
  Version table:
 *** 3.20.1+git20160420.1.ca63436.ubuntu-xenial-0ubuntu2 500
        500 xenial/main amd64 Packages
        100 /var/lib/dpkg/status

I intended to install MEGA Sync Client, Google Chrome and Dropbox by downloading the needed packages from their websites (respectively and and ). I opened the packages one by one with gnome-software and pressed Install - nothing, except for a super-quick progress bar animation, happened. No matter how many times I tried, same result. Also, an icon pops up on the panel saying "Waiting to install", but nothing seems to happen.

This only seems to happen with third-party packages; installing a random deb from worked.

I even tried to reinstall the system to make this work, but same problem.

Gdebi, however, installs the packages as expected.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gnome-software 3.20.1+git20160420.1.ca63436.ubuntu-xenial-0ubuntu2
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Apr 21 21:01:52 2016
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/gnome-software
InstallationDate: Installed on 2016-04-21 (0 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
 PATH=(custom, no user)
SourcePackage: gnome-software
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed

The same is true for this hangouts plugin I use in Firefox. It require this deb:

But, it won't install.

Same is true for this deb:

Vincent Thiele (vincentthiele) wrote :

Please fix this, it's a no go for an LTS release!

Stanislav (stanislav-schmidt) wrote :

Same issue here. Can't install any deb package in software centre.

1) Use the GDebi Package Installer
2) Use the command line: dpkg -i <filename>.deb

dusk (dusktumult) wrote :

This is happening to me to.
I cant seem to get either of the workarounds to work. When i try to install the gdebi package installer in the software center it does the same thing as when I try to install .deb files.
I had previously installed things via the software center but now nothing is installing. I can't really do anything on my computer without any software. Please Fix!

Changed in gnome-software (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Jonayad Rahman (jonayadrahman) wrote :

Same problem for me. I try to install Chrome. it just keep me waiting. and didn't give any result. Please try to fix it quickly.

Anuj Sharma (anujsharma9196) wrote :

Please fix it. I'm too suffering from this irritating bug

Subhadeep Dey (subhadeep-dey) wrote :

I thought I was the only one facing this issue, but it seems that it's a common issue. Hope it gets resolved soon.

Belenos (belenos) wrote :

Same problem here!

Shinjan Saha (sahashinjan) wrote :

It affects me as well....

Masi (soopo) wrote :

The same problem is with Google Chrome's 64bit .deb package in completely fresh 16.04. First application in fresh installation (not upgrade). Thread here

same bug here also ...
unfortunately :(

As Stanislav mentioned, in post #6, there are other ways you can installed these deb packages.

However, even after you get the deb package installed, it breaks your ability to sudo apt-get update.

See here:

Lonnie, the only error you should worry about is regarding dependencies after installing via dpkg. This can be fixed by doing a:

apt-get install -f

The other error is caused by SHA1 removal and can safely be ignored until the repos are updated:

There is also another bug report addressing that issue.

Same thing happen to me. Please, fix it to continue enjoying Ubuntu 16!

Mario (marcorr70) wrote :

I have a similar problem, was disappointed to watch the software center not able me to install third party .deb programs. I believe it's a step back and a bad promotion for ubuntu.

Mario (marcorr70) wrote :

Also Gdebi doesn't solve the problem, returned me dependencies problem and wasn't able itself to solve.

Changed in ubuntu-gnome:
status: New → Confirmed

I couldn't find a report filed on this issue upstream already so I have done so and added a bug watch to monitor that here.

Changed in gnome-software:
importance: Unknown → High
status: Unknown → Confirmed
postadelmaga (postadelmaga) wrote :

also affects me.

Siddhartha (narenana) wrote :

Reproducible for multiple packages on Ubuntu 16.04 LTS

Changed in ubuntustudio:
status: New → Confirmed
Pablo Celayes (pablocelayes) wrote :

Same here, trying to install Chrome or Skype.

bogdan.rusu (rusubogdan93) wrote :

it affects me also

To anyone that has not noticed yet. Even the packages that ARE getting installed via this "Ubuntu Software" program, appear as NOT installed when one checks again. I tried with Audacity and Darktable. Both are properly installed.. both appear as if they are not.

@PanosKatertziadis, Please report that as a separate issue. Though I believe I have already seen a similar report upstream, though I could be mistaken.

summary: - Ubuntu Software does not install third-party .deb packages
+ GNOME Software does not install third-party .deb packages
Changed in gnome-software (Ubuntu):
status: Triaged → Confirmed
Sebastien Bacher (seb128) wrote :
Changed in gnome-software (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Robert Ancell (robert-ancell)
Sebastien Bacher (seb128) wrote :

The fix is not working as it should, it seems to use the package name where the filename/path is wanted

Changed in gnome-software (Ubuntu):
status: Fix Committed → Triaged
status: Triaged → In Progress
tags: added: trello-import
Will Cooke (willcooke) on 2016-04-25
tags: removed: trello-import

It affects me also.

Doni (jerss2k) wrote :

This affects me as well.

Adnan Yumer (adnanyumer) wrote :

Affects me too.

Tim Hitchins (timtjtim) wrote :

Hi, this has been fixed upstream. If you still have issues, please fully update with:

    sudo apt-get update
    sudo apt-get upgrade

and check again. If it isn't working, please restart. Finally, if you're fully up to date (check again after the restart) please post back here, and we will look into it. Your Ubuntu distro would be helpful info too.

Changed in ubuntu-gnome:
status: Confirmed → Fix Released
Changed in ubuntustudio:
status: Confirmed → Fix Released
Changed in gnome-software (Ubuntu):
status: In Progress → Fix Released

There're no official updates for this software. The fix hasn't been released.

Changed in gnome-software:
status: Confirmed → Fix Released
brad (dragonsawareness) wrote :

Hi, this has been fixed upstream. If you still have issues, please fully update with:

    sudo apt-get update
    sudo apt-get upgrade

brad@Brad-Ubuntu-16:~$ sudo apt-get update
[sudo] password for brad:
Hit:1 xenial InRelease
Get:2 xenial-updates InRelease [92.2 kB]
Hit:3 xenial InRelease
Hit:4 xenial-backports InRelease
Get:5 xenial-security InRelease [92.2 kB]
Fetched 184 kB in 1s (140 kB/s)
Reading package lists... Done
brad@Brad-Ubuntu-16:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

There is no fix in Ubuntu 16.04?

Erik Pöhm (erzzo) wrote :

Im affected too

Albert Cutrona (acutbal) wrote :

I'm with Ubuntu 16.04, still not working. I've updated my system a few minutes ago, only an update for Numix theme and G'Mic for Gimp. Maybe the fix is not available?

Regards!! :)

Kumaraguru (gurukumara) wrote :

I know there are workarounds to install deb packages but I am totally disappointed with the new package installer. Shouldn't this be properly tested before release? especially, before pushing a LTS release?

Bruce Pieterse (octoquad) wrote :

All affected, apologies for the confusion but a fixed has landed upstream and has not yet landed yet in Ubuntu. The new upstream version will need to be packaged first before distributed to the main release pocket. If you need to install a package, please refer to comment #6 for the mean time.

Changed in ubuntu-gnome:
status: Fix Released → Triaged
Ross Gammon (rosco2) on 2016-04-26
Changed in ubuntustudio:
status: Fix Released → Triaged
importance: Undecided → High
Mathew Hodson (mhodson) on 2016-04-27
Changed in gnome-software (Ubuntu):
status: Fix Released → Triaged
Mathew Hodson (mhodson) on 2016-04-28
affects: gnome-software → ubuntu-translations
Changed in ubuntu-translations:
importance: High → Undecided
status: Fix Released → New
no longer affects: ubuntu-translations
28 comments hidden view all 108 comments
Cedara (cedara2) wrote :

Thanks for fixing the bug, finally could install the vivaldi-third-party-deb from nautilus.

Joe Dunster (joe-dunster) wrote :

I've installed 16.04 on a 32 bit laptop (yesterday) but am unable to install .deb files with the software installer... infact the software installer is just a blank screen now

brad (dragonsawareness) wrote :

Can someone please change the status to fixed

psionprime (psionprime) wrote :

It's not fixed as of 2016-05-24 08:50 edt. Installs sometimes happen but no indicator that the package is installed, just the same "Install" button shows. Further, "Important OS updates" does nothing for hours. I wind up using Synaptic to mark and upgrade the system. Synaptic is installed as Software doesn't display all available packages.

I appreciate the efforts for all involved in the Ubuntu project.

coskibum (1coskibum) wrote :

This effecting me to from adding programs from the Ubuntu software. Firewall says it's installed but when I try to configure it, it will not open up.I have uninstalled and reinstalled it and still nothing.

Also when I try to install Ubuntu Tweak the same thing happens.

This after a clean install of 16.04:

AMD FX 8350
18gb ram
new motherboard - Asus Sabertooth 990FC R2.0

Shoaib Sadiq (shoaibsadiq) wrote :

I am new to ubuntu and facing this kind of error in the beginning isn't welcoming..

description: updated

Being new to Ubuntu and already facing things like wont be able to install such things as Google Chrome and other 3rd party soft, and can't manage why is difficult. Hope this changes.

Whitney (blessedwhitney) wrote :

Also affects me -- this is particular troublesome bug for new people (ubuntus target demographic) since Chrome, a popular browser with syncing abilities, can only be installed via a work around.

Peter (readingmymail) wrote :

Please fix this bug!!! This has not been fixed despite what has been claimed. I have done a clean install of both 16.04 and 16.04.1 and the bug persists. Come on guys, this is a LTS release, and this should be addressed. Work-arounds is not a solution for faulty software.

It looks to me that when you try to install some package from the Software Centre, it starts the install then hangs. I believe this is because a dialog box should appear asking for admin credentials to install the software, but since that dialog box does not appear it just sits there waiting.

My set up is a Dell Precision M4500 (but this isn't a hardware issue - it is most definitely a software problem). My installation is a fully encrypted hard drive with encrypted home directory if that makes a difference.

Please mark this bug as not fixed.

Jonathan Martins (web-j) wrote :

man, what a shame! A nice feature for the user broken soo long! Elevate the IMPORTANCE!

Jeremy Bicha (jbicha) wrote :

@Peter please file a new bug about your issue since this particular bug is fixed, especially with a fresh install of Ubuntu 16.04. Please include specifics since there isn't enough information in your comment here for developers to know what exactly isn't working.

You may find it helpful to read "How to report bugs effectively" We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at

At a minimum, we need:
1. The specific steps or actions you took that caused you to encounter the problem.
2. The behavior you expected.
3. The behavior you actually encountered (in as much detail as possible).

Seems to instal with GDebi as also via terminal but at the end does not work

Fernando D. (fdbozzo) wrote :

This bug affects me too. I know that apparently it's fixed on the "Proposed" repos, but I don't want to enable it because I don't want to became a beta-tester with my System.

When be this fix available as normal update?

My system info:
cat /proc/version
Linux version 4.4.0-31-generic (buildd@lgw01-16) (gcc version 5.3.1 20160413 (Ubuntu 5.3.1-14ubuntu2.1) ) #50-Ubuntu SMP Wed Jul 13 00:07:12 UTC 2016

Fernando D. (fdbozzo) wrote :

I forgot to say that I've fresh installed from 16.04.1 ISO

Jeremy Bicha (jbicha) wrote :

Fernando, it is a normal update now. It was only a proposed update for a few days so it could be tested first to make sure it fixed bugs and didn't make things worse. The fix is also included in Ubuntu 16.04.1.

If it's still not working, please run ubuntu-bug gnome-software to report a new bug.

You may find it helpful to read "How to report bugs effectively" We'd be grateful if you could provide a complete description of the problem.

We have instructions on debugging some types of problems at

At a minimum, we need:
1. The specific steps or actions you took that caused you to encounter the problem.
2. The behavior you expected.
3. The behavior you actually encountered (in as much detail as possible).

Fernando D. (fdbozzo) wrote :

Hi Jeremy:

In the meanwhile I've installed the previous Ubuntu Software Center that works ok and have a more clear design.

Very thanks for answering! If I use this Software Center again, I'll report any problem following the steps you described.

Best Ragards.-

Zheng Cheng (guokrfans) wrote :

This affects me as well.

Is there any updates on a fix as over 4 months have passed and this problem still exists?

Andres Vega (avegacon) wrote :

I am also having this problem.

When are they going to fix this bug?

fred (nightfeaver) wrote :

Also having the problem.

Jordan van Zyl (jordan5zulu) wrote :

This also affects me

Deafpyrotiger (deafpyrotiger) wrote :

Happy to report that this affects me as well, it seems that this is a persistent bug as it has been 9 months since first reporting now...

stephy (stephy) wrote :

It affects me too..

Mihaly Vadai (vadaim) wrote :

I found that SOME repositories don't have the package files for Gnome updates, but some others do. So for me the same symptoms occurred with Gnome updates.

Changing my local repository to another one fixed the problem for me. In my case adding deb xenial-updates main solved the problem.

Here's a list of mirrors I think work at least with gnome updates:

I downloaded the ubuntu-16.04.2-desktop-amd64.iso from Ubuntu's main website around a month ago and it has this bug. I tried to install Chrome using the GUI and it failed, but using dpkg was fine.

Henrietta Forssen (hforssen) wrote :

Happening to me too, please fix asap! Thanks

med (anbessa) wrote :

installed ubuntu 16.04.3 LTS yesterday , I encountered this problem, couldnt install deb via Ubuntu Software installer

Jeremy Bicha (jbicha) wrote :

Garth or med,

Please open a new bug for that issue.

Keith (kivison) wrote :

Yes, I have just installed a clean 16.04 downloaded from the Ubuntu site last night and it has the same issue.

Przemyslaw Golab (n-pigeon) wrote :

Same issue with 17.04

Dimka ( wrote :

Same with ubuntu 16.04.3 LTS

Same with ubuntu 16.04.3 LTS

Danilo Miranda (danilokassio) wrote :

this affects me too.

Andrii (aemxdp) wrote :

Just installed Ubuntu Studio 16.04.3, also affects me.

sul aga (sul-aga) wrote :

This issue affects me.
Ubuntu 16.04.3 LTS

Ruslan Primak (ruslan-primak) wrote :

Just installed Ubuntu Studio 16.04.3, also affects me.

Odai Jawasreh (xodaix) wrote :

The issue still exists in Ubuntu 17.10, I can't install MySQL workbench or other software, I click install then I provide my password nothing is begin installed!.

Sruli (sruli) wrote :

Not sure if its the same, I am trying to install megasync dpkg -i megasync.deb, after install there is a icon but it just doesn't start, syslog shows nothing for it, it seems that its not installed, is it the same bug?

Sruli (sruli) wrote :

I don't see a delete/edit option, but ignore my previous post ^ it was a permissions issue

Mark Baumann (mark.baumann) wrote :

I have made an Update (sudo apt-get install update) and than I´ve made (sudo apt-get install gdebi).
Now I can run the Software Center on Debian as a virtual Machine.

Displaying first 40 and last 40 comments. View all 108 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers