gnome-software (ubuntu-software) doesn't install third party applications

Bug #1572871 reported by Jesse Theisen on 2016-04-21
102
This bug affects 24 people
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
Undecided
Unassigned

Bug Description

Software Center in 16.04 RC doesn't allow me to install third party applications. Install will work but nothing happens(I assume it hangs on something?)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed

This also happens with the 16.04 final release.

BTW, Ubuntu 16.04 comes with gnome-software and not software-center

affects: software-center (Ubuntu) → gnome-software (Ubuntu)
summary: - Software Center doesn't install third party applications
+ gnome-software (ubuntu-software) doesn't install third party
+ applications
/ (0-) wrote :

Confirmed. Cannot install Chrome using the default instructions and file handler. This will affect many users.

brad (dragonsawareness) wrote :

Can confirm that "software centre" aka gnome software centre in 16.04 will freeze/not respond with a .deb that is 3rd party aka google chrome.

There is a small ? in the dock that says installing, but doesn't show a window or progress.

You can continuously click "install" to no advail.

In earlier versions of Ubuntu, I had no issue installing this deb:
https://www.google.com/tools/dlpage/hangoutplugin

I haven't yet figured out a way to do it in Ubuntu 16.04:
http://askubuntu.com/questions/760305/how-to-install-google-hangouts-plugin-in-ubuntu-16-04

I really need this plug-in, because allows my to do all my phone calls at work via Gmail and my Laptop.

Also, this deb installed in previous versions of Ubuntu:
http://torrent-search.sourceforge.net/download

It does not install in the Ubuntu 16.04 release.

/ (0-) wrote :

Until this is fixed, you can install Chrome for now by adding the repo:

echo deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main | sudo tee /etc/apt/sources.list.d/google-chrome.list

And Hangouts plugin via:

echo deb http://dl.google.com/linux/talkplugin/deb/ stable main | sudo tee /etc/apt/sources.list.d/google-talkplugin.list

aaronfranke (arnfranke) wrote :

I can't believe that such a critical bug was allowed in an LTS release and has remained for months and months. This needs to be fixed before 16.04.1 LTS.

I really don't understand why they didn't just continue including the ubuntu-software-center package instead, as it works much better than this broken tool.

Well, I just installed 16.04.2 LTS and was faced with the same bug.
Guess I'd better go to Ubuntu 14 and save some headache.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers