[SRU Oneiric] gnome-shell users get GNOME3's new printer setup tool by default and this tool needs cups-pk-helper

Bug #877367 reported by Till Kamppeter
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Fix Released
Low
Unassigned
Oneiric
Fix Released
Low
Unassigned

Bug Description

gnome-shell users do not get system-config-printer as default printer setup tool but the new tool which comes with gnome-control-center (System Settings) of GNOME 3. This tool does not use CUPS' own authentication mechanisms ("lpadmin" group) for administrative tasks but PolicyKit through cups-pk-helper. As cups-pk-helper is not installed by default, most users have an unusable printer tool (without Unlock button).

The proposed SRU for Oneiric adds a dependency on cups-pk-helper to the gnome-shell, so that at least all gnome-shell users will have cups-pk-helper installed. We do not add this dependency to gnome-control-center as cups-pk-helper is in Universe and gnome-control-center in Main, and most users of gnome-control-center have a Unity desktop which is used with system-config-printer and so they do not need cups-pk-helper.

This is an interim solution until the new GNOME printer tool will be enhanced with functionality of system-config-printer and then made the default for everyone.

Changed in gnome-shell (Ubuntu):
status: New → Triaged
importance: Undecided → High
milestone: none → oneiric-updates
Changed in gnome-shell (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → High
milestone: none → oneiric-updates
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Uploaded the fixed gnome-shell package to oneiric-proposed. Please test it as soon as it gets approved. This will be announced with a comment in this bug report. A debdiff of the changes is attached.

Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-shell (Ubuntu Oneiric):
status: Triaged → Fix Committed
Revision history for this message
Jeremy Bicha (jbicha) wrote : Re: [Bug 877367] Re: [SRU Oneiric] gnome-shell users get GNOME3's new printer setup tool by default and this tool needs cups-pk-helper

Till, why don't we push this update along with the gshell 3.2.1 update? I
was planning on packaging it tomorrow if no one else had gotten to it.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Jeremy, feel free to join the two SRUs to one. Rodrigo Moya asked me for uploading as SRU for the cups-pk-helper dependency.

Revision history for this message
Martin Pitt (pitti) wrote :

Jeremy Bicha [2011-10-18 13:54 -0000]:
> Till, why don't we push this update along with the gshell 3.2.1 update? I
> was planning on packaging it tomorrow if no one else had gotten to it.

That's fine. Just upload a followup, then I'll reject Till's upload
and take your's instead.

Revision history for this message
Martin Pitt (pitti) wrote :

gnome-shell already recommends cups-pk-helper, so it should already work in oneiric final. What went wrong there? Did you install with --no-install-recommends or something similar?

I reject Till's upload because that now has a recommend _and_ a depends, and Jeremy will do a 3.2.1 upload.

Changed in gnome-shell (Ubuntu Oneiric):
status: Fix Committed → Incomplete
Changed in gnome-shell (Ubuntu):
status: Fix Committed → Triaged
status: Triaged → Incomplete
milestone: oneiric-updates → none
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

I have a machine on which I did the Oneiric development going through all the Oneiric development from stable Natty with daily updates during the cycle. Now it has the current Oneiric. One day there was an incompatibility of system-config-printer with cups-pk-helper (this is fixed in current Oneiric). So I removed cups-pk-helper manually. Later on I continued doing updates and this seems not to have re-installed cups-pk-helper.

Now my doubt is whether Recommends is strong enough or whether Depends would be better here. A manual (or conflict-induced) deinstallation of cups-pk-helper would break the printer tool.

Changed in gnome-shell (Ubuntu):
status: Incomplete → Confirmed
Changed in gnome-shell (Ubuntu Oneiric):
status: Incomplete → Confirmed
Revision history for this message
Martin Pitt (pitti) wrote :

Thanks for the explanation. I'm ok with adding a strong depends, but it shouldn't affect a lot of people, so lowering severity.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-shell (Ubuntu Oneiric):
status: Confirmed → Triaged
Changed in gnome-shell (Ubuntu):
importance: High → Low
Changed in gnome-shell (Ubuntu Oneiric):
importance: High → Low
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello Till, or anyone else affected,

Accepted gnome-shell into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-shell (Ubuntu Oneiric):
status: Triaged → Fix Committed
tags: added: verification-needed
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Then new gnome-shell has indeed a hard dependency on cups-pk-helper, so the reported problem cannot occur any more.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.2.1-0ubuntu1

---------------
gnome-shell (3.2.1-0ubuntu1) oneiric-proposed; urgency=low

  [ Jeremy Bicha ]
  * New upstream release (LP: #878672).
    - Restore the IM state on startup - if you were available in when you
      logged out, then you'll be set available again when you log in.
    - Improve searching for contacts in the overview: search more fields,
      show a more meaningful name, require that all search terms match.
    - Improve search for applications in the overview: take frequency into
      account and tweak match algorithm
    - Remove the "Show Password" switch from network password prompts, and
      move the functionality to a right-click menu
    - Add context menus with Cut/Paste options to most entries
    - Display a caps-lock warning in password entries
    - Show the state of installed extensions in Looking Glass
    - Load user extensions after system ones
    - Fix problem with many applications showing extra-large icons in
      notifications
    - Fix a problem where alt-Tab had trouble tracking the current
      application with certain applications such as Emacs.
    - Fix confusion between different users avatar images
    - Remove behavior where you could switch workspaces by bumping
      a dragged window in the overview against a screen edge; it was
      leftover and just confusing.
    - Fix long-standing bug where the Dash in the overview could end up
      mis-sized and run off the screen
    - Fix automatic launching of applications when media is inserted
    - Fix handling of vertically stacked monitors with NVIDIA drivers
    - Translation marking fixes
    - Code cleanups and warning fixes
    - Small memory leak fixes
    - On screen keyboard:
      + Show the keyboard immediately when it's turned enabled
      + Fix problem where keyboard would hide when starting to type
        in the search entry
      + Fix problem with keyboard hiding when selected accented characters
    - Misc bug fixes
  * debian/control.in:
    - Bump minimum mutter to 3.2.1
    - Drop dependency against libdconf0 and let dh_installgsettings set
      the right dependencies.
    - Depends on cups-pk-helper instead of recommends to ensure that
      the printer applet works (LP: #877367)
  * 01_favorite_apps.patch: dropped, replaced by override file.
  * New upstream release.
 -- Jeremy Bicha <email address hidden> Mon, 24 Oct 2011 06:43:05 +0200

Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-shell (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers