gnome-shell Alt+F2 can’t run anything

Bug #816762 reported by Anders Kaseorg on 2011-07-27
68
This bug affects 12 people
Affects Status Importance Assigned to Milestone
gnome-shell
Fix Released
High
gnome-shell (Fedora)
Unknown
Unknown
gnome-shell (Ubuntu)
Undecided
Unassigned
gobject-introspection (Ubuntu)
Undecided
Unassigned

Bug Description

If I do, say, Alt+F2 ‘true’, I get “Command not found”. (Similarly for anything else that should be in PATH.)

If I do Alt+F2 ‘/bin/true’, gnome-shell crashes with this error.

    JS ERROR: !!! Exception was: Error: Error invoking Gio.app_info_launch_default_for_uri: No application is registered as handling this file
    JS ERROR: !!! lineNumber = '0'
    JS ERROR: !!! fileName = '"gjs_throw"'
    JS ERROR: !!! stack = '"("Error invoking Gio.app_info_launch_default_for_uri: No application is registered as handling this file")@gjs_throw:0
("/bin/true",false)@/usr/share/gnome-shell/js/ui/runDialog.js:337
([object _private_St_IMText],[object _private_Clutter_Event])@/usr/share/gnome-shell/js/ui/runDialog.js:250
([object _private_St_IMText],[object _private_Clutter_Event])@/usr/share/gjs-1.0/lang.js:110
"'
    JS ERROR: !!! message = '"Error invoking Gio.app_info_launch_default_for_uri: No application is registered as handling this file"'

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-shell 3.1.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-7.8-generic 3.0.0
Uname: Linux 3.0.0-7-generic x86_64
NonfreeKernelModules: openafs
Architecture: amd64
Date: Tue Jul 26 21:44:07 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Anders Kaseorg (andersk) wrote :
Changed in gnome-shell (Ubuntu):
status: New → Confirmed
mlaverdiere (mlaverdiere) wrote :

Since latest updates, alt+f2 doesn't show at all in gnome-shell (i..e. no box appearing to allow entering any command).

Chui (jan-delandtsheer) wrote :

Confirmed Oneiric 32-bit

Jeremy Bicha (jbicha) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: https://bugzilla.gnome.org/show_bug.cgi?id=656054

Changed in gnome-shell (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-shell:
importance: Unknown → High
status: Unknown → New
Changed in gnome-shell:
status: New → Fix Released
Anders Kaseorg (andersk) wrote :

Ew. The problem is that these two gnome-shell commits between 3.1.2 and 3.1.3:

http://git.gnome.org/browse/gnome-shell/commit/?id=6fc49b79a4e957f2442abcb23fafa33e1af64241
http://git.gnome.org/browse/gnome-shell/commit/?id=4c5f3aa97173b0b073d19a372d45487e4f1f0332

account for a gjs API change between 1.29.0 and 1.29.15 that oneiric’s gjs hasn’t yet made:

http://git.gnome.org/browse/gjs/commit/?id=0cd4538efcc0e39005c7921181c8e3687911255c

This is the same root cause as bug 811291.

Reverting those two commits will fix the problem (until gjs gets upgraded to 1.29.15, when we’ll get the same problem in reverse).

Anders Kaseorg (andersk) wrote :

I filed bug 822464 “Upgrade gjs to 1.29.16”, which is probably the cleanest way to deal with this problem.

This bug still shows even after upgrading gjs to version 1.29.16-0ubuntu2. Behaviour is exactly the same as described in original comment.

Error after Alt+F2 ‘/bin/true’ is:

    JS ERROR: !!! Exception was: Error: Error invoking Gio.app_info_launch_default_for_uri: No application is registered as handling this file
    JS ERROR: !!! lineNumber = '0'
    JS ERROR: !!! fileName = '"gjs_throw"'
    JS ERROR: !!! stack = '"("Error invoking Gio.app_info_launch_default_for_uri: No application is registered as handling this file")@gjs_throw:0
("/bin/true",false)@/usr/share/gnome-shell/js/ui/runDialog.js:337
([object _private_St_IMText],[object _private_Clutter_Event])@/usr/share/gnome-shell/js/ui/runDialog.js:250
"'
    JS ERROR: !!! message = '"Error invoking Gio.app_info_launch_default_for_uri: No application is registered as handling this file"'

Anders Kaseorg (andersk) wrote :

The problem is that the GLib annotations in gobject-introspection were crippled with this upload:
https://launchpad.net/ubuntu/+source/gobject-introspection/1.29.0-0ubuntu2
Undoing that patch fixes gnome-shell. Supposedly that would also break python-gobject, but that would be fixed by upgrading python-gobject to 2.90.1 which has the invoke-rewrite branch merged.

Anders Kaseorg (andersk) wrote :

So I guess we just need to wait for bug 828751 “[FFE] update pygobject to 2.90.1” and then undo the debian/glib-2.0.c hack in gobject-introspection. Adding a gobject-introspection task.

Changed in gobject-introspection (Ubuntu):
status: New → Confirmed
Joe Barnett (thejoe) wrote :

is it worth adding a patch to the gnome-shell package to revert the util.js changes above until gobject-introspection patch is reverted?

Jeremy Bicha (jbicha) wrote :

Joe, I think bug 828751 will be fixed soon which should fix things without needing to create a gnome-shell patch, which we'd then have to drop again.

Anders Kaseorg (andersk) wrote :

The gobject-introspection and pygobject fixes are staged in https://launchpad.net/~ubuntu-desktop/+archive/ppa ; I confirmed that they fix the bug. Presumably they’ll be in the main archive shortly.

Changed in gobject-introspection (Ubuntu):
status: Confirmed → In Progress
Anders Kaseorg (andersk) wrote :

This was fixed in oneiric with

gobject-introspection (1.29.16+git20110829-0ubuntu1) oneiric; urgency=low

  * New upstream snapshot, to fix a lot of bugs, in particular Gio typelib
    generation.
  * debian/libgirepository-1.0-1.symbols: Update for new version.
  * debian/glib-2.0.c, debian/rules: Drop our hack to force older glib
    annotations, as we use pygobject 2.90 now. This unbreaks a lot of Gio API.
    Add a Breaks: to older pygobject versions.

 -- Martin Pitt <email address hidden> Thu, 18 Aug 2011 18:24:54 +0200

Changed in gobject-introspection (Ubuntu):
status: In Progress → Fix Released
Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Released
Alin Andrei (nilarimogard) wrote :

Hmmm it's not fixed for me.

Anders Kaseorg (andersk) wrote :

Yeah, it broke again in gnome-shell 3.1.90, but for a different reason: the default keybinding for the run dialog got cleared for some reason. See bug 845653.

Happens to me, too. Running gnome shell 3.2.0-0ubuntu1. Every command returns "command not found", even "r" or "rt".

Anders Kaseorg (andersk) wrote :

I can’t reproduce with gnome-shell 3.2.0-0ubuntu1. I suggest opening a new report by running ‘apport-bug gnome-shell’. If anything relevant shows up in ~/.xsession-errors when you use Alt+F2, include that in the report.

Ok, I've deleted all configuration files in my home folder. Now it works fine. Seems as if some settings where wrong/broke alt+f2. So, if anyone is still suffering with this bug, try to reset your configs.

thefuzz4 (jason-hamilton) wrote :

I can confirm that blowing away my configuration files does resolve the Alt-F2 problem.

Jeremy Bicha (jbicha) wrote :

You don't need to delete all of your configurations, just the ~/.gconf/apps/metacity/global_keybindings

Any way, the original bug report was fixed months ago; the Metacity bug is bug 856884 so please direct further discussion to that bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.