[FFe] Do not activate spread view on first boot

Bug #1940925 reported by Jean-Baptiste Lallement
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Wishlist
Daniel van Vugt
gnome-shell-extension-ubuntu-dock (Ubuntu)
Wishlist
Daniel van Vugt

Bug Description

On first boot the spread view shows the first boot wizard and it looks really weird. Moreover if you click on the right workspace the wizard is not displayed.

The spread view should be disabled and the wizard should be displayed full screen immediately.

ProblemType: Bug
DistroRelease: Ubuntu 21.10
Package: gnome-shell 40.2-1ubuntu1
ProcVersionSignature: Ubuntu 5.13.0-14.14-generic 5.13.1
Uname: Linux 5.13.0-14-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu68
Architecture: amd64
CasperMD5CheckResult: unknown
CurrentDesktop: ubuntu:GNOME
Date: Tue Aug 24 12:41:16 2021
DisplayManager: gdm3
InstallationDate: Installed on 2020-05-31 (450 days ago)
InstallationMedia: Ubuntu 20.10 "Groovy Gorilla" - Alpha amd64 (20200527)
RelatedPackageVersions: mutter-common 40.2.1-1ubuntu1
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
description: updated
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
Changed in gnome-shell (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
Changed in gnome-shell (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Daniel van Vugt (vanvugt) wrote (last edit ):

I should note we can't do this unconditionally because that would break the GNOME dock. It should only be done if Ubuntu Dock is loaded.

Changed in gnome-shell (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: Triaged → In Progress
Changed in gnome-shell (Ubuntu):
status: Triaged → In Progress
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks Daniel! I tested it successfully via this PPA:

https://launchpad.net/~gunnarhj/+archive/ubuntu/gnome-shell

and merged the gnome-shell MR.

Needless to say I'm inclined to upload, but I have a feeling that this requires a freeze exception. So I subscribed ~ubuntu-release. You could of course argue that this doesn't add a feature but rather removes one. Not sure that everyone would agree, though. ;)

summary: - Do not activate spread view on first boot
+ [FFe] Do not activate spread view on first boot
Changed in gnome-shell (Ubuntu):
status: In Progress → New
Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: In Progress → New
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: New → Confirmed
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

I talked with Brian Murray in the release team on IRC. He would like to see some +1 from more desktop members before approving this from a release team POV.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Committed
Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Quoting from https://wiki.ubuntu.com/FreezeExceptionProcess :

"The bug should be set to status of "New" when requesting a freeze exception, to ensure the release team sees the request."

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

No problem. In hindsight that was the wrong task. Let me fix it...

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: In Progress → New
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

If there was a way to set a status for upstream tasks then I would say:

  Ubuntu Dock = In progress

due to this pull request into the ubuntu-dock branch:

  https://github.com/micheleg/dash-to-dock/pull/1512

Revision history for this message
Olivier Tilloy (osomon) wrote :

WRT comment #10, +1 from me.

Revision history for this message
J-P Nurmi (jpnurmi) wrote :

+1 from me too.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: New → Confirmed
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

@Brian: Besides the '+1's above, Jean-Baptiste (member of the Canonical desktop team) pointed out that he is the bug reporter — aka implicit +1 :) — and Sebastien blessed the change on IRC:

https://irclogs.ubuntu.com/2021/08/26/%23ubuntu-desktop.html#t12:01

Revision history for this message
Brian Murray (brian-murray) wrote :

This looks good to me, feel free to upload the relevant packages. Thanks!

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell-extension-ubuntu-dock - 70~ubuntu2

---------------
gnome-shell-extension-ubuntu-dock (70~ubuntu2) impish; urgency=medium

  [ Daniel van Vugt ]
  * extension: Disable starting in the overview
    - We don't need it when the GNOME dash is being replaced.
    - Applied upstream PR #1512 (LP: #1940925).

 -- Gunnar Hjalmarsson <email address hidden> Thu, 26 Aug 2021 20:04:01 +0200

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 40.2-1ubuntu6

---------------
gnome-shell (40.2-1ubuntu6) impish; urgency=medium

  * d/rules:
    - Drop dh_translations workaround. gettext used by LP has been
      updated (LP: #1756547).
    - Fix Lintian warning about DEB_HOST_ARCH assignment

gnome-shell (40.2-1ubuntu5) impish; urgency=medium

  * Fix translation issues (LP: #1941954):
    - Really fix translation import problem as reported in LP: #1756547
    - Add libgtk-3-bin to Build-Depends for dh_translations

gnome-shell (40.2-1ubuntu4) impish; urgency=medium

  * debian/rules:
    - Skip tests when building for ppc64el to fix FTBFS (LP: #1941792)

gnome-shell (40.2-1ubuntu3) impish; urgency=medium

  [ Daniel van Vugt ]
  * Add layout-Make-starting-in-the-overview-optional.patch:
    - So that extensions like Ubuntu Dock have the option of preventing
      the shell starting in the overview. (LP: #1940925)

gnome-shell (40.2-1ubuntu2) impish; urgency=medium

  [ Daniel van Vugt ]
  * Add workspace-Remove-skip-taskbar-windows-while-the-over.patch to stop the
    desktop icons window appearing like an app window in the overview on
    startup (LP: #1936643)

 -- Gunnar Hjalmarsson <email address hidden> Wed, 01 Sep 2021 15:44:38 +0200

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers