Update gnome-shell to 3.32.2

Bug #1834517 reported by Iain Lane on 2019-06-27
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Medium
Unassigned
Disco
Medium
Marco Trevisan (Treviño)

Bug Description

[ Description ]

The second stable release in the 3.32 series.

[ QA ]

Run Ubuntu session, expect the shell to work normally with various setups

https://wiki.ubuntu.com/StableReleaseUpdates/GNOME

[ Regresison potential ]

Mostly crash fixes, possibly regression in the menus popping ups, images textures aspect ratio, Network interface names, world-clocks in calendar, dialog texts, widgets style change

[ Related bugs ]

https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1722886
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1834517
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1831555
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1827953
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1809788

Iain Lane (laney) on 2019-06-27
Changed in gnome-shell (Ubuntu):
status: New → Fix Released
Changed in gnome-shell (Ubuntu Disco):
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)

(Removed the ref to the apport hook as that is covered in bug #1722886)

summary: - Update to 3.32.2
+ Update to 3.32.2 [includes changes to Apport hook]
summary: - Update to 3.32.2 [includes changes to Apport hook]
+ Update to 3.32.2
summary: - Update to 3.32.2
+ Update gnome-shell to 3.32.2
description: updated
Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
Changed in gnome-shell (Ubuntu Disco):
importance: Undecided → Medium
description: updated
description: updated

Hello Iain, or anyone else affected,

Accepted gnome-shell into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.32.2-2ubuntu1~ubuntu19.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-shell (Ubuntu Disco):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-disco

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of gnome-shell from disco-proposed was performed and bug 1835420 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed-disco" tag from this bug report and add the tag "bot-stop-nagging" to bug 1835420 (not this bug). Thanks!

tags: added: verification-failed-disco
Steve Langasek (vorlon) wrote :

This SRU has now been removed from -proposed due to the failed verification. However, the referenced regression looks like it has been root-caused to mutter rather than gnome-shell, so it's possible this SRU is actually ok to release (possibly only after a fixed mutter has been uploaded). If so, please comment on this bug with the appropriate details and ask an SRU team member on IRC to resurrect this package.

Yes, GNOME shell 3.32.2 is not strictly dependent on the mutter 3.32.2 snpashot (3.32.2+git20190626-1ubuntu1~19.04.1) nor 3.32.2 as the changes included are just fixes not depending on mutter itself.

These are the changes involved:
 https://gitlab.gnome.org/GNOME/gnome-shell/compare/3.32.1...3.32.2

So, while mutter should not upgraded, gnome-shell can safely be resurrected.

Adam Conrad (adconrad) wrote :

Copied gnome-shell back into disco-proposed, per the above comment.

tags: removed: verification-failed-disco
tags: added: verification-done verification-done-disco
removed: verification-needed verification-needed-disco

The verification of the Stable Release Update for gnome-shell has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :
Download full text (6.9 KiB)

This bug was fixed in the package gnome-shell - 3.32.2-2ubuntu1~ubuntu19.04.1

---------------
gnome-shell (3.32.2-2ubuntu1~ubuntu19.04.1) disco; urgency=medium

  * No-change SRU backport from eoan to disco. (LP: #1834517)

gnome-shell (3.32.2-2ubuntu1) eoan; urgency=medium

  * Merge with Debian. Remaining changes:
    + Replace gnome-backgrounds dep with ubuntu-wallpapers and Suggests
      gnome-themes-standard-data, gnome-backgrounds
    + Add some Recommends:
      - ubuntu-session (| gnome-session) to have the ubuntu session available
      - xserver-xorg-legacy
      - yaru-theme-gnome-shell for the default ubuntu theming
    + Update debian/gbp.conf with Ubuntu settings
    + gnome-shell-common.install: Install Ubuntu mode
    + gnome-shell-common.prerm: Remove deprecated ubuntu theme alternative
    + ubuntu/desktop_detect.patch:
      - add caching for desktop detection to avoid querying the current
        desktop env variable as iterate through the list each time. For the
        time of the Shell process, we can expect this env variable to stay
        stable.
    + ubuntu/smarter_alt_tab.patch:
      - quick alt-tab (without showing up the switcher) switch only between
        the last window of the last 2 applications to be focused instead of
        raising all windows of those apps.
    + ubuntu/lightdm-user-switching.patch:
      - Allow user switching when using LightDM.
    + ubuntu/lock_on_suspend.patch
      - Respect Ubuntu's lock-on-suspend setting.
    + ubuntu/gdm.patch
      - as gdm is system-wide and not session-wide, ensure gdm has an ubuntu
        styling by default, not impacting the gnome user session though.
    + ubuntu/background_login.patch
      - Change default background color as we modified the default GDM color
        for our ubuntu session. Change it as well here, still applying the
        background noise loading.
    + ubuntu/gdm_alternatives.patch
      - Add support for GDM3 theme alternatives
    + ubuntu/block_mode_extension_update.patch
      - Don't allow ubuntu mode extension to update
    + optional-hot-corner.patch
      - enable patch proposed by upstream developer already in package (but
        not in series) to add a settings for optional hot corner activation.
    + volume-Add-back-sound-feedback-on-scroll.patch
      - Fix regression causing missing feedback on volume slider scroll
    + main-show-an-error-message-on-gnome-shell-crash.patch,
      global-make-possible-to-set-debug-flags-dynamically.patch,
      main-increase-the-granularity-of-backtraces-in-SHELL_DEBU.patch,
      main-add-backtrace-crashes-all-and-backtrace-all.patch,
      sessionMode-add-support-for-debugFlags-parameter.patch:
      - Improve debug JS tracing for crash reports
    + st-scroll-view-Handle-the-case-where-scrollbars-are-NULL.patch,
      st-scroll-view-Remove-scrollbars-references-on-dispose.patch:
      - Fix crash on theme changes
    + ubuntu/search-call-XUbuntuCancel-method-on-providers-when-no-dat.patch:
      - stop searches when requested from UI
    + magnifier-Show-cursor-when-magnifier-is-enabled-and-scale.patch:
      - Show monitor scaled cursor when magnifier is enabled

gnome-shell ...

Read more...

Changed in gnome-shell (Ubuntu Disco):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers